FORUMS: list search recent posts

Can't import or convert .mp4 Files

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Matt Tureck
Can't import or convert .mp4 Files
on Jan 25, 2011 at 8:49:32 pm

Hey folks,
I've had issues dealing with a few video files I've gotten as handouts at press conferences.
Both were named as .mp4 files, under "get info" they're in a h264 AAC codec.

When I import it into FCP and try to play it, I get an error message saying "General Error", and then "Error, Out of Memory"

The file plays fine in Quicktime, but when I try to export it into a new format, it gives me an error message saying, "movie contains an incorrect time value"

It also plays fine in Streamclip, but when I try and export to a new format, it gives me an "Error, can't prepare movie: message.

I'm running a top of the line mac with all the latest operating systems and updates.
Thanks..any ideas?


Return to posts index

Olin Padilla
Re: Can't import or convert .mp4 Files
on Jan 25, 2011 at 8:58:47 pm

Try doing it from MPEG Streamclip as a batch. Probably won't help though.

It sounds like your files might be corrupt. Usually in this situation I will panic a little, then try every possible transcoding tool I have. Something will eventually work.


Return to posts index

Brian DeViteri
Re: Can't import or convert .mp4 Files
on Jan 25, 2011 at 11:11:10 pm

- Have you installed Perian?
- Have you tried VLC?
- What's the origin of the MP4? Client compressions, DSLR footage, or something else?
- Can you export just the video in one pass and then just the audio in a separate pass?
- Is the file corrupted at all?
- Are you able to try on a Windows machine to convert to anything?

Few options...
Try opening with a program like Adobe After Effects and render into a new file format/codec. This may or may not work, depending on the file and the nature of the issue.

If the file PLAYS fine in QT and other programs, last resort would be to do a live streaming capture of your computer screen of the file playing and then trying to work with that capture (such as iShowU).


Does MediaInfo show any additional information about the file? (http://mediainfo.massanti.com/)



Return to posts index


Rafael Amador
Re: Can't import or convert .mp4 Files
on Jan 25, 2011 at 11:23:04 pm

Hi Matt,
MP4 are not supported by FC.
What is strange is that you can play (so the codec is available) but no export those clips from QT or MPGStreamclip (Perhaps some protection?).

I would try something with QT Player:
- Open a clip and open the Clip Properties (Cmd-J).
- Click Video Track > Click Extract
- Clip Audio Track > Clip Extract.

Now you have both tracks isolated in two QT windows.
- Click the Audio Track and "Select All" (Cmd-A) and Copy (Cmd-C).
- Click on the Video Track window.
- In the Edit menu, select "Add to Movie" (Cmd-Alt-V).
Save the Movie.
This should work. I hope you have no much footage to process this way.
rafael

-

http://www.nagavideo.com


Return to posts index

Burk Finley
Re: Can't import or convert .mp4 Files
on Jun 22, 2013 at 4:55:03 pm

Update June 2013 -- I just came across the same issue with a screen record to MP4 with AAC 48k audio. Played in QT and MPEG Streamclip just fine, but could not for the life of me cut the clip or export as anything else!

Tried Rafael's process, worked like a charm.

Thanks Rafael -- very helpful trick.

Burk


Return to posts index

Jenni Nelson
Re: Can't import or convert .mp4 Files
on Nov 5, 2011 at 10:44:06 pm

I am having this exact same problem as you described. Did you ever find a solution? I have a quick turnover project and have already spent hours trying to get to the bottom of this.

Thanks!


Return to posts index


Jennifer Conner
Re: Can't import or convert .mp4 Files
on Dec 20, 2013 at 8:14:17 pm

I know this is an old thread, but in case anyone else out there is stuck, I think I've figured out a free way to do it. I uploaded the original .mp4's shot on an Android phone to YouTube. I then downloaded them. They're still .mp4's, but for some reason, FCP (I'm on 6.0.2) happily accepted them.


Return to posts index

Monica Peña
Re: Can't import or convert .mp4 Files
on Oct 13, 2014 at 7:07:35 pm

It just happened to me. A friend told me a solution, and it worked. In this case, the first frame of the clip was corrupt and that is why it would't play. The solution is import the mp4 to FCP and make a new sequence. Drag the file to it. FCP will say "general error" but you will be able to continue. Cut the first frame, again it will say "general error". Render the clip from the timeline and it will work well. It happens to me with Videoblocks mp4 clips

Monica Peña


Return to posts index

Octavio Warnock-Graham
Re: Can't import or convert .mp4 Files
on Apr 20, 2015 at 2:43:50 pm
Last Edited By Octavio Warnock-Graham on Apr 20, 2015 at 3:21:41 pm

I also had the same problem. Here is another solution that works quite nicely but requires QT Player 7.

TL;DR Use QT Player 7 to trim the first frames of the mp4 file and export with codec of choice.

Step-by-step Instructions

Open the mp4 file in QT Player 7. Move your playhead a few frames forward and set an in point. (Shortcut key = i) Then move your playhead to the last frame and set your out point. (Shortcut key = o). Then "trim to selection" (Edit/trim to selection).

After you have trimmed the selection, Export the file (Command-E) and under the export settings pick your codec of choice.

Easy Peezy Lemon Squeezy.

Cheers,
Octavio


Return to posts index


Alicia Victoria Palacios Thomas
Re: Can't import or convert .mp4 Files
on May 21, 2015 at 4:20:16 pm

Hi! This is what worked for me:

-Open .mp4 file with After Effects
- Export as a Premiere Project

-Open Premiere Project in Premiere and go to File> Export> Media
- Choose video settings (I recommend exporting the highest quality as possible)

After that you will be able to open and export the file in MPEG Streamclip.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]