FORUMS: list search recent posts

import with alpha cause wrong field order

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
anders bundgaard
import with alpha cause wrong field order
on Jan 4, 2011 at 2:13:46 pm

hello,

i've supplied graphics with an alpha channel to a fcp editor. when this is imported i shows that the clip has a field order of upper. the quicktime is without field order and using the animation codec. i've double checked my after effects setting and imported again but still doing it. is this a bug in fcp or are they incorrectly imported... is there a way of changing the default so this does not happen...?

thanks
anders


Return to posts index

walter biscardi
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 2:37:35 pm

[anders bundgaard] "i've supplied graphics with an alpha channel to a fcp editor. when this is imported i shows that the clip has a field order of upper. the quicktime is without field order and using the animation codec. i've double checked my after effects setting and imported again but still doing it. is this a bug in fcp or are they incorrectly imported... is there a way of changing the default so this does not happen...?"

Are you rendering to the exact specifications of their timeline? Such as they are working in a 720p / 59.94 ProRes timeline so you are supplying them with a 720p / 59.94 Animation file?

Are they working in an Interlaced project such as 1080i / 29.97? If so, then you need to provide an interlaced clip.

Walter Biscardi, Jr.
Editor, Colorist, Director, Writer, Consultant, Author, Chef.
HD Post and Production
Biscardi Creative Media

"Foul Water, Fiery Serpent" Winner, Best Documentary, LA Reel Film Festival...

Blog Twitter Facebook


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 2:48:52 pm

the gfx is rendered to the same specs as the timeline. but that shouldn't really make any difference as when you look at the info on the clip in the bin it's listed as having an upper field dominance when the actual file has not....

i'm not a fcp user so if my terminology is wrong, please accept my apologies.

anders


Return to posts index


Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 3:05:53 pm

If you in fact rendered without fields, simply have the editor change the setting to none and it will be fine.


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 3:09:38 pm

they were done without fields.
the editor did actually figure out how to do this.

the main issue is that they've done a bunch of tv spots and they have only now noticed that it was interpreted wrong and they have to import everything again and change it in all the timelines...

is there a way of forcing fcp to import them correctly?


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 4:03:17 pm

Use ProRes 4x4 which has a field order metadata flag.

You can also use the weird utility Dumpster to modify the field flag.

http://forums.creativecow.net/readpost/8/1032788

Really, this falls on the editor to be mindful of these things.


Return to posts index


anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 4:08:40 pm

thanks for this i'll check the dumpster out.

does prores 4444 support alpha channels?


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 4:13:18 pm

ah dumpster is an old app and can't run on my system without rosetta (is that OS9...).

any other way to manipulate quicktime files in that way?


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 4:23:52 pm

Absolutely ProRes 4x4 supports alphas. The last 4 is the Alpha. Highly recommended to move away from the larger animation files. 4x4 will play better in real time in fcp as well.


Return to posts index


anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 4:30:31 pm

i think i looked into this a while back. is it still the case that you can't buy that codec from apple?


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 4:33:52 pm

You must purchase FCP7


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 4:37:35 pm

thought so. that's a lot of money for a codec (as i've got no use for the rest of the package)...


Return to posts index


Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 4:53:52 pm

If you know someone with FCP7, they can temporarily give you the codec. That's all I'm going to say about that one.

Jeremy


Return to posts index

Dave LaRonde
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 4:46:40 pm

[anders bundgaard] "is it still the case that you can't buy that codec from apple?"

It was the last time I checked, which was about 6 weeks ago. To my knowledge, ProRes 4444 is available only on machines running FCP 7.

It sounds like you may be right back where you began in this thread, rendering to the Animation codec. If your editor specifies Quicktime movies, you may have no other choice.

However, you might ask if the editor will accept PNG sequences. They're lossless, they support alpha channels, they have far greater bit depth than ProRes 4444, and they're easily converted to the editor's quicktime codec of choice using QT Pro.

I run FCP on a Mac Pro at work, and I occasionally do After Effects work at home on Windows machine. I render out to PNG sequences in AE. I find that even though PNG sequence file sizes are astoundingly large, a reasonably-long shot can easily fit on a flash drive, and is easily converted to an editing codec when I get to work.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 5:20:55 pm

lots of ways around it, but it doesn't really solve the initial problem that the stuff is not imported correctly ;-)

is this a well know issue with animation codec and fcp?


Return to posts index


Dave LaRonde
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 5:32:56 pm

[anders bundgaard] "is this a well know issue with animation codec and fcp?"

It typically is if:

1) the editor doesn't have a video monitor, and relies only on the FCP viewers, thus giving the editor an inaccurate view of image quality... or

2) the video needs rendering and it hasn't been rendered yet.... or

3) the editor is using an FCP edit timeline that can't accurately reproduce high-quality motion graphics, such as DV or HDV

I render PNG sequences out of AE simply because I have absolutely no access to ProRes 4444 on my Windows machine at home. If I edit in an 8-bit edit timeline at work, such as DVCPro 50, the Animation codec is just fine.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 5:35:35 pm

Anders, what format/frame rate?


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 6:18:55 pm

animation codec either 23.97x or 24.


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 6:40:33 pm

[anders bundgaard] "animation codec either 23.97x or 24."

And that's coming in as upper field first? Wow.

Ok, let's take it back a second. You are rendering out of AE? Are you absolutely sure field rendering is turned off?


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 8:14:22 pm

yes out of after effects and without field...


Return to posts index

Dave LaRonde
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 6:42:03 pm

[anders bundgaard] "...either 23.97x or 24..."

If your work needs to be frame-accurate, they can't do that to you. It can't be one or the other. Insist that they give you the correct frame rate.

If you happen to be working in After Effects, the correct frame rate is absolutely crucial. Because FCP and many camera makers lie about the correct NTSC film frame rate, there is much confusion. They call it 23.98, which is not correct. It is 23.976 frames/sec, and you must work at that frame rate in After Effects.

Many people have mistakenly created 23.98 comps in AE, only to have trouble with the footage in FCP. I guess they expected Apple to tell the truth.

What if they tell you to work at 24? Work at 24, and hope they know what they're doing.

In either case, you shouldn't have to worry about field order -- don't render with fields. Since both 23.976 and 24 are progressive-scan frame rates, they ultimately won't contain fields, and the worst the editor will have to do is render in FCP. It isn't a big deal.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 8:16:44 pm

sorry the 23.x or 24 was me not remembering what it was. i know that it's very important to match frame rates, been i too many nightmare situations to forget ;-)


Return to posts index

Dave LaRonde
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 8:28:42 pm

Well, then, if the following conditions are true after rendering in AE:
  • The frame rate is correct
  • The horizontal & vertical resolution is correct
  • The pixel aspect ratio is correct
  • The type of alpha channel (Straight/Premultipled) is correct
  • The field order (None) is correct

You've done all you can do, and it's up to the editor to get his/her act together. This would include using a proper codec for successful FCP editing, which is beyond your control.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 8:32:08 pm

And FCP will usually mark the field order correctly when a movie is 23.976 fps or 24.0.

Any chance you can render a small one second test, zip it, and upload it here? It could be anything, just black is fine.

Jeremy


Return to posts index

Rafael Amador
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 5:01:15 pm

[Jeremy Garchow] "Absolutely ProRes 4x4 supports alphas. The last 4 is the Alpha. Highly recommended to move away from the larger animation files. 4x4 will play better in real time in fcp as well."
But lets don't forget that a Prores 444 file from AE (10b RGB), once in FC is crunched to 8b RGB.
This, at least. the picture. NO sure if the 10b Alpha channel survives or get crunched too.
So the only advantage of Prores 444 over Animation is the field order flag.
rafael

http://www.nagavideo.com


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 5:08:50 pm

This is simply not true, Rafa.


Return to posts index

Rafael Amador
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 5:41:54 pm

[Jeremy Garchow] "This is simply not true, Rafa."
Jeremy, you should know that FC can't process 10b RGB without the help of third part software (GlueTools, Cineform),.
FC RGB processing is limited to 8b.
rafael

http://www.nagavideo.com


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 4, 2011 at 5:51:43 pm

This is not the time andnplace for this discussion but when bring in a 444 movie to a 422 YUV timeline, I am not processing in RGB.

I can prove it, but it's not the time or place as it doesn't matter to Anders.


Return to posts index

Atticus Culver-Rease
Re: import with alpha cause wrong field order
on Jan 5, 2011 at 2:10:18 am

I was having this same problem recently... rendering either animation or ProRes 4444 out of AE and importing into FCP the field order in FCP would say upper every time, even though I was definitely rendering progressive (30p in my case) out of AE. The fix, as you discovered, was just to manually set the clips to "none" fields in FCP, but yeah, it's annoying to have to do it every time.

I don't recall having this happen until just recently, so my guess its some kind of issue that's popped up having to do with the latest update of FCP and/or AE CS5.


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 5, 2011 at 5:15:53 pm

[Atticus Culver-Rease] "I was having this same problem recently... rendering either animation or ProRes 4444 out of AE and importing into FCP the field order in FCP would say upper every time, "

This is because you haven't set the field order correctly in the QT dialog in AE and then saved it as an output module.

ProRes has a field order flag that can be set and it will be honored by FCP upon importing. In the QT dialog of the output module, make sure that the "Interlaced" box is not checked.

At least, that's how it works here.

Jeremy


Return to posts index

Dave LaRonde
Re: import with alpha cause wrong field order
on Jan 5, 2011 at 5:19:34 pm

Like Jeremy says.

And know that it's possible in AE to create your own custom Render Settings and Output Modules, which can then easily be set as the defaults. It makes the process of getting things out of AE a whole lot easier.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 5, 2011 at 5:25:12 pm

I should add that this metadata flag is not possible to add in the Animation codec. You have to modify it later, which can be tricky.

Geez, and one more thing, Dumpster works here on Intel, Snow Leopard.

Jeremy


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 5, 2011 at 6:08:11 pm

just done a render from another machine.
cs5 as well. no fields. animation codec. and it imported with a field dominance of 'none'.

plot thickens.


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 5, 2011 at 6:08:29 pm

just done a render from another machine.
cs5 as well. no fields. animation codec. and it imported with a field dominance of 'none'.

plot thickens.


Return to posts index

Atticus Culver-Rease
Re: import with alpha cause wrong field order
on Jan 6, 2011 at 2:59:39 am

Well actually I do have a custom output module for ProRes 4444, and if I open that up and go to "format options" and then "codec settings" the "interlaced" checkbox is NOT checked. I just re-checked and tested it again to be sure, and FCP still thinks it's upper field after import. I also made sure that field render in the AE render settings is turned off.


Return to posts index

Jeremy Garchow
Re: import with alpha cause wrong field order
on Jan 6, 2011 at 4:32:47 am

Yeah, not making much sense there. Any chance you can render, zip and upload that one second test?

Also, what version of FCP?


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 6, 2011 at 10:18:54 am

thanks to everyone who has tried to help on this issue. much appreciated.

it turns out that the initial work was done at 25fps (no fields) but fcp assumes that it's pal footage and automatically puts the field dominance to upper. we changed the fps to 24 and the same render settings imports in fcp as field dominance 'none'.

sorry for the wrong info to begin with (i as kinda helping someone else out and assumed that it was done at 24fps).

i'm sure you all know what they say.. "never assume as it makes..."

thanks
anders


Return to posts index

Dave LaRonde
Re: import with alpha cause wrong field order
on Jan 6, 2011 at 4:47:03 pm

[Atticus Culver-Rease] "...FCP still thinks it's upper field after import..."

Well, how does it look on your video monitor after you render it? And PLEASE say you're not relying on just the viewers in FCP to judge image quality....

It could also be that you need to trash FCP prefs, too.

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index

anders bundgaard
Re: import with alpha cause wrong field order
on Jan 6, 2011 at 4:52:31 pm

hi dave,

thanks for taking time to help out... we figured out what it was. i replied to a post here.

http://forums.creativecow.net/readpost/8/1116252

a


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]