FORUMS: list search recent posts

Can FCP 4 be used on a G5 quad?

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Oscar Bakker
Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 7:47:06 am

Hello

I've bought a FCP 4 version which I want to install on my G5 Quad machine. During installation everything seems to be fine (althought is seems only 100 mb of software, which is a bit weird from a 4.5 DVD). After installation is complete it returns with a comment that it is missing hardware, G4/350 mhz and AGP graphics card. The G5 pro quad is using PCIe bus and not an AGP.

I've searched the internet on this and ran into an article about this that you can remove this line in the Plist file. It seems to boot now, but only untill the audio drivers are loaded, than the software crashed.

Is it or is it not possible to use Final Cut Pro 4 on a G5 quad machine?

If not, what is the latest release which can be used?

Thanks



Return to posts index

Tom Wolsky
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 8:21:26 am

Just press the escape key when you get the error message.


All the best,

Tom

Class on Demand DVDs "Complete Training for FCP7," "Basic Training for FCS" and "Final Cut Express Made Easy"
Author: "Final Cut Pro 5 Editing Essentials" and "Final Cut Express 4 Editing Workshop"


Return to posts index

Oscar Bakker
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 8:43:24 am

That sounds a bit too easy!

The system only stops only with a force stop and the error list is enorm.



Return to posts index


Tom Wolsky
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 12:30:35 pm

I can't see your computer so I have no idea what this "The system only stops only with a force stop and the error list is enorm" means.




All the best,

Tom

Class on Demand DVDs "Complete Training for FCP7," "Basic Training for FCS" and "Final Cut Express Made Easy"
Author: "Final Cut Pro 5 Editing Essentials" and "Final Cut Express 4 Editing Workshop"


Return to posts index

Oscar Bakker
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 12:51:42 pm

I could make a screen dump from that.
But the only way to stop the software is to force the stop.

But straight forward, would it be possible to install and use it with a G5 and Mac OS 10.5.8 or not?


Return to posts index

Jeremy Garchow
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 1:05:33 pm

Why not get a newer version of FCP?

Fcp 4 is 7 years old.


Return to posts index


Oscar Bakker
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 1:11:01 pm

I'm not sure if I wrote this but I'm a 'starter' with Apple Mac and video edit. It's a money issue cause I also moved to HD.

If I like FCP I will in the end move to a later release. What is the last release I can use on a G5 quad machine?


Return to posts index

Tom Wolsky
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 1:20:22 pm

What format of HD are you working in? FCP4 supports a very limited range of HD formats. It didn't even do HDV. I think it was only DVCPRO HD, but I may be wrong.


All the best,

Tom

Class on Demand DVDs "Complete Training for FCP7," "Basic Training for FCS" and "Final Cut Express Made Easy"
Author: "Final Cut Pro 5 Editing Essentials" and "Final Cut Express 4 Editing Workshop"


Return to posts index

Tom Wolsky
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 1:07:15 pm

Ah no. The problem is not the computer but the OS. The QuickTime version associated with the OS after 10.4.10 is too new for that version of FCP.


All the best,

Tom

Class on Demand DVDs "Complete Training for FCP7," "Basic Training for FCS" and "Final Cut Express Made Easy"
Author: "Final Cut Pro 5 Editing Essentials" and "Final Cut Express 4 Editing Workshop"


Return to posts index


Oscar Bakker
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 1:28:09 pm

Thanks!

The seller told me it is capable of doing HD. Is there any website which clearify this?

I use a JVC GZ-HD7 camera which does this strange TOD files, a lot has been written about that. But anyhow the output will be converted to MOV, MPEG or H.264.

But does FCP 4 handle this? reading your story probably not?!?



Return to posts index

Jeremy Garchow
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 1:38:07 pm

FCP 4 handled uncompressed HD. That's it.

Fcp 4.5 handled dvcpro hd and hdv support came in Fcp 5.1 ish.

I'd suggest at least final cut studio2.


Return to posts index

Oscar Bakker
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 2:15:16 pm

Sounds clear!

Will return to the seller and see what we can do.
Probably not possible to upgrade from FCP 4 to FCP studio 2.


Return to posts index


Jeremy Garchow
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 2:19:24 pm

[Oscar Bakker] "Probably not possible to upgrade from FCP 4 to FCP studio 2."

I don't see why it wouldn't be. Get your hands on an upgrade copy of FCS2 and you're all good.

Jeremy


Return to posts index

Tom Wolsky
Re: Can FCP 4 be used on a G5 quad?
on Jul 20, 2010 at 1:59:07 pm

This camera isn't supported by any version of FCP. You'd need to convert the media to another codec, however as Jeremy says this version just is not suitable for HD, especially not with this camera. Move up to FCP5 at least.

All the best,

Tom

Class on Demand DVDs "Complete Training for FCP7," "Basic Training for FCS" and "Final Cut Express Made Easy"
Author: "Final Cut Pro 5 Editing Essentials" and "Final Cut Express 4 Editing Workshop"


Return to posts index

Miodrag Ristic
Re: Can FCP 4 be used on a G5 quad?
on Jul 21, 2010 at 2:06:18 am

You couldn't pick up more inconvenient camera than that one... You might have better luck with
iMovie and the footage from that camera.

Mio


Return to posts index


Oscar Bakker
Re: Can FCP 4 be used on a G5 quad?
on Jul 21, 2010 at 6:42:16 am

Yes I know the camera is not one of the best, I found out afterwards!

But once it is converted to MOV or H.264 there is not so much wrong.

I want to have a running MAC now first before I will search for an other camera.

Can anyone tell me what the last release from Final Cut Pro or Studio is I can use on my G5 quad? It is been very confusing to be honest. It seems the G5 quad is a system built just before the change to Intel and with that all software is changed as well....




Return to posts index

Miodrag Ristic
Re: Can FCP 4 be used on a G5 quad?
on Jul 21, 2010 at 7:03:43 am

The last version, I believe Final Cut Studio 2:

Final Cut Studio 2 System Requirements

Minimum Requirements to Install All Final Cut Studio Applications

A Macintosh computer with a 1.25GHz or faster PowerPC G4, PowerPC G5, Intel Core Duo, or Intel Xeon processor
1GB of RAM
An AGP or PCI Express Quartz Extreme graphics card (Final Cut Studio is not compatible with integrated Intel graphics processors)
A display with 1024-by-768 resolution or higher
Mac OS X v10.4.9 or later
QuickTime 7.1.6 or later
A DVD drive for installation


Return to posts index

Oscar Bakker
Re: Can FCP 4 be used on a G5 quad?
on Jul 21, 2010 at 7:40:20 am

In other words, the latest release Final Cut Studio - Final Cut Pro 7 won't work?

Bit strange because the last Final Cut Express does work!


Return to posts index


Miodrag Ristic
Re: Can FCP 4 be used on a G5 quad?
on Jul 21, 2010 at 9:16:55 am

FC Express 4 was released in 2007 (wow, just another reminder about Apple's treatment of pro or if you wish semi pro users) and last G5 in 2006 so it's logical that they are compatible.

FCP 7 came out 2 and half years later and that's a looong time in this business.

Mio


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]