FORUMS: list search recent posts

24p and Cinema Tools

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
george lance
24p and Cinema Tools
on Apr 28, 2010 at 7:45:58 pm

Hello,

This is my first time posting but have benefited enormously from the sage advice here. I'm having a problem with interlaced fields when reverse telecine-ing 1080i 24p (normal; not advanced) footage from a HVX200. I've seen many similar posts but following the advice there has not quite solved my problems. For a variety of bad reasons, I have 24p footage that I want to edit on a 24p timeline for web delivery. The description below is a bit long-winded but I'm adding detail in the hopes of expediting helpful responses.

I've brought my HVX footage into FCP using Log and Transfer (without the remove advance pulldown checked--I understand that's for 24pA mode only). This yields 1080p30 footage that has 3 progressive frames followed by 2 interlaced frames (on both my computer monitor--yes viewing at 100%--and on my external monitor--viewed through an AJA card). In FCP, if I choose Remove Advance Pulldown from the Tools menu, it reformats the footage as 23.98fps but now I have 3 progressive frames and 1 interlace frame.

So, onto Compressor. Here, I've brought in my original sources files from my Capture Scratch folder into compressor. I checked the source files field dominance (always listed as progressive); then I convert to ProRes422 (not HQ; I've also tried 1080i60 to keep the compression the same), specify a frame rate of 23.976 in the video settings, turn on frame controls, and select reverse telecine under deinterlace. The result shows every frame now as interlaced.

So, onto Cinema Tools. Here, I cannot reverse telecine because of temporal compression (it lists the source file as 29.97fps, dvcpro hd 1080p30, normal with temporal--that seems odd to me).

I haven't given up though! Back to Compressor where I transcode everything to ProRes then back to Cinema Tools. Now, I can reverse telecine. Parking the playhead on my first interlaced frame, I then select CLIP-->Reverse Telecine and then select capture Field 1 - Field 2 and _BC_, conform to 23.98. This result again produces three progressive frames and 1 interlaced frame. If I repeat this again but uncheck "Standard Upper/Lower" then--AT LAST--I get progressive video.

Here's my question (since this can't possibly be the best workflow): where am I making a mis-step (besides not shooting 24pA)? Or mis-steps? As always, a major thanks in advance to any and all advice. This forum has been a treasure trove of information for me.


Return to posts index

Michael Sacci
Re: 24p and Cinema Tools
on Apr 28, 2010 at 9:17:46 pm

Did you try Frame Control>Reverse Telecine in Compressor, I should work, it is not just for pA. As long as it is working with single clips at a time it should figure out the cadence of the Telecine, Advanced is just a cleaner version.


Return to posts index

george lance
Re: 24p and Cinema Tools
on Apr 28, 2010 at 11:57:56 pm

Hi Michael,

Thanks for your quick reply. Unfortunately, I did try that (see paragraph 3 of my original post). Using compressor resulted in worse interlacing than the original clip (every frame was interlaced). I've had good luck with Compressor using 720p 24p footage but this particular footage (1080i 24p) has me stumped.


Return to posts index


Michael Sacci
Re: 24p and Cinema Tools
on Apr 29, 2010 at 1:57:33 am

Your settings confuse my,

Try this
Start with the ProRes 422 for Prog. material preset

change frame rate to Custom 23.976 (yes use that and not 23.98)
make sure Compressor: Interlace is not checked, hit okay.

The in turn on frame control and reverse tele.

just to a same section and hopefully it will be okay


Return to posts index

Matt Lyon
Re: 24p and Cinema Tools
on Apr 29, 2010 at 5:41:36 pm

The fact that you had to uncheck the "standard upper/lower" box suggests that something is funky with the field order/field dominance of your clip. Could you have flipped the dominance inadvertently during the transcoding process (the first one, not the reverse telecine step)?

It also sounds like Compressor can't automatically detect "non standard upper/lower" so maybe you are stuck using cinema tools.

IIRC, when you select the "remove pulldown" option in FCP, it will make use of whatever your last settings were in Cinema Tools. So you should find a setting in CT that works, then you can run a batch in FCP. HOWEVER, i believe FCP uses the FIRST frame of the clip as the "start point" for your A/B/C/D frame setting (as opposed to the "parked frame" system that CT uses). So, for the batch processing to work properly in fcp, EVERY clip has to start at the same point in the pulldown pattern. If your clips are all over the map in terms of cadence, you'll need to do them one at a time in CT.

I guess the best way to speed up the process would be to try to fix the "non standard upper/lower" issue so you could use Compressor and have it auto-detect the correct pulldown removal setting.

Hope this helps,

Matt Lyon
Editor
Toronto


Return to posts index

george lance
Re: 24p and Cinema Tools
on Apr 29, 2010 at 6:47:12 pm

Matt,

Thanks for your helpful suggestions. I agree something is definitely up with the cadence but just wanted to make sure there wasn't some obvious mis-step. Would there be any reason FCP would bring the material in wrong during Log and Transfer? At that initial ingest, it lists the clips as progressive (or no field dominance). Same in Compressor when I bring in the clips from the Capture Scratch folder.

Fortunately, the problem clips are for a short commercial spot and there really aren't that many unique shots that need reverse telecine. Moreover, the interlacing is consistent in every clip--3 progressive frames followed by 2 interlaced frames.

Still, I would like to be better informed on workflow so this problem doesn't repeat in a larger project. Thanks again.


Return to posts index


Matt Lyon
Re: 24p and Cinema Tools
on Apr 30, 2010 at 1:40:32 pm

Hi George, I don't really have any specific experience with the camera you are using, so I can only speculate about the field issues...

That being said, it does clearly sound like the computer is having interpretation issues, since the footage is definitely interlaced, yet always comes up as "progressive."

If you open a clip in Compressor, you can pull up the Inspector and look at the "native field dominance" setting. (Make sure to click on the clip thumbnail, so you are modifying the clip attributes, NOT the compression settings). You should be able to override the automatically selected setting (progressive, in this case). I'm not sure which is the correct setting to go with ("upper," I suspect -- but you should test both ways).

Hopefully after changing the field dominance setting, Compressor will properly remove the pulldown! Please let us know if you have any luck.

Matt Lyon
Editor
Toronto


Return to posts index

Doug Metz
Re: 24p and Cinema Tools
on Jul 27, 2012 at 12:02:15 am

Just ran into this Exact problem... here's what I did:

Ingest via FCP L&T - After ingest, files pretend to be 29.97 progressive, but have pulldown.
Bring DVCProHD files into Compressor - I'm transcoding to ProRes, too.
Check clip's A/V Attributes - change each file from Progressive to Top First.
Set up my preset as usual, with frame controls set to Reverse Telecine.

Presto! Nice, clean 23.976 progressive video.

YMMV

Doug

Doug Metz

Anode


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]