FORUMS: list search recent posts

Qmaster and virtual clusters on OS 10.4.11 will not behave

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Matt Lyon
Qmaster and virtual clusters on OS 10.4.11 will not behave
on Feb 19, 2010 at 5:50:12 pm

Hi all,

I hate to add to the already huge pile of posts about Qmaster :-) but I'm ready to throw in the towel with my virtual cluster setup on my home machine. It's worked in the past, but has always been unreliable. It would usually take about 20 minutes of resetting/pref cleaning/service relaunching/etc before finally working. This success would be short lived, because it would stop working after a few batches, or a reboot.

The past few weeks it stopped working altogether. Today I reinstalled Compressor/Qmaster from scratch hoping to clear the problems. Now my virtual cluster shows up immediately in Compressor, but as soon as I submit a job, "Qmasterd" crashes. Here's a snippet from the console log:
----------------------
crashdump[612]: compressord crashed
--
QmasterStatusMenu[385] *** CDOClient::connect2: CException [NSException raised by 'NSPortTimeoutException', reason = '[NSPortCoder sendBeforeTime:sendReplyPort:] timed out'], server [tcp://192.168.0.103:51110]
-----------------------------

I've tried pretty much ever 'HOW TO' on fixing compressor out there and I'm using the "Comressor Repair" app. It seems like this is an issue that goes beyond the qmaster libraries ... maybe 'Bonjour' is having issues? (I'm seeing a lot of 'mDNSResponder' errors too)

So should I just bite the bullet and finally upgrade to Leopard or Snow Leopard? Will that make virtual clusters less kludgy? Has anyone had similar issues with 10.4.11? Any tips are greatly appreciated!

Here's my full setup:

OS 10.4.11
FCP 6.06
Compressor 3.0.5
2 x 2 GHz Dual Core Intel Xeon
3 gigs RAM

Thanks,

Matt Lyon
Editor
Toronto


Return to posts index

Matt Lyon
Re: Qmaster and virtual clusters: fixed!
on Feb 20, 2010 at 12:27:31 am

Okay, in case anyone is interested, I seem to have fixed this:

I re-installed qmaster and compressor for a second time (as root user), with no luck, then again a third time as my "normal" login, again with no luck. But then I tried a different preset then the one I was using for testing and it worked! Turns out I was using a CBR mpeg2 preset that was causing qmaster to crash. I guess CBR encodes don't like job segmenting? So qmaster definitely needed a re-install, but my guess is it probably would have worked from the get-go if I had been using a different Compressor setting. And I'll avoid using virtual clusters if I want to do constant bit rate mpeg2 streams.

Hope this helps,

Matt Lyon
Editor
Toronto


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 CreativeCOW.net All Rights Reserved
[TOP]