FORUMS: list search recent posts

Share burn Blu-Ray seems to insist on dual layer blanks

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Jim Lukas
Share burn Blu-Ray seems to insist on dual layer blanks
on Jan 30, 2010 at 3:22:28 pm

FCP 7.01 seems to insist that I use BD DL (dual layer blu-ray disc) blanks. I have seen tutorials where if you have the Apple SuperDrive, you can burn blu-ray format (and I assume h.264) onto a DVD. But my bigger problem is that the Share output is so totally automatic that you can't specify if your target is DVD-5 or DVD-9 or BD or BD-DL. Unfortunately I have a BD burner, so it seems to just automatically assume I want to burn BD-DL at $10 a blank, instead of 25GB single layer BD at $2 a blank. Its just icky and weird that this seems poorly documented. I tried creating BD data files and running them through Toast but Toast got the audio completely out of sync. Should I be learning how to use compressor... anybody got a workflow for me? I guess what I want to do is burn single layer BD of a sequence.


Return to posts index

Greg Barringer
Re: Share burn Blu-Ray seems to insist on dual layer blanks
on Jan 30, 2010 at 4:53:07 pm

Maybe the file is too large for single layer BD. Have you tried "Send to Compressor" in the Share dialog box? Maybe setting more compression will fix it.


Return to posts index

Jim Lukas
Re: Share burn Blu-Ray seems to insist on dual layer blanks
on Jan 30, 2010 at 5:10:54 pm

I found http://discussions.apple.com/thread.jspa?messageID=10692365 which discusses some related problems and proposes a couple workarounds, like using Toast, or editing plist files. "Share" seems like a good idea, but it also seems to have some bugs, or its not as rosy as advertised, IMHO.


Return to posts index


Mike Raff
Re: Share burn Blu-Ray seems to insist on dual layer blanks
on Jan 30, 2010 at 6:28:26 pm

I have no personal experience with Blu-Ray, but a fair amount with using Compressor for authoring DVDs.

So, to answer your last question first, yes you should be learning how to use Compressor, if you are also working with DVD Studio Pro, as it will save you headaches later down the line. In fact, Compressor 3.5 has pre-sets for Blu-Ray (h.264) now, I believe.

(It's true that you can burn Blu-Ray on a SuperDrive, but I think you are limited to about 15 minutes of content.)

Perhaps you ought to study up on Compressor and then post your questions in the Compressor forum.

(By the way, how much content are you trying to burn to the disk? Is the problem that it's more than a single layer BD can hold? Maybe that's why it's asking about the dual layer disk? Maybe that's why it ought to be compressed?)

Hope that helps.



Return to posts index

Kevin Monahan
Re: Share burn Blu-Ray seems to insist on dual layer blanks
on Feb 1, 2010 at 6:40:51 am

I have burned over 100 discs with Share and Blu-ray (H.264 and AVCHD). I didn't experience the problem you described.

Kevin Monahan
60 Blu-ray Templates for Final Cut Studio 2009
http://www.fcpworld.com
Author - Motion Graphics and Effects in Final Cut Pro


Return to posts index

Jim Lukas
Re: Share burn Blu-Ray seems to insist on dual layer blanks
on Feb 3, 2010 at 1:31:22 pm

I don't know what you're doing right or what I'm doing wrong or what Apple is doing wrong. I am sitting here staring at the "Please insert the dual layer media to burn the disc 'Sequence 1-Blu-ray'" once again. I can see the two files in my output folder, the .264 file is 23.56 GB and the ac3 file is 178.6 MB. It rejected my single layer 25GB blank. I see this squarely in the FCP forum. Apple touts this as a feature of FCP 7. Their claimed feature says nothing about having to use Compressor or DVDSP (which I had to use to get even a DVD to burn, but of course does not support BD). Some people think the problem might be in Apple's Create Disc app. I downloaded BluStreak Burner but it didn't want to open any of my files and as far as I can tell its completely undocumented. Back to Create Disc a thread I found suggests...

"First of all, I learned from this thread:

http://discussions.apple.com/thread.jspa?messageID=10675016

that the Create Disc.app is located in /Library/Application Support/Apple Qmaster/Create Disc.app. You can just open it up like an application -- but don't do that yet.

When Compressor has finished making your .h264 and .ac3 files it writes out a file to the /private/var/tmp directory to tell Create Disc.app what to do. To see the directory, use the Finder's Go> Go to Folder... command and enter that path.

If you look around in there a bit, you'll see some files that have long hexadecimal names with the file extension .1cdvd. Those are what we're looking for. Despite the odd extension, they are Apple plist files. There are two ways to edit them: if you have XCode installed, you can select the file and run it with /Developer/Applications/Utilities/Property List Editor.app. That's safer, and I'll use it for describing the technique, but actually I used the second way: you can just open it with any text editor, such as TextEdit.app. Either way, you can see and edit items in the file.

The settings that are most relevant in the file are audioURL and videoURL -- if you're in Property List Editor.app, look under the 'media' tab. The files also have settings for your menus, etc. in them. If you have a bunch of these .1cdvd files, look through them to decide which one has the same settings as the disk you want to burn. Save it as a more sensible name, like sample.1cdvd.

Once you've saved it to a different name, you can actually edit the audioURL and videoURL to burn different .h264 and .ac3 files if you need to, by the way. I leave most other things alone, but see a caveat below about the discFormat setting.

OK, you're mostly done. Before we fire up Create Disc.app though, open up Activity Monitor (/Applications/Utilities/Activity Monitor.app). The only feedback you're going to get during this exercise is seeing what apps are consuming CPU time, so open it up first.

Now select your new sample.1cdvd file and choose Open With... > Other and select Create Disc.app as above (alternatively, if you're a shell sort of person, you can do 'open ...Create Disc.app sample.1cdvd").

If you've gotten the path to the files wrong, you'll get a reasonable error dialog telling you it couldn't find the media.

If everything is all set, nothing will happen. The only way you'll know it's working is that a process called BlurayEncodingServer or something like that will come to the top of the list in Activity Monitor.

What I found was crucial at this step is... don't do anything. Don't surf the internet, don't open up new apps, just leave your system alone. Especially don't insert, eject or otherwise change what storage is available. Create Disc seems to be quite fragile to those things, and that's probably why we're getting these bugs in the first place.

It does take some time to re-burn this way because it's having the re-multiplex the h264 and audio, but it's way faster than re-encoding the video. After the multiplex is done, it will ask for the media, or use the one you've previously inserted before running Create Disc.app (because after running Create Disc.app, you didn't do anything, right?).

The infinite loop about "This media cannot be used" happened for me one time. It seems to be related to the discFormat parameter. For what I was doing (BD-R single-layer) the correct discFormat seems to be "2". I don't know how it ever got changed since I always said I was burning to Blu-ray, but apparently that can get messed up. YMMV.

So, to summarize:
1. Look through the .1cdvd files in /private/var/tmp to find the one you want
2. Copy that file to a name you can remember
3. Open up Activity Monitor to watch your progress
4. Open the .1cdvd file with Create Disc.app
5. Don't do much with the system until the disc is burned

Sorry for the tech-y explanation, just passing along what I learned in hopes it may save some other folks some sleep! "


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]