FORUMS: list search recent posts

Apple compressor: 50p -> 50i no interlacing?

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Frederic Garnier
Apple compressor: 50p -> 50i no interlacing?
on Dec 30, 2009 at 10:28:06 pm

Hi,

I'm trying to convert a 50 frames-per-second file into a 50 fields-per-second DV file using Apple compressor. Problem is, I always get a 25 frames-per-second DV file (every 2nd original frame gets dropped, result is not interlaced). I already played with all the settings to no avail, as far as I can see.

Can somebody tell me the proper setting so that compressor makes proper 50 fields-per-second video out of 50 frames-per-second output?

Thanks!
Frederic


Return to posts index

Jeremy Garchow
Re: Apple compressor: 50p -> 50i no interlacing?
on Dec 30, 2009 at 11:14:39 pm

Is this 720p50 material?



Return to posts index

Dave LaRonde
Re: Apple compressor: 50p -> 50i no interlacing?
on Dec 30, 2009 at 11:15:11 pm

[Frederic Garnier] "I always get a 25 frames-per-second DV file (every 2nd original frame gets dropped, result is not interlaced)."

No, it IS interlaced. But because you started with progressive material, the two fields are virtually identical. The conversion is using the first of a pair of 50fps frames to create the two fields at 25fps. The question is, "Why is it doing that?"

Dave LaRonde
Sr. Promotion Producer
KCRG-TV (ABC) Cedar Rapids, IA


Return to posts index


Jeremy Garchow
Re: Apple compressor: 50p -> 50i no interlacing?
on Dec 30, 2009 at 11:18:43 pm

[Dave LaRonde] "But because you started with progressive material, the two fields are virtually identical."

Not if it's 720p50 or 1080p50. You can make traditional interlaced 25i from 50p material where every p frame gets mapped to an i field.

I imagine Frederic didn't setup Compressor to render lower first for DV PAL.

Jeremy


Return to posts index

Frederic Garnier
Re: Apple compressor: 50p -> 50i no interlacing?
on Dec 30, 2009 at 11:24:00 pm

Hi Jeremy,

source file is QT 1024x576, uncompressed, target is DV PAL 16:9.

You mentioned "setup Compressor to render lower first for DV PAL". I tried the setting "Field order: bottom field first", but it didn't gave me the expected result. I also set it to "progressive" and to "automatic" by clicking the gears to the right, but all tries resulted in said problems.

Thanks!


Return to posts index

Josh Olenslager
Re: Apple compressor: 50p -> 50i no interlacing?
on Dec 31, 2009 at 6:17:19 am

Unless I've been terribly misinformed (and incorrectly converting to PAL DV this whole time), field order should actually be upper first for PAL DV; I'm about 90% sure this is the case -- although it is true that NTSC DV is lower first.

By the way, what setting are you using in Compressor? The standard DV PAL template? And where is your final output headed, to DVD? Broadcast? It might be worthwhile to export using different codec/package than DV depending on where you intend to go. Plus, if you're actually trying to retain 50fps you'll probably need to set that up custom anyway under the video settings dialogue in your compressor setting.



Josh


Return to posts index


Frederic Garnier
Re: Apple compressor: 50p -> 50i no interlacing?
on Dec 31, 2009 at 9:29:07 am

yes I'm using the standard DV PAL template. My final output is to DV, which will then get played on a CRT TV.

I'm actually looking for those settings, but I can't find any inside Compressor.

If you're interested in tinkering with this problem, I've created a 1-second sample sequence:
http://rapidshare.com/files/328319235/sequence.mov.zip.html

And here are my settings:
Name: Back to DV
Description: -
File Extension: dv
Estimated file size: 10.48 GB/hour of source
Audio Encoder
16-bit Integer (Big Endian), Stereo (L R), 48.000 kHz
Video Encoder
Format: QT
Width: 720
Height: 576
Pixel aspect ratio: PAL CCIR 601 (16:9)
Crop: None
Padding: (L: 8, T: 0, R: 8, B: 0)
Frame rate: 25
Frame Controls Automatically selected:
Retiming: (Best) High quality Motion Compensated
Resize Filter: Statistical Prediction
Deinterlace Filter: Best (Motion Compensated)
Adaptive Details: On
Antialias: 0
Detail Level: 0
Field Output: Same as Source
Codec Type: DV - PAL
Multi-pass: Off, frame reorder: Off
Pixel depth: 32
Spatial quality: 50
Min. Spatial quality: 50
Key frame interval: 15
Temporal quality: 50
Min. temporal quality: 50

If you'll try it, you'll see that it's very difficult to get a DV stream with the info of all 50 fields (I didn't succeed).

Thanks!
Frederic


Return to posts index

Sean ONeil
Re: Apple compressor: 50p -> 50i no interlacing?
on Dec 31, 2009 at 11:16:13 am

I think it does this to encode faster. It segments Frame 1 into two fields, and then throws Frame 2 away into oblivion. Do you actually need a DV file or are you just trying to make a tape? If it's just to make a tape, you can probably make a 576p50 ProRes QT in Compressor, then bring it into FCP and output to tape. I bet that would work.

Sean


Return to posts index

Frederic Garnier
Re: Apple compressor: 50p -> 50i no interlacing?
on Dec 31, 2009 at 2:21:41 pm

Alright, found the answer. Strypes over at lafcpug.org gave me the solution: In the frame controls tab, I had to change the "output fields" to "lower first", then everything works fine :-)

http://www.lafcpug.org/phorum/read.php?17,246084,246105#msg-246105

Thanks and Cheers!


Return to posts index


Jeremy Garchow
Re: Apple compressor: 50p -> 50i no interlacing?
on Dec 31, 2009 at 4:01:48 pm

[Frederic Garnier] "source file is QT 1024x576, uncompressed, target is DV PAL 16:9."

Sorry, I meant Upper First not lower (thanks for the correction, Sean) but is this file truly 50p or is it 25p?

If it is 50p, then when in Compressor you need to bring up the movie properties and make sure that compressor is seeing the file as progressive. You can bring up the movie properties by single clicking on the large thumbnail once the movie is loaded in to compressor. My guess is that it's reading it as either lower or upper field first. Interpret the incoming movie to be progressive in Compressor, then in the frame controls tab change to upper field first there.

This will only work if is truly a 50p file. If it's a 25p file, then just keep it as p and it will layoff as 25psf to tape.

Jeremy


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]