FORUMS: list search recent posts

jl cooper fadermaster pro with final cut?

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
philipp hahn
jl cooper fadermaster pro with final cut?
on Nov 28, 2009 at 3:55:21 pm

I am trying to use my JLCooper FaderMaster Pro as a control surface in FCP 6.
None of the presets work; FCP only has "templates" for Mackie and Logic controllers.

Has anyone done this successfully?

Or, does anyone know where I can find the MIDI information that either the Mackie or Logic control surfaces send, so I can program the JLC to emulate them?

Or, does anyone know what MIDI information (channels, params, etc) FCP expects to receive from a control surface?

Thanks!


Return to posts index

Warren Eig
Re: jl cooper fadermaster pro with final cut?
on Nov 28, 2009 at 6:35:14 pm

Do you have the Audio fader window open in FCP? THat has to be open in order for my Mackie Pro Control to be recognized. Also when you add the control surface in FCP does your JL Cooper show up as a choice?

Warren Eig

O 310-470-0905


email: warren@babyboompictures.com

website: http://www.babyboompictures.com


http://www.babyboompictures.com/BabyBoomPictures/AFX.html

http://www.babyboompictures.com/BabyBoomPictures/KnitWits_Movie.html

http://www.imdb.com/name/nm0251670/


EDITING REEL: http://www.babyboompictures.com/BabyBoomPictures/Editing_Reel.html

TITLE DESIGN: http://www.babyboompictures.com/BabyBoomPictures/Titles_Reel.html



Return to posts index

philipp hahn
Re: jl cooper fadermaster pro with final cut?
on Nov 28, 2009 at 9:49:39 pm

thank you for your quick response!

i have the fcp-mixer window open.

when i set up "control surface" in fcp it shows my midi interface (which is a simple usb-midi cable) but not the fadermaster. i can set up the interface with mackie or logic control and i tried both.

the basic midi connection is working as the fadermaster works fine in avid. there is no other midi equipment connected.

i manually set up the fadermaster in "Audio Midi Setup". when i use the "Test Setup" function the connection midicable -> fadermaster works (the signal gets sent back because of the fadermaster's merge function). however, when i move a fader of the fadermaster, "audio midi setup" shows no reaction although the little light on my midicable indicates data being sent. should it? is that any relevant?

any ideas? thank you very much for your help!


Return to posts index


philipp hahn
UPDATE: jl cooper fadermaster pro with final cut?
on Nov 29, 2009 at 1:39:01 am


i got it er, ... sort of... working.

i setup the fadermaster in final cut via "Mackie Control" and programmed the faders to send pitchbend info (which is the midi-signal for the volume control in fcp) on channels 1-8 through the faders. according to my midi monitor app everything is fine and the pitchbend info gets sent properly (always).
now, in most cases in finalcut the faders don't do anything. the pitchbend infos get sent back and forth through the cable but in finalcut nothing happens.
but sometimes, when randomly switching back and forth between final cut, midi monitor and "Audio Midi Setup", suddenly fcp goes wild: the master volume (which is on channel 9 but does not get signals by the fadermaster) jumps randomly up and down and the channel 9 midi signal goes into some sort of feedback loop. BUT at the same time (and only then) suddenly the fadermaster has perfect control over all eight tracks and even the automation works perfectly well!
however, when i switch programs once more, or turn off automation in fcp, the charm is gone and final cut and the fadermaster sink back into their sullen disrespect for one another.

i didn't really manage to systematically reproduce this state of frenzy, it really seems to happen quite randomly and i'm not even sure wether it has really to do with switching programs.
the mergefunction on all faders is set to "off" but that actually doesn't seem to have much to do with it.
i'm running macos 10.5.8, final cut version 6.0.6.

any ideas?


Return to posts index

philipp hahn
SOLUTION: jl cooper fadermaster pro with final cut!
on Nov 29, 2009 at 7:37:11 pm

i got it working... :)




fadermaster pro for final cut pro:

- connect only the fadermaster's output to your midi interface (i.e. a midi-usb cable) since otherwise you'll have looping problems.
- switch into a p-bank (up/down)
- press "prog" until the fader-led is lit. now you program the faders by pressing and holding the buttons above the faders to define what controls you are changing while using the faders to select which faders and what values:
PARM: set all faders to pb (pitchbend)
CHAN: from right to left 1-8. you can also set the mastervolume which is transmitted on channel 9.
PARM#: irrelevant, set to 0
MIN: 0 (all faders)
MAX: 127 (all faders)
- now you want to solo tracks 1-8 with the buttons above the faders. read in the manual how to program buttons and set them to:
PARM: note
CHAN: 1
PARM#: from right to left 8-15
MIN: 0
MAX: 127

in finalcut, select tools/control surface and set up your device as "mackie control" connected to your midi interface.

enjoy. :)


some additional stuff:
- i didn't get the fadermasters touch-feature to work with final cut. since "touch" only works in the automation banks (which only permit control-infos) i used the open source app "MidiPipe" to translate the control- into pitchbend-infos and back which does sort of work... but finalcut behaves rather randomly and as you need to connect the midi-in on the fader master, i had problems with feddback looping too. i don't think it's impossible but i'm just too tired to figure it out this time... if anyone gets this working, please post!
- greatly helpful in the process is a little freeware app called "midi monitor" (http://www.snoize.com/MIDIMonitor/) which shows what is going in and out.
- forget about "Audi Midi Setup", doesn't seem to do anything.
- sometimes my fadermaster seemed to get confused...: reset by pressing and holding "down, null, up" while switching it on.



Return to posts index

Brian Murphy
Re: SOLUTION: jl cooper fadermaster pro with final cut!
on Jan 14, 2011 at 5:26:37 pm

Well first thanks for the post and the info, it works and with your post and the manual I am getting a grip on midi and how to set things up. I know this post is a year old but had to ask the question. I have no level meter action anymore when I use the JLCooper. The master level meters on are frozen and there is no action on the level meters on the audio mixer in FCP. The Fadermaster does control the pots and the levels go up and down but no metering.
Ideas?


Return to posts index


philipp hahn
Re: SOLUTION: jl cooper fadermaster pro with final cut!
on Jan 17, 2011 at 9:27:14 am

i'm currently without my setup and can not verify it but i do not think i had this problem... just a random guess: could it be you use some plugin that interferes with the mixer tool i.e. bigtime or likewiese?
good luck
philipp


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]