FORUMS: list search recent posts

serious xml issues

COW Forums : Apple Final Cut Pro Legacy

<< PREVIOUS   •   FAQ   •   VIEW ALL   •   PRINT   •   NEXT >>
Nate Hubbard
serious xml issues
on Oct 2, 2009 at 12:47:47 am

MacOS v10.5.8
MP 2 x 3 Ghz Quad-Core
8 Gb ram
2 xserves as meta-data controllers
All systems running Xsan 2 software
Fiber RAID Sans disks are 3rd party

Part 1 by Ben 8/20/09
Just want to report a pretty serious issue I’ve had with FCP 7.

First off, it seems to be connected to a project migration from 6.x to 7.0. So many of you may not be surprised there. It seems to be involving the way FC deals with meta-data between the two versions. So I highly suggest (as any community user would) that you start fresh projects in 7.0 if you’ve added a lot of custom meta data to your clips with XML tools.

Here’s the details:

We started a FCP 6.x project 2 weeks ago that was merely a collection of prores footage from our recent shoot. Certain meta-data fields, however, were not populated from within the bin structure in FCP, but in a 3rd party program that is able to use XML to add the clips (with metadata) to FCP. We used clipfinder, as part of the RED camera footage workflow. It’s actually a great pipeline that we’ve devised here to quickly organize a RED shoot for offline and online editing. So just imagine a bunch of prores clips in FCP with the scene and take field meta-data added not in FCP, but in clipfinder and then relinked to the prores dailes quicktimes in FCP. We had to use media manager to make the original R3D QT proxy clips with the metadata offline and then relink to the prores dailies made from RedCine. That’s how we synced the meta data from the RedCode codec clips to the ProRes codec clips.

At the end of the day, it’s still just a project with a bunch of Prores clips in there. That’s when we converted the project to FCP 7.0. At that point, FC would randomly rename my clips to the name of the sequence. The “f” key for matchback would not match back to anything, but move my timeline cursor to a different point in the cut and randomly select in/out points. If I tried to duplicate a cut, all clip names in the cut would change names, and the master clips in the bins would change names too – usually to the same name. It made iteration and organization impossible. I tried a few different tests to eliminate any footage on my end. I kept having the same problem. So we rebuilt the cut in FCP 6.x and had none of the issues. We also started a fresh FCP 7.0 project and put the files through the metadata sync process we had previously done in FCP 6.x. None of the issues have occurred since we started from scratch. Aside from my assistant having to re-sync dailies and meta data in a new project, we’re good to go now in FCP 7.0.

Part 2 by Nate the editor 10/01/09

I’ve been working on this project for a month and I’ve been beset with problems I can’t track down but here are a few of them.
sequence name change to the name of the clip which is cut in and all the clips in the cut are renamed the same as the incoming clip. I can’t Matchback these clips. When I select the clip in the browser, it carries the same name as seq.

when I duplicate some sequences, they are duplicated with the same name (with no copy). If I try to rename one, the other will also change. I have resorted to putting titles at the head of each seq to identify the version

I’m sure you can understand how frustrating editing in this environment is. Thanks in advance for your help!

Nate Hubbard



Nate Hubbard
310-345-1301
natehubz@mac.com
ACT fcp6


Return to posts index

David Heidelberger
Re: serious xml issues
on Oct 2, 2009 at 7:09:03 pm

Hi Nate.

There's a thread on this from September, which I largely ignored until it happened to us. We had an editor complaining of exactly the same thing, also on a project that originated in 6 (on a fresh install of Snow Leopard, for what it's worth). For logistical (unrelated to the bug) reasons, we had to take the project back into 6 with XML. I've been out of town all week so I'm not sure if that resolved anything.

We've been unable to resolve the sequence and clip renaming issue, but if you right click on the sequence in the browser window and say "Make Sequence Clips Independent," that does seem to resolve the match-frame issue.

Also, this is just a thought, but you could try exporting the project as an XML, try different versions (5, 4, and 3, maybe) and then re-import the XML into a new project. See if you lose any of your metadata (hopefully not, although I don't know what the version history is for the XMLs and what features are lost each version you go back) and whether that fixes the problem.

There are a couple annoying bugs in the otherwise very nice FCP 7, this being high on that list. Hopefully there's a 7.0.1 not too far away.

- David



Return to posts index

Matt Lyon
Re: serious xml issues
on Oct 3, 2009 at 3:55:32 pm

Hi Nate,

I wish I could offer more concrete advice, but I haven't experienced your issue directly. That being said, I have in the past dealt with troubleshooting integration issues between FCP and custom and/or 3rd party tools, so I feel your pain. Have you tried exporting a "bad" project via XML and comparing it to an XML from a "good" project? You can use an XML diff tool that might be able to shed some light on what syntax is different, which could offer clues as to what is causing the problems. Depending on what resources you have available (know any good shell script gurus?), you might be able to write a little program that could essentially do a "find and replace" in your xml to fix the bad tags. Having been through this process, I should warn you that it can be very time consuming to do all the iteration necessary to get a script working properly. Have you tried contacting the makers of "Clipfinder"? Maybe you could send them an xml and see if they could shed some light on the issue? Please keep us updated on whether you solve this issue! Hope this helps,

Matt Lyon
Editor
Toronto


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]