FORUMS: list search recent posts

Mac OS X version 10.5.8, processor 1.8 GHz PowerPC G5

COW Forums : Apple OS X

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
joe sullivan
Mac OS X version 10.5.8, processor 1.8 GHz PowerPC G5
on Sep 23, 2012 at 7:23:43 pm

Hello all,

I wonder if you can help please?

I have a Mac OS X version 10.5.8, processor 1.8 GHz PowerPC G5, Memory 2GB DDR SDRAM. I am currently using Safari 5.0.6 (5533.22.3) and Fire Fox 3.5.19.

These browsers are quite old now and Gmail is not supporting them any more and I am having problems browsing but mainly using this mail client.

I want to download the latest / more recent browsers that are compatible with my O.S & processor?

If someone could post / send me a link ? that would be great

I have tried:

fire fox: "Unfortunately the latest version of Firefox isn't compatible with your computer's operating system. Learn more."

Google Chrome: "Your operating system is not supported.
Google Chrome is available for Mac OS X 10.5 or later, Intel only"

Many thanks in advance

Best regards


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]