FORUMS: list search recent posts

RE:Map and 3ds Max 2014 (Set up Problem)

COW Forums : RE:Vision Effects

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Mitch ROsenberg
RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 3, 2014 at 11:33:07 pm

Dear Smart People,

I just bought Re:map for 3ds max 2014.

The set up guide for Re:Map utilizes 3ds max 2011 for guidance of modifying a specific shader folder.
My problem is that 2014 does not show that folder to be anywhere so I can't set up for a UV multi pass properly. Not finding what I'm looking for in either Mental Ray or VRay.

Any wisdom passed here would be very much appreciated.
Thanks! ~mitch

Below is said text from the set up for 3ds max 2011.

-Mentalray: In mentalray there is a dedicated map to create a uv pass. The problem is that from 3dsmax 2011 and later versions this map is hidden to user, to show again you need to find and edit “3ds max shaders” archive you can find in: C:\ProgramFiles\Autodesk\3dsMax2011\mentalimages\shaders_standard\mentalray\include

Open with notepad and put “#” in front of “hidden” just after gui “gui_max_base_UVGenerator” {


Return to posts index

Pierre Jasmin
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 3, 2014 at 11:38:43 pm

let me ask someone else (not a pro at it either)
and come up with proper instructions

Pierre



Return to posts index

Mitch ROsenberg
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 24, 2014 at 9:45:54 pm

Hi, I'm still not out of the woods with this issue.
Its been a couple weeks please.



Return to posts index


Pierre Jasmin
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 24, 2014 at 9:53:54 pm

I thought I did, don't know where my post went

Again: You need to use the path
C:\Program Files\Autodesk\3ds Max 2014\NVIDIA\...
instead

Pierre



Return to posts index

Mitch ROsenberg
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 24, 2014 at 10:13:51 pm

No worries mate.
This plugin will rock my world once we get it working.

Any documents I have on installing RE:Map takes me to the "include" folder.
There is a a bit of communication gap with installing RE:Map for 3ds Max 2014 and we are here to close that gap.
Below are screenshots within the "include" folder because I have no clear instruction of where to go from there. Also below is a paste from Eloi's site on installing meant for an older version of 3ds MAX.

Thanks Pierre!






From Eloi...
Exporting uv maps from 3ds max

So the setup in AE is very easy, but how we setup and render this uv’s inside 3dsmax? We need to know how to apply our material and setup the render, map our objects, how to and finally how we save this images, here we go!:

Render Setup and materials

We will look how to do this in mentalray and in vray with dedicated maps:

-Mentalray: In mentalray there is a dedicated map to create a uv pass. The problem is that from 3dsmax 2011 and later versions this map is hidden to user, to show again you need to find and edit “3ds max shaders” archive you can find in: C:\ProgramFiles\Autodesk\3dsMax2011\mentalimages\shaders_standard\mentalray\include

Open with notepad and put “#” in front of “hidden” just after gui “gui_max_base_UVGenerator” {



Return to posts index

Pierre Jasmin
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 24, 2014 at 10:24:33 pm

You don't install RE:Map for 3DS Max
You install it for AE or Fusion or Nuke...

The instructions are for exporting a UV pass out of mental ray (making it visible in Max UI)

Pierre



Return to posts index


Mitch ROsenberg
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 24, 2014 at 10:48:51 pm

Yes. Thanks for the correction. What I want to say is that.

I am trying to find the Shader to edit in the "include" folder.
Currently I have no UVgenerator in my Material Editor in 3ds until we find and edit that Shader.
Until I'm resolved I can't do a UVPass snap shot from Mental Ray that I can bring into AE.

By all means correct me if I'm wrong. Just want to solve this.

Thanks!



Return to posts index

Pierre Jasmin
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 25, 2014 at 3:52:10 am

I asked my friend at Autodesk, more when I get an answer

Pierre



Return to posts index

Mitch ROsenberg
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 25, 2014 at 2:34:16 pm

Appreciate it. Standing by...



Return to posts index


Pierre Jasmin
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 26, 2014 at 1:52:00 am

No news yet here, maybe you could cross post your question to the 3dsmax forum
http://forums.creativecow.net/autodesk3dsmax
It's more likely to be monitored by someone at Autodesk

Pierre



Return to posts index

Mitch ROsenberg
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 26, 2014 at 5:12:35 pm

OK I've posted there.
PLease chime in if there is anything about my wording that seems off in describing the problem.



Return to posts index

Pierre Jasmin
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 26, 2014 at 10:25:02 pm

Looks fine except you forgot the tidbit that the folder path in 2014 is now nVidia instead of Mental Images
(nVidia bought Mental Images, the maker of Mental Ray)
There is nothing under nVidia?

Pierre



Return to posts index


Mitch ROsenberg
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 28, 2014 at 3:42:16 pm

No. See my screen shots above that look in Nvidia.
Unless I'm looking in the wrong path?

Can't help but feel a bit frustrated here.
Don't you have a programmer or developer to keep your $150.00 software current?
I don't understand why this is so difficult.



Return to posts index

Pierre Jasmin
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Feb 28, 2014 at 9:05:09 pm

I posted the question in Autodesk area forum, hopefully someone will answer
http://forums.autodesk.com/t5/Shading-Lighting-and-Rendering/Creating-a-UV-...

Pierre



Return to posts index

Pierre Jasmin
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Mar 3, 2014 at 5:13:49 pm

And the answer is:

"

You can still unlock the "UV Generator" shader in mental ray.

You'll have to edit the "3dsmaxshaders.mi" file located @ C:\Program Files\Autodesk\3ds Max 2014\NVIDIA\shaders_standard\mentalray\include


Before you edit the file, make a backup in case you make a mistake.


With the file opened in Notepad search (Ctrl + F) for "UV" until you find the following text.


gui "gui_max_base_UVGenerator" { control "Global" "Global" ( "uiName" "UV Generator", "helpCHM" "max/max help.chm", "category" "Texture Space Mapping", "hidden"


Now just change the "hidden" to #"hidden" (just add the pound sign in front) and save the file.

Restart 3ds Max and in your mental ray shaders you'll now see the "UV Generator" appear.


To get this pass with your image make a separate a new Render Element called "mr Shader Element".

In this element you can add the "UV Generator" map to create a pass with your UV's.

Turn off filtering and "Apply Shadows" to get the correct result.

Also make sure you have your frame buffer set to 32-bit in the mental ray Renderer settings to get the full range in the Render Elements.

Since Max 2014 though, your render elements might not be outputting unfiltered data correctly when using Unified Sampling, so you'd be best off rendering a separate pass from a separate file.


Hope that helped,


M.

"



Return to posts index


Mitch ROsenberg
Re: RE:Map and 3ds Max 2014 (Set up Problem)
on Mar 5, 2014 at 11:29:52 pm

Awesome! There it is.

I would just add to your install notes that you can't edit in the root folder.
Copy/paste "3dsmaxshaders.mi" to another location, make your edit/save, then replace it back into the 'include folder'.

Thank you. Problem Solved.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]