FORUMS: list search recent posts

Workflow FCP FieldsKit - Twixtor

COW Forums : RE:Vision Effects

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Tom Kramer
Workflow FCP FieldsKit - Twixtor
on Nov 19, 2008 at 12:10:56 am

I've posted this before in an older threaad, but apparently nobody's reading it anymore, so I'll try again here..

OK, for me, FCP/FieldsKit/Twixtor workflow is a mystery. I went through the (very few) available tutorials, which mostly focus on using Twixtor in AE, which I do neither use nor know.

Still, I am already lost on the most basic question of fields. Basically, what I do is, in a full fledged timeline, remap some select clips via Twixtor.

For basic slomos on "easy" material (little movement, relatively stable, uniform backgrounds) I'd rather use Motion's Optical flow mode, which will give me OK results while rendering in the background, saving time and effort.

When I need to do ramped slomos, I use Twixtor. The trouble is, these clips tend to be on the difficult side of things: Fast movements in multiple direction, moving backgrounds, you name it.

So for better results, I want to use Fields:Kit Deinterlacer to properly deinterlace the footage first, then apply Twixtor. That's already where the trouble begins.

The original timeline and footage is interlaced DV (PAL).
So, as not to mess to much with my project timeline, I create a second timeline and copy the clip in there, pad it by comping it with at least one copy of the same clip, and put the deinterlacer on there. As I am looking at minimum 50% slomos, I set FieldsKit to 1 Frame per field, already yielding a 50% slomo. Am I correct so far?

So now I have got a progressive clip with a 50% slomo. Good. BUT: should this have happened in a sequence set to lower field, as the original footage and timeline is, or should I have used a no fields sequence?

Setting the sequence to interlaced will rather often give me some quirky in-between frames, a progressive sequence , while giving me crisp images both on the computer screen as on TV control monitor apparently just puts out doubled frames as in-betweens, resulting in a choppy slomo.... (fill method of course being set to anything other than DUPLICATE). So I stick with an interlaced sequence.

(Huhm, odd feeling there...)

So, let's assume I were happy with what I see, I would now apply Twixtor to that deinterlaced 50% comp (I do not even render it most of the time, cause with my equipment it takes forvever to do so). Or should I have quicktime-exported it first and twixtor the reimported, deinterlaced solid clip, this time in a progressive timeline?

Well, no idea. Anyhow, now I tweak and ramp it with twixtor (takes forever, the whole stuff being less than ideal material to create in-between frames from, but eventually way better results than I could ever get out of Motion).

In the end, I have a deinterlaced, ramped slomo in, well, an interlaced timeline, that I am gonna copy back to my original interlaced timeline.
(Actually, most of the time I export and reimport that thing as quicktime clip, so I do not have to re-render the slo-mo all the time when I do an opacity change, or add a filter or the like later.)
Still, it is a no fields-clip in lower fields timeline!

Reinterlace first? Or let FCP do that, which, apparently, it does, as I can see the slomo on the monitor, and it is not all bad...

So the final result, is, well, sometimes quite good, sometimes rather poor, and I am afraid something is very, VERY wrong with the workflow I came up with.

Stil, as I mentioned, using a progressive timeline results in strange slomos...

I believe that what I want to do with twixtor is nothing extraordinary, so I suppose somebody must have come up with a really smart workflow.... anyone? ....please?

Quite lost and grateful for any explanation on how to correctly use the Fields:Kit/Twixtor package in FCP,

Kramer





Return to posts index

Peter Litwinowicz
Re: Workflow FCP FieldsKit - Twixtor
on Nov 19, 2008 at 1:09:00 am

[Tom Kramer] "So, as not to mess to much with my project timeline, I create a second timeline and copy the clip in there, pad it by comping it with at least one copy of the same clip, and put the deinterlacer on there. As I am looking at minimum 50% slomos, I set FieldsKit to 1 Frame per field, already yielding a 50% slomo. Am I correct so far?"

yes, this sounds good.

[Tom Kramer] "Setting the sequence to interlaced will rather often give me some quirky in-between frames, a progressive sequence , while giving me crisp images both on the computer screen as on TV control monitor apparently just puts out doubled frames as in-betweens, resulting in a choppy slomo.... (fill method of course being set to anything other than DUPLICATE). So I stick with an interlaced sequence. "

You should be able to set the sequence to "none" as a field order setting, but I just tried that and it does indeed produce stuttery results (one field of each frame is deinterlaced and repeated, instead of each field being deinterlaced) . This is probably due to a bug introduced by FCP in some recent version that we simply have not caught. Sorry about that (a progressive sequence used to work just fine!)

[Tom Kramer] "So, let's assume I were happy with what I see, I would now apply Twixtor to that deinterlaced 50% comp (I do not even render it most of the time, cause with my equipment it takes forvever to do so). Or should I have quicktime-exported it first and twixtor the reimported, deinterlaced solid clip, this time in a progressive timeline? "

I would quicktime export the 50% slowed down sequence, so that as you place with Twixtor you don't have to have FCP recalculate the deinterlaced frames each time you change a Twixtor sequence. It may SEEM like it takes longer, but I'm not convinced it actually does in the long run.

Of course when you apply Twixtor, you'll want to make sure you mark the input as Progressive within the Twixtor settings.

Then, upon output, simply set the sequence settings (on the sequence that Twixtor is within) to progressive or "lower" or "Upper" as appropriate. If you want Twixtor to calculate 1 frame per field, set the sequence settings to lower or upper. If you want progressive output, set the sequence field settings to "None". Note that by setting the sequence settings to "lower" or "upper" you'll get 2x as many frames rendered by Twixtor to recreate each field.

Of course, since you've doubled the duration of your interlaced footage by using our Deinterlacer, then you'll need to factor that in to the percentages (or frame numbers) you use in Twixtor

Hopefully this helps answer your questions.
pete





Return to posts index

Tom Kramer
Re: Workflow FCP FieldsKit - Twixtor
on Nov 19, 2008 at 12:26:10 pm

First up, thanks a lot for your reply. It surely helped lifting some of my uncertainties.

[Peter Litwinowicz] "I would quicktime export the 50% slowed down sequence, so that as you place with Twixtor you don't have to have FCP recalculate the deinterlaced frames each time you change a Twixtor sequence. It may SEEM like it takes longer, but I'm not convinced it actually does in the long run.
"


That is probably the smart thing to do, so far I have just been to lazy to go through that extra step, and afraid to see my storage melt away... But apparently, my machine is faster rendering when it just has to do one thing at a time. Thanks..

However, I just tried the whole thing, and in doing so the issue of fields rose again.

So I want to export the DEINTERLACED (2xDuration, 1Frame per field) clip from a INTERLACED timeline to avoid that issue of stuttering/repeated frames. The clip's object settings after deinterlacing are stating that its field order is "UNDEFINED" (or "NOT SET" or whatever that is called in the English version of FCP, as opposed to "NONE").

Yet when I reimport the quicktime-exported clip to a PROGRESSIVE sequence, it is interpreted by FCP as LOWER FIRST, and a warning pops up stating that field orders do not match - which in fact both logically as well as actually they do: The clip plays back fine, no matter if I set the clip's field order to NONE or leave it set to LOWER.
Actually, it is OK from an INTERLACED timeline, too, no matter what the settings are(?)! Plus, no warning there.

So is FCP just unable to keep track of the actual field order of a clip? Or rather, why does it "care", when everything is in fact OK, but ignore the fact that field orders are not matching as long as everything is somehow defined as INTERLACED?

I also tried exporting/reimporting the clip after manually setting it's field order to NONE rather than UNDEFINED - same thing.

OK, this basically is a little confusing, but not my real problem, because up to this point I stick with the progressive workflow, as it seems more logical to me. Hopefully, it is also correct.

[Peter Litwinowicz] "Of course when you apply Twixtor, you'll want to make sure you mark the input as Progressive within the Twixtor settings.
"


I now apply Twixtor (Absolutely: Input Fields set to "None"). On a PROGRESSIVE CLIP. Set to PROGRESSIVE manually. In a PROGRESSIVE TIMELINE. Which all seems kind of sensible, at least to me...

However, the twixtored clip (DEINTERLACED, so far) has to go back to an INTERLACED timeline. What now?
Just plug it in there, and let FCP handle the reinterlacing upon the final output? Probably not, as you wrote:

[Peter Litwinowicz] "Then, upon output, simply set the sequence settings (on the sequence that Twixtor is within) to progressive or "lower" or "Upper" as appropriate."

So I EXPORT first as INTERLACED (i.e. from a sequnce set to interlaced), and put that copy in the interlaced timeline?

Or would it be even better to

EXPORT as progressive, REIMPORT to another INTERMEDIATE timeline (Interlaced? Progressive?) and reinterlace via FieldsKit, then export/reimport again (ewhh, fair bit of work...)?

Anyhow, thanks again for your clarification so far, but I must admit that I did not quite get this one:

[Peter Litwinowicz] "If you want Twixtor to calculate 1 frame per field, set the sequence settings to lower or upper. If you want progressive output, set the sequence field settings to "None". Note that by setting the sequence settings to "lower" or "upper" you'll get 2x as many frames rendered by Twixtor to recreate each field. "

There should not be any fields in an already deinterlaced clip, right? Do you mean that TWIXTOR does create different speeds, depending on output field order? I could not recreate that: The same Twixtor clip from a progressive as well as an interlaced timeline is the same duration and file size, at least on my computer. Or did you refer to the settings within the FieldsKit deinterlacer? I am confused...

Well, maybe I'm just making to much of a fuss about all this, as FCP apparently does not care too much about about fields as long as the initial deinterlacing is done in an interlaced timeline. But I will have to do 40+ Twixtor SloMos on my project, so I really would like to know what I am doing beforehand rather than end up finding out something was crooked with my workflow when the whole thing is finished... and have to do it all over.

I am really sorry for being so lengthy, but hopefully it helps in trying to understand what my problem is...

(BTW, I am using FCP 6.0.4 on a slowish PowerMac G5 2.7 Dual running OS 10.5.5.)


Any reply greatly appreciated, have a great day,

Tom






Whoops, One last thing, uhm, getting some some blackish noise in the first few lines of the deinterlaced clip is quite common, right? I mean, it'll be cropped away on a TV, but it looks kind of nasty on a computer screen...










Rendering - the only breaks I somehow can't appreciate....


Return to posts index


Peter Litwinowicz
Re: Workflow FCP FieldsKit - Twixtor
on Nov 20, 2008 at 11:39:20 pm

[Tom Kramer] "et when I reimport the quicktime-exported clip to a PROGRESSIVE sequence, it is interpreted by FCP as LOWER FIRST, and a warning pops up stating that field orders do not match - which in fact both logically as well as actually they do: The clip plays back fine, no matter if I set the clip's field order to NONE or leave it set to LOWER.
Actually, it is OK from an INTERLACED timeline, too, no matter what the settings are(?)! Plus, no warning there.
"


As you said you did, I would suggest after you reimport your deinterlaced clip which is erroneously labeled Lower First, I would suggest manually setting the the Item Property for the FIeld Order of clip to "None" before placing into a sequence. You can do that by right-clicking (or control-clicking if you have a one-button mouse) on the clip in the bin, then choosing the "Item Properties...-> Format" menu item in the context-sensitive menu that pops up. THen right-click (or control-click) on Lower Field in the Field Dominance row and change it to "None".
[Tom Kramer] "However, the twixtored clip (DEINTERLACED, so far) has to go back to an INTERLACED timeline. What now?
Just plug it in there, and let FCP handle the reinterlacing upon the final output? Probably not, as you wrote: "


Well, what I would do if you want deinterlaced out is to put the progressive clip in into a interlaced timeline (the timeline where you have Twixtor!). That way Twixtor can figure out that it is creating interlaced output (because it reads the sequence settings) and does the proper thing to create inbetween fields. If you don't need inbetweened fields and just need progressive footage displayed in your interlaced output, then what you suggest you did works fine.

[Tom Kramer] "There should not be any fields in an already deinterlaced clip, right? Do you mean that TWIXTOR does create different speeds, depending on output field order"

No, it doesn't create different speeds, it just creates inbetweens for each field if the output field order is set to something other than progressive, and doesn't create the inbetween fields if the output field order is set to None. Does this makes sense?

Pete





Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]