FORUMS: list search recent posts

Strange halo on border on transparent swf !

COW Forums : RE:Vision Effects

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Magicaldog
Strange halo on border on transparent swf !
on Nov 20, 2007 at 1:25:15 am

Hi there I have been working with After Effects for a couple of weeks now so I guess you can say im a beginner.

I am trying to do a morph between two images with RE:Flex.

As I understand it this is the method to use for creating really cool interfaces like the ones on this site http://www.derbauer.de/index1.htmlor thishttp://www.carpe-diem-studios.de

Can anyone explain why I get a brown halo or stroke on the transparent border of the exported swf?

I managed to remove it but then I found out that I've lost the transparency and got a black background instead.

All help will be greatly appreciated.

Thank you!

My little experimental morph looks like this:
http://www.studiobergman.com/ae03.html


Return to posts index

Pierre Jasmin
Re: Strange halo on border on transparent swf !
on Nov 20, 2007 at 2:51:34 am


Looks good except you say there should not be a brown outline

Do you see that in AE or only when you export the SWF?

I don't think that this is introduced by RE:Flex

IF you see this in AE THEN:
I am not 100% on your source pictures are generated (are you making the source images in AE or importing that),
if you apply AE Matte | Simple Choker over and under 0.0
Does the outline go away in one case and does it grow in the other case.

Pierre


Return to posts index

Magicaldog
Re: Strange halo on border on transparent swf !
on Nov 20, 2007 at 10:28:50 am

Hi Pierre and thanks a million for your fast reply!

It looks perfect in AE but not in the exported swf.
I made the images in Photoshop and saved as png24 and have also tried with tiff and png8.

I managed to lose the brown border with the Keylight effect but at the same time the transparence was replaced with black!

This is driving me nuts!

I will try the simple choker later today.

Thanks again Pierre.


Return to posts index


Magicaldog
Re: Strange halo on border on transparent swf !
on Nov 20, 2007 at 9:13:02 pm

Pierre

Now I have tried the Simple Choker.
A value of around +5 seems to work best.

I also did one with AE's solids (green thing) and that shows clearly brown stuff on the edges?

http://www.studiobergman.com/ae04.html

Thank you!


Return to posts index

Pierre Jasmin
Re: Strange halo on border on transparent swf !
on Nov 20, 2007 at 9:20:14 pm


Wonder where that brown stuff comes from?
Is your comp background color brown (try black)
Looks like a bug in the swf export related to premultiply, unmultiply if you ask me
If you send me a project to techsupport@revisionfx.com I can look at it and submit the bug to Adobe if you like

Pierre


Return to posts index

Magicaldog
Re: Strange halo on border on transparent swf !
on Nov 20, 2007 at 11:55:26 pm

The background 'is' black and I tried to use only solids with some animated opacity and when you set it lower than 100% the brown appears? So its clearly not coming from ReFlex.

Ill send it to you so you can have a look at it.
If you look at the swf, it stops at opacity 50% where you can clearly see the brown!

It looks as if the background indeed was brown but it is not.

I just really hope I've missed something basic that you may have overlooked so I can get down and get creative instead of just trying to find out whats going wrong.

Thanks!


Return to posts index


Pierre Jasmin
Re: Strange halo on border on transparent swf !
on Nov 21, 2007 at 5:14:50 am


Thanks for sending project
The brown seems to come from the shape stroke color even if it's set to size 0
Maybe it helps if you set stroke transparency to 0%?

Pierre


Return to posts index

Magicaldog
Re: Strange halo on border on transparent swf !
on Nov 21, 2007 at 9:06:46 am

If you export the project to swf do you also get the same "brown" result?

I havent experimented with stroke transparency, where is that control? (Im at work at the moment)

Could it be my graphic card that generate the brown when rendering the swf?

Thanks!



Return to posts index

Pierre Jasmin
Re: Strange halo on border on transparent swf !
on Nov 21, 2007 at 5:35:09 pm


I see that brown color in the Stroke Controls if you twirl up Ellipse - that's all I see for now as where that could be coming from


Return to posts index


Pierre Jasmin
Re: Strange halo on border on transparent swf !
on Nov 21, 2007 at 6:26:25 pm


It's not that, I see if I render that it blends to brown whatever the setup when you have transparency.
I sent your test project to ae bugs to see what they say

Pierre


Return to posts index

Magicaldog
Re: Strange halo on border on transparent swf !
on Nov 22, 2007 at 9:51:06 am

Pierre

Well it feels good to hear that im not the only one on the planet who have this issue.

Lets hope they can fix this bug soon so that I can get creative and forget about the brown stroke thing.

Thanks Pierre You've made my day!



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]