FORUMS: list search recent posts

Particular - Need advice with Textured Polygons

COW Forums : Trapcode

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Joe Derone
Particular - Need advice with Textured Polygons
on May 29, 2010 at 2:14:50 pm

Hi!

I am trying to make an animation kind of like a slide show, but I am using Particular for the following effect:

Pictures fly in from a central vanishing point, then fly past the camera, spreading out on the x and y axis.

I managed to get this set up with Particular - I set up an emitter that shoots particles at the camera and particles are drifting right and left, up and down.

The Pictures for the polygon textures are taken from a picture composition, where each Image is on a layer, one keyframe long and they are sequenced.

In Particular, I set the texture to "Random - Still Image".

All works great, however I have one problem - I would like the images in the picture composition to appear in the original sequence, NOT in a random sequence. Each particle should hold 1 image, each following particle should hold the next image in the sequence.

Is there ANY way to do this? I have tried everything but am at the end of my rope.

Thanks!!
Joe


Return to posts index

Mike Park
Re: Particular - Need advice with Textured Polygons
on May 29, 2010 at 6:08:56 pm

Yes, there is a way to do this, kinda......

Since you are talking about textured polys, I assume you have Particular 2. Instead of making your time sampling "Random - Still Frame", change it to "Current Frame - Freeze". Then set your particles per second to the fps of your comp. So, if you are using a comp rate of 29.97, set you particles per second to 29.97 also. Now, you will have exactly one particle emitting per frame. The limitation is that you cant slow down the birth rate of the particles, so here is the work around. Name this comp, Particle Precomp. Then, move you slider to the last frame where the particles have all flown off screen and hit "n" on the keyboard and then right click in the timeline and choose trim comp to work area.
Next, drop this comp into a new comp and then choose "Layer, Time stretch." Now, set your comp lenght to whatever length you want your final comp, and adjust you final comp with the Particular precomp in it. Now, if necessary, adjust the velocity of the particle in the precomp to get the right look. The velocities will be much slower since you slowed down time significantly in the Final Comp.

I hope this makes sense. I would love to have an option for emitting particles in order based on a precomp, but until that is a direct option, this is the best, and only way I know of at present. If you have any questions, let me know.

Best,

Mike Park


Return to posts index

Joe Derone
Re: Particular - Need advice with Textured Polygons
on May 29, 2010 at 9:16:37 pm

First of all - thank you very much for the fast and very helpful reply!!

I was actually thinking about the Current Frame - freeze option but I couldn't work out how to really make it work with the emitter rate - your way seems a workable option - thank you so much!

I will try it this way.

Again, thanks for the help!


Return to posts index


Joe Derone
Re: Particular - Need advice with Textured Polygons
on May 30, 2010 at 9:05:29 am

I tried the method - I have a picture source composition with the single-framed pictures, which has 54 frames and it runs at 24 fps (everything in the composition runs at 24 fps).

I set the emitter to 24 particles per second (I made a new emitter and started fresh) - I then added a camera and moved it far back, cranked the velocity up (to minimize the overlapping of pictures since they are emitted faster) - also I need a high velocity, otherwise the pictures do not drift along the X and Y axis enough (point emitter).
One of the problems now was, that starting from about frame 8 (in the non-time stretched comp), there are "double pictures" - i.e. he takes the same frame twice. I have checked all the fps - they are all at 24.
I had to set the emitter to 23.9 - now it works - with 54 pictures, the drift on this should not come into effect.

But even with high velocity, the pictures still overlap quite a bit, in the time-stretched comp as well - any ideas? Also, is it possible to control the x and y drift directly? I have looked a long time through the options but so far, Z velocity is the only thing I have found but it is inaccurate.

With a light emitter (that I was using before - cone angle helped drifting along x and y), I was so far unable to match it to the correct emitter rate of 23.9.

Again, thanks in advance!
Joe


Return to posts index

Joe Derone
Solved
on May 30, 2010 at 7:25:18 pm

Ok this may sound silly to post after my previous post - but I worked it out.

I used a higher velocity and a larger distance to the camera as well as a spherical field which sits straight on the camera with a radius that extends to the emitter. Also, a lot of fiddling with all the parameters until it worked.

This way, the Pictures spread a bit more to the side (or go faster as the approach the sides.

Again, thank you so very much for your workaround!!
Joe


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]