FORUMS: list search recent posts

Shaders Unassigning Themselves in MAYA 2012

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Eddie Gali
Shaders Unassigning Themselves in MAYA 2012
on Jun 14, 2012 at 8:53:29 pm

Hey folks,

So we're working in MAYA 2012 and the mia shaders we have applied to the models are disappearing after reopening saved scenes, on random render layers seemingly without rhyme or reason. Has anyone ever experienced this before?

Thanks in advance!

- Eddie G


Return to posts index

Steve Sayer
Re: Shaders Unassigning Themselves in MAYA 2012
on Jun 15, 2012 at 3:37:08 pm

This is a known, giant, horrible, heartache-causing, deadline-ruining, bug.

There is a script to correct it which sometimes works:

http://mayastation.typepad.com/maya-station/2009/12/connection-errors-when-...

A couple of techniques to try to prevent this from happening:

1. Never assign shader overrides to different faces on different layers. E.g. if you assign a shader to one face of a cube on Layer A, then assign an override shader to the whole object on Layer B, this will cause errors.

2. Always save your scene with the Master Layer as the current layer. Don't save with any other render layer selected as current; if you do, you run the risk of the shaders being disconnected on file load.

There's lots more info out there on this; keep searching if you want to know more.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]