FORUMS: list search recent posts

Textures display white in viewport but renders normal

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Patrick Frischknecht
Textures display white in viewport but renders normal
on Oct 12, 2011 at 10:47:07 am

Hi,

So i've googled around but haven't found anything related to my issue. There was a previous post where the solution was to lower the pixel count of the texture however my issue is by simply using a lambert texture with checkerboard (preset) so that i can get an idea on how my UV's are so before i start making blend shapes. But i tried deleting and restarting all my uv sets as it got a bit messy and now my model with textures on only displays white.

I have done the following.
Updated all Graphics Cards Firmware (Nvidia GT 120 & ATI RADEON HD 5880)
Deleted preferences for Maya.

Does anyone have any ideas as a solution?
Thanks in advance,

Patrick.


Return to posts index

Jules Bodenstein
Re: Textures display white in viewport but renders normal
on Oct 13, 2011 at 11:24:35 am

Hi Patrick,
I’ve had this problem before, so I know how annoying it is! I found a solution to it, but can’t be certain it’ll work for you. Just so you know, I’ve only seen it when importing an object from another program (in this case 3ds Max). Although I’m fairly certain it’s a corrupt UV set that’s the cause, so you might get it from a poly made in Maya.

This solution is quite fiddly, so if there’s another solution I’d live to know about it!

1. Duplicate the object in question.
2. Create a new mesh, a cube will do.
3. Combine the original object with the cube.
4. Delete the current UV set on the object-cube.
5. Create a new UV set (planar will do fine) for the object-cube mesh.
6. Select faces, then delete the cube faces of the object-cube (at this point you should see the texture now, not just white.
7. Now “Mesh - Transfer Attributes” the UV’s from the duplicate to the original object. (this is to keep the UV’s you may have). I used the settings – all off except. “UV Sets” Current. Sample space “Component”

Hope this helps!

Jules Bodenstein

Render-It
mjb@render-it.co.uk
http://www.render-it.co.uk


Return to posts index

Dylan John
Re: Textures display white in viewport but renders normal
on Sep 13, 2014 at 2:14:00 am

1. Right click on the Object that has gone turned white.
2. Right-click and go to 'Object Properties'.
3. Uncheck 'Vertex Channel Display" under 'Display Properties"
4. (Optional) Go to your 'Material Editor' and reassign the material to your object.

Keep this here for future references please.
Good Luck!


Return to posts index


Camilo Argüello
Re: Textures display white in viewport but renders normal
on Mar 20, 2015 at 8:34:04 pm

Sorry man, but I have Maya 2015 and I can't find "Vertex Channel Display" :(

is it in attribute editor too ? o where?

thanks!


Return to posts index

Dylan John
Re: Textures display white in viewport but renders normal
on Mar 22, 2015 at 12:44:04 am

Sorry, that was actually for 3ds max, the same idea should apply for maya it just may be labeled differently,
see what resources you can find online, i could possibly mention this, even though it may be for a different issue.
http://knowledge.autodesk.com/support/maya-lt/learn-explore/caas/CloudHelp/...
http://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/clo...


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]