FORUMS: list search recent posts

Camera render shows no lights/environment

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Igor Harmendani
Camera render shows no lights/environment
on Aug 12, 2011 at 6:36:45 pm

Hello! I'm having a little problem with rendering through camera. The rendering through persp view works fine, with all lights and environment.

capturarcopy.jpg

But, when I render through the camera, I can't get the lights and the rest of the environment.

cameraproblemcopy.jpg

I need the camera because I'm rendering a sort of animation. Not really a animation, it's more like a normal camera shot.

How can I solve it? Thanks


Return to posts index

Igor Harmendani
Re: Camera render shows no lights/environment
on Aug 13, 2011 at 11:12:08 pm

May I ask...

Is there any way to use the persp camera as a default camera, do animations, keyframming and stuff?


Return to posts index

Steve Sayer
Re: Camera render shows no lights/environment
on Aug 15, 2011 at 2:21:36 pm

Yes, you can use the persp camera just like any other. It can be keyframed as normal.

However, you should be able to get your other camera working... let me ask you about the lighting in your scene. Are you using any kind of indirect lighting based on the environment, like Final Gathering or IBL? My guess is that you have some kind of lighting environment which is connected to your persp camera but not to your render camera. If you change those connections you should get the results you want.

Post again if you're unsure of how to do this, or if that's not the real problem.

-Steve


Return to posts index


Igor Harmendani
Re: Camera render shows no lights/environment
on Aug 17, 2011 at 3:19:06 pm

Thanks for replying!

I didn't saw any connectios between lights and persp, but I'm just a beginner, so I maya have missed something. But I managed to use lights in the camera and I already rendered the work.

I was using a direct light, and I tried to keyframe the persp camera but I couldn't =(

How can I keyframe the persp camera?

Again, thanks for the reply.


Return to posts index

Steve Sayer
Re: Camera render shows no lights/environment
on Aug 18, 2011 at 2:06:41 pm

Hi, Igor. My question wasn't about direct light sources, but indirect. Indirect lighting calculations can use things like the camera's background colour to affect the look of the scene.

It looks to me like you created a background environment for the persp camera, but not for the render camera. You can check this by going to the 'Environment' section of the two cameras and seeing if something is mapped there.

As for keyframing the persp camera, just select it and use the usual keyframing methods: shift-W, shift-E, shift-R, or right-click in the channel box, or whatever.

Also, I don't know whether it was intentional or not, but you wrote "I'm just a beginner so I maya have missed something," and that made me laugh. :)

-Steve


Return to posts index

Igor Harmendani
Re: Camera render shows no lights/environment
on Aug 18, 2011 at 5:44:25 pm

I don't know if I did it right, but I clicked on the camera, showed its atributes, then clicked on "Evironment". There's a "shader" thing and I couldn't change the background fot it. Also there was a Light shader.

All I did was using the Physical Sun and Sky from the mental ray render settings menu.

And that phrase, it wasn't intentional. Actually, I just saw it because you talked about it. Funny, indeed lololololol


Return to posts index



Steve Sayer
Re: Camera render shows no lights/environment
on Aug 18, 2011 at 5:56:09 pm

Yeah, the problem is most likely that you created your render camera after creating the physical sun/sky. It doesn't know about the new camera.

Select the mia_physicalSky1 node and click the 'update camera connections' button, and it should work with your new camera, too.

-Steve


Return to posts index

Igor Harmendani
Re: Camera render shows no lights/environment
on Aug 19, 2011 at 6:40:53 pm

It worked!!! It was right this problem. I'm sure that I created my camera after I created the physical sky/sun.

Thank you for the advice!!!


Return to posts index

Miloš Milovanović
Re: Camera render shows no lights/environment
on Feb 22, 2014 at 12:28:14 am

Thank you :)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]