FORUMS: list search recent posts

rendering pass problems

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
ken marvel
rendering pass problems
on Apr 3, 2011 at 10:40:20 pm

hi im new to maya and trying my best to get past obstacles when i can but this one is a road block , if any one could help it would be nice. i have to render passes, one is for pfx (paint trees ) the other ,polygon rigged figure, i have the figure masked in the layer with a surface shader but it overlaps in the final render and sticks out a bit.


Return to posts index

Stuart Christensen
Re: rendering pass problems
on Apr 6, 2011 at 7:16:56 pm

Just wondering why you are using a mask/shader, it's probably not a good way to texture the surface. Need more information!


Return to posts index

ken marvel
Re: rendering pass problems
on Apr 6, 2011 at 8:59:28 pm

Hi Stuart,thanks for responding. ive watched your tutorials on youtube ,they're great.your vids were the first place i looked. still, i'm going nutso right now rendering multiple passes which i can't find a solution for.paint effects trees with maya software and a polygon character with mental ray aren't playing nice together.i followed the 2009 maya foundation guide but being a novice i don't quite know the best way to render the scene in passes, the book explained to place a shader over the character as a silhouette, which almost worked but alas artifacts. if you can help im greatful and all ears


Return to posts index


Steve Sayer
Re: rendering pass problems
on Apr 6, 2011 at 11:12:30 pm

Hello, Ken.

It looks to me like you're having a problem with the difference between Maya's and mental ray's interpretations of smoothed polygons.

When you select a poly mesh in the viewport and hit the '3' key on your keyboard, you get a smoothed version of it. Mental ray actually respects this smoothed preview, and renders it--but Maya software doesn't. So there is a mismatch between the two layers.

Try actually applying a Smooth node to the character instead of pressing the '3' key. In fact, after you add the smooth node, you should press '1' to go to the unsmoothed version--otherwise mental ray will render out a smoothed-then-smoothed-again version.

Hope that helps.

-Steve


Return to posts index

ken marvel
Re: rendering pass problems
on Apr 7, 2011 at 1:32:09 am

Thanks Steve , when i have a chance to explore that i will my dead line is too tight , but maybe you could help with another instead. when i animate its very slow and my creatures eyes fly out in the playblast even though they are bound- ken


Return to posts index

ken marvel
Re: rendering pass problems
on Apr 7, 2011 at 2:18:30 am

Thanks Steve , when i have a chance to explore that i will my dead line is too tight , but maybe you could help with another instead. when i animate its very slow and my creatures eyes fly out in the playblast even though they are bound linked to the skeleton


Return to posts index


Steve Sayer
Re: rendering pass problems
on Apr 7, 2011 at 4:33:37 pm

The smooth poly is a very quick fix; no matter how tight your deadline you should give it a try, because if I'm correct (of course I might not be) it will instantly solve your masking issue.

As for the eyeballs, I'm not sure why they're flying out like that... you say 'in a playblast'; does that mean that they DON'T fly out when you're just working in the viewports or when you render?

The only thing it looks like to me is a double transformation, which happens when something is both bound and parented to a skeleton. But in that case I'd expect the problem to show up in all cases: viewport, playblast, and render.

Anything else you can tell us about the problem?

-Steve


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]