FORUMS: list search recent posts

Render problem, please SOS

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Pedro Gomez
Render problem, please SOS
on Nov 8, 2010 at 5:26:18 pm

Hi guys,

I am having a problem to render a scene. I am using Maya 2009, the maya.standalone module for Python and the Maya Software render.

My scene is composed of 2200 meshes which represent neurons, each of them contains lot of triangles (over 135.500). Some of these neurons share the same mesh, so I decided to use instances in order to reduce the amount of memory needed to render the scene (If I do not use instances I run out of memory). Some of the meshes interpolate each other.

The thing is that when I set the camera position to a distance of 900 from the centroid of the neurons, I can render the scene. However, when I set the distance of the camera to a larger value, 2000, Maya crash during the rendering. This is the output of the gdb debugger:


Rendering current frame.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x4480c950 (LWP 8956)]
0x00002aaad508d361 in TtileNode::scanConvert () from /usr/autodesk/maya/lib/libRenderSlice.so
(gdb) bt
#0 0x00002aaad508d361 in TtileNode::scanConvert () from /usr/autodesk/maya/lib/libRenderSlice.so
#1 0x00002aaad4f73efb in TtriangleWrapper::scanConvertForTile () from /usr/autodesk/maya/lib/libRenderSlice.so
#2 0x00002aaad4f7cb15 in TperTileBboxWrapper::scanConvertForTile () from /usr/autodesk/maya/lib/libRenderSlice.so
#3 0x00002aaad4f72f7a in ThiderWrapperList::nextNode () from /usr/autodesk/maya/lib/libRenderSlice.so
#4 0x00002aaad4f4be16 in TeasSampler::sampleWrapperList () from /usr/autodesk/maya/lib/libRenderSlice.so
#5 0x00002aaad50a0e7e in TtileRenderData::sampleWrappersInSpace () from /usr/autodesk/maya/lib/libRenderSlice.so
#6 0x00002aaad50a298e in TtileRenderData::EASSampleVector () from /usr/autodesk/maya/lib/libRenderSlice.so
#7 0x00002aaad509bb07 in TtileNode::sampleNextScanline () from /usr/autodesk/maya/lib/libRenderSlice.so
#8 0x00002aaad5098922 in TtileNode::renderTileScanlines () from /usr/autodesk/maya/lib/libRenderSlice.so
#9 0x00002aaad5045c92 in destr_detour156.0.329 () from /usr/autodesk/maya/lib/libRenderSlice.so
#10 0x00002aaad5045ad9 in sMpRenderTilesProc () from /usr/autodesk/maya/lib/libRenderSlice.so
#11 0x00002aaaceba8cb4 in TmtThreadSubPool::sThreadStagingProc () from /usr/autodesk/maya/lib/libFoundation.so
#12 0x00002aaaceba999f in TmtThread::fork () from /usr/autodesk/maya/lib/libFoundation.so
#13 0x00002ac0b5127020 in start_thread () from /lib64/libpthread.so.0
#14 0x00002ac0b4e9ff8d in clone () from /lib64/libc.so.6
#15 0x0000000000000000 in ?? ()


I have been reading the documentation, but I have not found anything that could give me a clue. I have tried to change the near and far clip planes, but I get the same error. I am using a lambert shader to shade the meshes and nothing else.

Do you have any idea why it is happening? I have been trying to solve this problem for weeks, maybe the interpolation of the meshes could be a problem for Maya, but they do not mention it in the documentation.

Thank you in advance,

(I hope I could solve this problem because is an important part of the final project of my degree.)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]