FORUMS: list search recent posts

HELP Maya pencil curves not attaching properly

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Ting-wei Hu
HELP Maya pencil curves not attaching properly
on Apr 2, 2010 at 1:59:47 pm


Hi, I was working in Maya 09 on trying to make a human shaped picture out of pencil curves. I used a lot of separate pencil curves, then selected them all and did the intersect and cut. Some didn't intersect so I went in and fixed it. But even then, when I attach the entire bunch of curves, they start attaching all over the place, there's jsut about 2 or 3 lines that are wrong, but I'm just not sure what's going wrong.
Checking them up close, doesn't seem like they aren't connected or anything. Any help would be appreciated, would want to try anything to fix this.

Thanks in Advance,
Ting


Return to posts index

Ting-wei Hu
Re: HELP Maya pencil curves not attaching properly
on Apr 2, 2010 at 2:15:02 pm



This is an image I screencapped
As you can see there are curves attaching from left to right or from right to left. I'm really hoping to fix this asap so that I could move on since I have lots of stuff to do in this project.
Really hope I can find the answer from the much more experienced people on here.

Thanks


Return to posts index

Michael Frank
Re: HELP Maya pencil curves not attaching properly
on Apr 3, 2010 at 7:28:30 pm

I think the way that the curve attaching works is based on the direction of the curve. If you look at the curve in component mode, there is a large square that indicates the first point, followed by a U. That is the the direction the curve is running in.

When you go to attach the two curves together, the last points on both curves are where it will join. In order for them to attach correctly you might have to Edit Curves -> Reverse Curve Direction.


Return to posts index


Ting-wei Hu
Re: HELP Maya pencil curves not attaching properly
on Apr 8, 2010 at 2:45:40 pm

Thanks, that fixed a lot of the problems, although I still ended up redoing a lot of my curves.

I have a new problem right now, my curves attach properly, but while some can use bevel plus, my major one has problems with bevel plus.
Especially if I try to use edit>close curves, the curves you see of two human figures simply disappear after I do this.
I really don't want to redo this again, or is there an easier method to bevel this kind of image??

Or should I maybe just model a plane to the image and bevel it??



Return to posts index

Michael Frank
Re: HELP Maya pencil curves not attaching properly
on Apr 8, 2010 at 3:16:05 pm

Yeah, the curve has to be closed in order for bevel plus to work.

So we gotta figure out why your curve is disappearing when you close it..

First thing - when you do close curve - its going to attach the first point (the square shaped CV) to the last point. So I dunno how you drew it, but keep that in mind.

Also try deleting history and freezing the transformations.

You could model a plane, but its not gonna be NURBS.. so you'll need a bunch of vertexes.

If you're gonna rebuild the thing, I'd break the design down into more parts if possible. Maybe simplify it so each figure has its own curve.



Return to posts index

Ting-wei Hu
Re: HELP Maya pencil curves not attaching properly
on Apr 8, 2010 at 3:45:41 pm


Basically every bird was done separately in small bunches of curves then intersected, cut and attached.

The two figures and the little window thing, all three parts were done together, then I attached them not with blend but with connected mode, it that what's making this happen? Cause all the other ones that work properly were attached with blend.

Also, I tried what you said, I deleted the history, froze transformation, and tried again, but it's still the same.
The pic shows what I get when I bevel, and close the curve.
When I close the curve, the whole curve disappears
When I bevel plus, it returns me with an error in the script editor
Which doesn't help much..

Thanks







Return to posts index


Michael Frank
Re: HELP Maya pencil curves not attaching properly
on Apr 8, 2010 at 4:40:10 pm

Hmm, I wonder why it won't let you close the curve correctly without it disappearing. There must be something going on with the curve it doesn't like.

Maybe try rebuilding the curve?


Return to posts index

Ting-wei Hu
Re: HELP Maya pencil curves not attaching properly
on Apr 8, 2010 at 4:56:16 pm

I've tried rebuilding it more than once already and it's such a tiring job I don't want to do it again.
Another method I know is to try and convert the image into a vector ai file and import it into maya, then bevel plus it

But never done that before, wonder if there would be any problem involved and what process is involved, would you happen to know?


Return to posts index

Michael Frank
Re: HELP Maya pencil curves not attaching properly
on Apr 8, 2010 at 5:54:10 pm

Sorry, by rebuilding I meant to say try Edit Curves -> Rebuild Curve. Maybe it can fix it for you or help expose whats going on.

I think importing an .ai file is pretty straightforward, but I haven't tried it. It should be like a nurbs curve after importing, might need to close it or do some things before beveling.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]