FORUMS: list search recent posts

Maya nParticle fill object not working

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Bryant Coffey
Maya nParticle fill object not working
on Mar 19, 2010 at 6:13:24 am

Alright I create a poly cube, go to the ndynamics menu set then nParticles -> create nParticles -> Fill Object. Nothing happens. I uninstalled Maya 2010 as well as 3ds Max in hopes that the combination might be causing a problem and still nothing is happening. I tried the same combination on another computer and it worked just fine. Took down the active plug-ins and settings made them the same on my computer and it still did nothing. Tried all the other nParticle emitters/creators and they all worked. Every time I try to fill the object I get this message in the status box, which I would assume meant that it attempted to create it.

particleFill -rs 10 -maxX 1 -maxY 1 -maxZ 1 -minX 0 -minY 0 -minZ 0 -pd 1 -cp -dw;

The cube is selected as I'm doing this. Any thoughts/solutions? Let me know, thanks!

Bryant


Return to posts index

Michiel Duvekot
Re: Maya nParticle fill object not working
on Mar 19, 2010 at 8:03:38 pm

Turn off Double Walled in the Particle Fill Options. You may have to scroll a bit in the window; it's the last option and easily missed.


Return to posts index

Bryant Coffey
Re: Maya nParticle fill object not working
on Mar 20, 2010 at 5:54:18 am

I have both tried this with the double walled option on and off... same thing happens both ways. I've also tried a variety of different options on and off to see what happens. Thanks for the response. Any other ideas? Let me know what you think. Thanks.


Return to posts index


Michiel Duvekot
michiel@duvekot.ca
on Mar 20, 2010 at 4:18:41 pm

run this from the Script Editor

polyCube -w 1 -h 1 -d 1 -sx 1 -sy 1 -sz 1 -ax 0 1 0 -cuv 4 -ch 1;
particleFill -rs 10 -maxX 1 -maxY 1 -maxZ 1 -minX 0 -minY 0 -minZ 0 -pd 1 -cp;


Return to posts index

Bryant Coffey
Re: michiel@duvekot.ca
on Mar 20, 2010 at 4:30:28 pm

Do I just type it in at the bottom or is there a better way to do it? I'm still new to Maya and the I haven't gone in depth too much with the script editor...

Bryant


Return to posts index

Michiel Duvekot
Re: michiel@duvekot.ca
on Mar 20, 2010 at 5:48:41 pm

You paste in in the Script Editor and choose Command -> Execute from the menu.


Return to posts index


Bryant Coffey
Re: michiel@duvekot.ca
on Mar 20, 2010 at 5:51:58 pm

Thanks man, I'll give it a try when I get back to my place.


Return to posts index

Bryant Coffey
Problem Solved.
on Mar 22, 2010 at 4:23:59 am

So I tried your solution by pasting it in and it didn't work. So many people have said the double walled option was the culprit so I tried it on a computer that does work and it took on the same problem as what mine was doing. So I did yet another re-install and after it was done unchecked the double walled option and it filled perfectly. Thanks for all of your help guys -- those who said double walled were correct it must've been a buggy install or something. It works, it's good.

Bryant


Return to posts index

stephen weber
Re: michiel@duvekot.ca
on Feb 21, 2017 at 12:56:58 pm

Thanks . Works great for me.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]