FORUMS: list search recent posts

Problems cleaning up and assigning Uv Sets for Texturing

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
arlington cruz
Problems cleaning up and assigning Uv Sets for Texturing
on Dec 18, 2009 at 6:24:50 am

Hello I have been going over an old UV mapping tutorial and It's my first time attempting to create Uv sets to then do snapshots for texturing.

My problem is divided into 3 parts:

1- The instructor finalized tutorial dividing the Uv maps into two sections to create 2 sets of Uv maps to do snapshots.
uvsets

I have been trying to create the first uv set out of the uv's on the top right square of texture editor. I keep getting Error: Error While parsing arguments:

error parsing objects


I googled this and some people have solved problem by deleting history. I Attempted deleting history, but didn't fix problem.

2- If I create these 2 Uv sets, Do I need to Drag all Uv shells located on the top left uv space square to overlap the ones on the top Right square?(since they will be separated by 2 sets?)

3- When I tried to assign a new Uv set, I saw all of these different parts on the drop down menu:

uvsets cleanup

I am not sure if these are all uv sets that were created during projections or if these are just the names of all the shells.
If so, How would one Clean up this list to only create the 2 uv sets I need and remove the rest?
Thanks very much for your help as always.


Return to posts index

Michiel Duvekot
Re: Problems cleaning up and assigning Uv Sets for Texturing
on Dec 18, 2009 at 2:38:47 pm

this will remove all uvSets except map1;

string $UVSs[] = `polyUVSet -q -allUVSets`;

for ($tmp in $UVSs) {
if ($tmp == "map1") {
// do nothing
}
else{
polyUVSet -delete -uvSet $tmp;
}
}



Michiel
http://www.thnkr.com


Return to posts index

arlington cruz
Re: Problems cleaning up and assigning Uv Sets for Texturing
on Dec 18, 2009 at 6:23:19 pm

Thank you very much! I will use script to clean up sets tonight @ home.

To prepare final Snapshots, Do I need to move both UV sets and place them on top Left quadrant and then take a separate snapshot selecting each UV set?I am trying to use Uv Linking.

Haven't done it before so I am not sure how to go about that. Once again thank you for all your help.


Return to posts index


Stuart Christensen
Re: Problems cleaning up and assigning Uv Sets for Texturing
on Dec 19, 2009 at 7:43:59 am

Hello Arlington, your UV sets should actually be in the upper right hand quandrant to make a snapshot. So, you would select the first UV set and make sure they are in the upper right quad, then take a snapshot, then select the second set and make sure they are in the upper right quad an take the snapshot.

You can use the move tool to move the UV sets completely out of the way, (ie; anywhere but the upper right quad.) It's a little tricky at first, but stay with any texturing tutorials and soon you will get the hang of it. There's also some other mapping features such as automatic, planar etc. theat may be of help, but you are on the right track. Hang in there! STU

I know alot....but not as much as the other guy.


Return to posts index

arlington cruz
Re: Problems cleaning up and assigning Uv Sets for Texturing
on Dec 19, 2009 at 8:50:26 am

Stuart, This cleared the last of my confusion. This was where the tutorial left off and the instructor didn't get to explain if we had to move both sets on the quadrant. Only had done 1 uv mapping tutorial without using uv sets before. I am still a noob, but I am glad that there's always those willing to help.

Thanks to you both once again.





Return to posts index

arlington cruz
Re: Problems cleaning up and assigning Uv Sets for Texturing
on Jan 12, 2010 at 6:54:39 am

Hello Again Everyone,I am really sorry to reopen this problem. I thanked everyone before Trying out the Script. I Used script to clean up uv sets and stay with original UV set but wasn't able to get it to work (error while parsing Arguments) I even tried deleting all these extra uv sets one by one and still got same error.

For Any chance is there any work around to delete or clean up uv sets?

My goal is to only have 2 uv sets (see picture on first post)to then select individually having both sets on top right quadrant and do Snapshots to texture.

I tried doing a search on this problem asked some friends,but haven't been able to find a specific solution as of yet.


Return to posts index


arlington cruz
Re: Problems cleaning up and assigning Uv Sets for Texturing
on Jan 20, 2010 at 4:11:03 am

A friend of mine told me the problem. To clean up uv's I also had to clean up "non deformer history." With this, everything else worked. and copied uv's to new uv set.

Problem Solved, thanks guys.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]