FORUMS: list search recent posts

textures are importing with transparancy

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Jeff Crowe
textures are importing with transparancy
on Aug 21, 2009 at 5:07:02 pm

Hopefully this is a quick fix someone can help me with.

I'm creating a simple character in maya and am at the shading and texturing stage. The problem I'm running into is that when I'm importing an image file to use as a texture, it is coming in semi-transparent.

I'm rendering with renderman for maya (which I'm pretty new to), but the problem is also occurring in the maya software renderer as well. But strangely enough, if I render in mental ray, it renders out fine.

It seems like there is a simple setting I'm missing. I can sort of fix it by changing the 'alpha gain' or 'alpha offset' values, but I would thing there is a better way.

By the way, I'm creating this image file in Photoshop (flattened image) and have tried several different file types to see if that would work (.tif, .jpg, .tga).

Any help would be much appreciated.

EDIT:
Ignore this post. For some reason when I was attaching the image files, both the color and transparency values were being mapped. Duh. Don't know why, but got it changed to color only and all is good.


Return to posts index

Adam Benson
Re: textures are importing with transparancy
on Aug 26, 2009 at 3:25:29 am

I've seen this happen to me occasionally. I've found that the problem had to do with the way things got imported. I have not found a way to keep things from importing this way (when it happens) but that's not important. The solution (if its like mine) is very simple.

Open the Hypershade. Right-click the material that's giving you the problem and choose "GRAPH NETWORK". The material will show up with all its nodes in the Hypershade Editor. At the top level there will be at least two connections (unless you've created more). The main two coming in from the FILE node of your texture will probably be connected to the material's color AND to the material's transparency. If you mouse over the connection lines it should tell you what's what. Simply click on the connection that goes to the Transparency (it should turn yellow) and then click DELETE.

That should do the trick. If that's not the problem, then I'd have to see it to know what's going on.

Good luck!

Adam Benson
Visual Effects Artist/Musician/Sound Engineer/Editor
http://www.SleepDeprivedProductions.com
http://www.SleepDeprivedFilms.com


Return to posts index

Shoban Reddy
Re: textures are importing with transparancy
on Aug 27, 2009 at 4:41:41 am

It is very simple problem.

At first we know the difference between FileNode and PSD FileNode.
In File node there is not possible for Linking to LayerSet.In PSD FileNode it was possible..I can briefly note the procedure below..check once..

Open the Hypershade.In that Edit menu there ia an option Create PSD Network.In that Attribute selection tab we easily include the layers we want[Example:Color,Transparency,Specular].Then click on create button.It creates different PSD file nodes,and single texture map..
Then we open that texture map in photoshop it knows how it work.It takes various groups for different layers set.

For example we take PSD file[flattened image]without grouping.It connect both color and Transparency ex..So we should remove the connection repeatedly when we open the maya file..
That is simple Technique.

All The Best..
Shoban reddy.
Lighting Artist.



Return to posts index


Bård R Gunnerud
Re: textures are importing with transparancy
on Feb 3, 2015 at 10:07:55 am

My question is, why does this happen to start with?? I want to connect a file to color, and only color, why does Maya also connect the file to Transparency, what's the point? Is there a way to avoid it? A box to uncheck or is this a bug?


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]