FORUMS: list search recent posts

Alpha Issues

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Javier Saldivar
Alpha Issues
on May 21, 2009 at 6:52:19 pm

Hello,

I am mapping a PNG image (with transparency) to the color attribute of a lambert material. Then I apply this lambert to a polygon plane. The idea is that we would only see the part of the image that is visible thanks to the alpha embedded on the PNG, which works as expected.
The problem is that for some reason the bounding box of the plane this material being applied to is casting some shadows in areas that should be transparent. Something like my alpha is not completely transparent and areas that are supposed to be transparent are still casting some shadows.
I make sure that my alpha is 100 % transparent when I export the PNG out of Photoshop. I also observe the problem when using TIFF or PSD files with transparency.
I’m using Maya 2009 on a Mac and rendering with Mental Ray (but I also observe the same artifact when rendering with Maya Software)

Any idea on how to fix this?

Thanks!




Return to posts index

Alvaro Castaneda
Re: Alpha Issues
on May 21, 2009 at 10:48:32 pm

Hi

for that to work you need raytrace shadows, also map the transparency to the specular and reflection channels y raytracing is not enough

l8r

----------------------
varomix - pixelEater
http://www.intelianimate.com


Return to posts index

Campbell Morgan
Re: Alpha Issues
on Aug 17, 2009 at 11:00:26 am

I've been struggling with this for ages and have tried a number of bizarre workarounds that I've seen elsewhere on the web such as nesting two surface shaders, then using a color blend etc... The solution is actually frustratingly simple:

On the (lambert) material attributes, click on the "Raytrace Options" tab and set "Shadow Attenuation" to 0. For some reason it's preset to 0.5 and this causes the unwanted subtle shadow.

Good luck


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]