FORUMS: list search recent posts

Connecting transparency to Surface Shaders?

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Berk Frei
Connecting transparency to Surface Shaders?
on Jun 17, 2008 at 6:33:32 am

Hey folks

I am working on a project where I have rigged my characters with 2D geometry planes that are being deformed by a joint system. It is 2D animation and I am using .tif textures with alpha channels cutting off the excess geo and thus showing my characters. Here is the problem. I would like to use a surface shader so that I don't have to worry about light interacting with the shader and polygons. However, I can't seem to get the surface shader to read the alpha channels on my .tif texture files! Lamberts work fine (minus the fact that they interact with light and it slightly changes my colors!) I just have to connect the file and it automatically connects the transparency.

How is it done?!?

Anyways I hopefully someone out there has some solutions for me. Thanks!


Return to posts index

Steve Sayer
Re: Connecting transparency to Surface Shaders?
on Jun 17, 2008 at 1:00:33 pm

Hi, Berk.

I don't think the connection will be made automatically with the Surface Shader the way it is with more standard materials such as Lambert.

You'll have to make the connection manually: in your Hypershade, click the bottom right of the file texture node, and choose 'outAlpha' from the menu that pops up. Then click the bottom left of the Surface Shader node, and select 'outTransparency'.

Hope that helps,

-Steve


Return to posts index

Berk Frei
Re: Connecting transparency to Surface Shaders?
on Jun 18, 2008 at 4:45:50 am

hey steve

thanks for the response great idea I just tried it and it seemed to be working. In the perspective window with "display textures on" the alpha/transparency seems to work but when I render it with maya mental ray or hardware the transparency no longer works.

actually, with your directions(mm dragging the texture to the shader and connecting it to the default connection is what I thought was working) when clicking on the bottom left of the surface shader node I was supposed to get "outTransparency" option but I had to choose "other" because it wasn't there to connect the outAlpha of the texture to the RGB (i had to connect them separately) of the out Transparency. This result ends up giving me an inverted mask that blocks out exactly opposite of what I want. however this will render. so i could invert my alpha channel on my textures to fix the problem but i have hundreds of textures- a daunting task.

any other suggestions? am I missing something?



Return to posts index


Steve Sayer
Re: Connecting transparency to Surface Shaders?
on Jun 20, 2008 at 4:53:54 am

I don't think you're missing anything, which is unfortunate if you have hundreds of textures.

There's an 'Invert' checkbox in the file node, but that might invert the RGB as well as the alpha, which won't be a good solution.

You could always use a Reverse node between the texture and the material... although, again, if you've got hundreds of textures, that's going to be a pain in the neck to do.

Really, your best bet might be to reverse the alpha channels of the images if you can. Can you batch-process them with Photoshop? That shouldn't be too difficult to set up...

-Steve


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]