FORUMS: list search recent posts

Motion Vectors

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
zenozeno
Motion Vectors
on Jul 20, 2007 at 6:12:40 pm

What's the best way to kick out a motion vector render from maya (and incorporate with RS Motion Blur)?


Return to posts index

SSGGMM
Re: Motion Vectors
on Jul 20, 2007 at 9:36:56 pm

Try this:

http://www.revisionfx.com/support/faqs/generalfaqs/motion_vectors/#Maya

Follow the instructions carefully. It will lead you to a downloadable shader that appears to be lacking a .dll file. Instead, use the .dll that is included in the XSI download (you'll know when you get there.)

I just got this very problem solved today.

S.


Return to posts index

zenozeno
Re: Motion Vectors
on Jul 20, 2007 at 10:00:20 pm

Ahh, the XSI "dll" . . . very confusing, I would never have figured that out. Tried installing earlier, but no luck . . . will try your suggestions.

Did you also complete the following steps making the additions to the "rayrc" file?

link "{MAYABASE}/lib/lm2DMV_v2.{DSO}"

mi "{MAYABASE}/include/lm2DMV_v2.mi"

If so, where in the rayrc file do these insertions go? It is not clear from the site: (http://www.impresszio.hu/szabolcs/MentalRay/lm_2dmvMayaFiles.htm)

Also, in the OS-X version, there is a "render_lm2DMV_v2.xpm" file that is not mentioned at all in the installation details . . . did you also place this file somewhere?



Return to posts index


SSGGMM
Re: Motion Vectors
on Jul 22, 2007 at 2:30:20 pm

For the RAYRC file: Simply copy and paste the new lines after similar declarations.

Just kidding. What does "after similar declarations" mean anyway? No idea. Just paste the lines down at the bottom of the RAYRC file (in Notepad) and save.

I didn't realize you were on OS-X. The Windows shader also comes with a mysterious .xpm file. I ignored it.

As for the .dll, the one found in the XSI zip file just sorta worked for me (as it did for others). On OSX, you might have to hunt it down.

When you settle in to try this thing, remember to check "Pass Custom Alpha Channel" in your MR settings, under "Custom Entities". Don't ask me why.

I will point out that Re: Vision has forum here on the cow. The two guys who run it are incredibly helpful. It's their company, after all (or so I believe.)

SGM


Return to posts index

zenozeno
Re: Motion Vectors
on Jul 26, 2007 at 12:13:48 am

"For the RAYRC file: Simply copy and paste the new lines after similar declarations."

OK, I thought I was the only one confused by this! ;-) I added the lines of code at the very end so that the maya.rayrc file reads something like this:


end registry

$lookup "{MRMAYA_START}"

link "{MAYABASE}/lib/lm2DMV_v2.{DSO}"
mi "{MAYABASE}/include/lm2DMV_v2.mi"


Does this seem about right?

I've installed the following files into the relevant directories in Maya "package contents":

mayacontentsmentalrayincludelm2DMV_v2.mi
mayacontentsmentalrayliblm2DMV_v2.dll
mayacontentsscriptsAElm2DMV_v2Template.mel

Everything seems good to go, and "pass custom alpha" option is set in render globals . . .

have a simple scene with a sphere moving with the lm2DMV_v2 shader assigned. Only two keyframes, and trying to render out the middle of the sequence, but get the following error:

// Warning: (Mayatomr.Custom) : /Applications/Autodesk/maya8.5/Maya.app/Contents/mentalray/include/lm2DMV_v2.mi: no shader library specified nor found in search path, expect manual loading //

Any ideas?



Return to posts index

SSGGMM
Re: Motion Vectors
on Jul 26, 2007 at 4:19:06 pm

Everything looks right.

I came across that same error many times, but I can't remember what the specific solutions were each time.

I do recall running the new mel script in the script editor upon starting my session. I did that as a "just in case" sort of thing, but I really can't tell you if it meant anything to mental ray.

Another possibility might be the .dll you have. I'm on PC, you're on Mac. Could be worth looking into.

Meantime, if any detail pops back into my head I'll post it.

Google your problem, by the way. I read dozens of posts in dozens of forums before I got any sort of grip on it. It appears to be somewhat of a home-made shader, so its integration may not be all that simple.

SGM


Return to posts index


zenozeno
Re: Motion Vectors
on Jul 27, 2007 at 3:26:52 am

Well, thanks for all the advice you've offered! I'll keep looking . . . and if I manage to isolate the issue, I'll be sure to post . . .



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]