FORUMS: list search recent posts

Exporting camera to AE - Unit translation

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Exporting camera to AE - Unit translation
on Dec 1, 2006 at 7:24:39 pm

I'm somewhat of an old hat in After Effects, but a Maya novice.
I'm having a problem that I imagine someone has encountered.
When importing a camera from maya, what is the factor for translating units of Maya's worldspace into AE's quote-unquote worldspace - pixels?

For example, say my camera in Maya does an x-trans of 100 inches.
When I bring this camera into AE, this trans is interpreted as 100 pixels, hardly the same. The distance relationships of everything is off.
The move needs to be scaled up by a factor in order for everything to be properly rebuilt and comped. Is there a specific factor that makes the translation seamless, effectively recreating the distance relationships from the original Maya scene in AE's world? (so far we've eyeballed it and a factor of appx 15 is almost right, but we're not that into 'almost')

I've posted this in the AE forum as well just in case

Thanks everyone!

Return to posts index

Re: Exporting camera to AE - Unit translation
on Dec 2, 2006 at 3:42:23 am

I'm not sure. I've had similar problems in the past and I think mine was related to rectangular AE comps vs. square Maya footage.

- MythProd
(John David Hutton)

Build Your Own Velocity. See how:

VelocityX, Version 1.0.01
Kansas City, Kansas - United States

Return to posts index

Re: Exporting camera to AE - Unit translation
on Dec 7, 2006 at 11:01:23 am

What version of AE are you using?

Return to posts index

Re: Exporting camera to AE - Unit translation
on Dec 8, 2006 at 7:56:13 pm

Recently, this was posted on the Adobe AfterEffects User forums:

wiso - 12:10pm Dec 4, 06 PST (#2 of 6) Edited: 04-Dec-2006 at 12:36pm

Wow, I think I just got a lot closer . . . I was looking in AE7s help (what a place to look eh?) and in one results returned by searching "maya" it says:

"If you apply FilmFit camera setting, make sure to use either Horizontal or vertical FilmFit, not fill"

I went back to my maya file, checked my camera attributes, under Film Back settings my film fit was set to fill. I switched this to horizontal, rerendered the frames and reexported the camera and null_objects, brought back into AE, and things are lining up perfectly . . . I have only messed around with a test scene, 100 frames, will try later to apply it to the project I am working on to make sure everything still works. Try this out, let me know if you get similar results.

One other though, I think this is actually very simple . . . look at the aspect ration in render globals and in the camera attributes . . . for me they did not match up. Thus, filmfit forces this to match. Another way to proably make this work is to match the aspect ratios without using film fit . . . will try this next.

Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2018 All Rights Reserved