FORUMS: list search recent posts

Particles thru tube Help?

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
BRIAN
Particles thru tube Help?
on Feb 24, 2006 at 5:27:34 am

Banging my head against the wall..
I have an emitter (omni) traveling along a path..
The particles (blobby surface) are emitting nicely.
Want to keep these.
However I need the particles not to hit into the forground.
They need to stay in the view but not reach the camera.

The camera is following the particles on thier journey.
(like: you, the viewer are following bubbles travelling through a hose
-but you never reach the bubbles)

I can't just fade the particles out because they are suppose to be dissolving into the wall of the 'hose'

I've tried using a gravity field but since the 'hose' twists and turns I can't set
an XYZ direction because it changes as the path turns.

I admittedly have scant knowledge in dynamics... any dummy way to make it happen?

Thanks for any advice!

Brian





Return to posts index

Steve Sayer
Re: Particles thru tube Help?
on Feb 24, 2006 at 7:33:11 pm

If I understand you correctly, you want all the particles to move away from the path which runs through the centre of the hose, and move towards the wall of the hose itself. The problem arises because some of the particles emitted by your omni emitter happen to end up travelling back towards the camera, obscuring the shot.

I think the simplest solution would be to replace your omni emitter with a cylindrical volume emitter. With a volume emitter, you have more control over how the particles behave. You would give them an 'away from axis' velocity component which was larger than their 'along axis' velocity component, and that way they will all be moving away from the path from birth; by tweaking the speed, you can ensure that none of them are left near the path by the time the camera gets there.

Note that you'll have to make sure the volume emitter's cylinder is always aligned with the path, but that shouldn't be too much of a problem.

-Steve


Return to posts index

BRIAN
Re: Particles thru tube Help?
on Feb 24, 2006 at 10:11:01 pm

Thanks very much!
Right, you've got the picture exactly.
I'm going to give that a try.
I did attempt to get an emitter to 'face forward' or aligned with the path (same as the camera does) while going through the tube but couldn't see how.
Would you mind clueing me in?

Brian




Return to posts index


Steve Sayer
Re: Particles thru tube Help?
on Feb 25, 2006 at 12:19:59 am

Not at all.

When attaching the emitter to the motion path, check the 'Follow' option and check 'y' for the 'Front Axis' choice.

-Steve


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]