FORUMS: list search recent posts

Black edges around objects when I enable motion blur!? Help!

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
gizmo1990
Black edges around objects when I enable motion blur!? Help!
on Feb 14, 2006 at 9:22:47 pm

As the title says really?? :(

I've turned on 2D motion blur for my camera and I get these really harsh black lines around all my objects for some reason?

It doesn't happen on 3D blur or when I turn motion blur off altogether.

I've tested it on different scene setup with a moving cube and it still does it? Surely it's not supposed to do this? As I say 3D looks absolutely fine?
Am I missing something really dumb here...?

Any help really appreciated.



Return to posts index

Ben Insler
Re: Black edges around objects when I enable motion blur!? Help!
on Feb 14, 2006 at 9:30:38 pm

are you seeing the black edges when you composite, or directly in your MAYA Render View?

Ben Insler

Editor

Telemark Films


Return to posts index

gizmo1990
Re: Black edges around objects when I enable motion blur!? Help!
on Feb 14, 2006 at 11:21:36 pm

Thanks for your reply Ben.

I'm seeing it directly in my render view.

Heres a quick image of the test cube I setup. The image on the left is the rgb and the one on the left is its alpha.

http://img116.imageshack.us/img116/1381/motionblur1nm.jpg

As you can see its alpha looks fine so why would I be getting this dark black edging?

Any help really appreciated.



Return to posts index


Lars Bunch
Re: Black edges around objects when I enable motion blur!? Help!
on Feb 15, 2006 at 4:37:03 pm

Hi,

This may only confuse the issue further, but it looks like the left image is not pre-multiplied with the alpha channel.

For elements of the image to appear transparent, a pixel's value must be multiplied by the alpha pixel's value. For example if your image's pixel value is 256,256,256 (white) and the alpha pixel's value is 0,0,0 (black) then the image pixel value will become 0,0,0 (Multiplying by 0 leaves 0)

If the image is not pre-multiplied by the alpha, you will see the image pixel values at whatever they are set to with no transparency. Maya may leave the pixels in the blurred, semi-transparent area around the moving object black, relying on the final compositing operation to blend them with the background. This would create the ring of black around your object.

Very often in compositing situations if you try to adjust the levels of an image that is pre-multiplied by the alpha, you will start to see a ring around the non-transparent part of the image. This is because as you adjust the image, you are affecting the final multiplied version of the image.

In your case, without actually knowing what I'm talking about, I would guess that for some reason, Maya is outputting an un-pre-multiplied image. There may be a way of adjusting this setting. Usually 3D graphics renders are pre-multiplied, but because programs like Shake allow a great deal of control over how the alpha is combined with the image, there may be times when you might want to output an un-pre-multiplied image.

Of course, this may not have anything to do with your problem. I only know enough to be a danger to myself and others...

If you could post an iff file with the alpha, I'd be happy to look at it in Shake and see if I can figure out it's multiplication status.

Hope this helps.

Lars


Return to posts index

Steve Sayer
Re: Black edges around objects when I enable motion blur!? Help!
on Feb 15, 2006 at 7:04:30 pm

Lars, I think your response is right on the money.

Gizmo, try checking the 'Smooth Color' radio button in the 2D motion blur section of your render globals. That should get rid of the artifacts you are seeing in the render itself. But depending on your compositing workflow, it might produce other artifacts during compositing; I'm not sure.

-Steve


Return to posts index

Ben Insler
Re: Black edges around objects when I enable motion blur!? Help!
on Feb 16, 2006 at 10:11:31 pm

Hey,

Lars' reply is exactly right, although I think it might be more technical than you're looking for. I may be wrong, but I assume that you're rendering the white background straight out of Maya. In my experience, Maya's native render compositor isn't too good with transparency, especially when you're rendering on a background that is any other color than black, and that could be why the semi-transparent edges in your motion blur are getting black halos. Try rendering out your motion blurred image on a black background with an alpha as a .tga or .tiff or some other image file that embeds the alpha channel within itself. Then take your image into photoshop or After Effects and try placing it over a white background - see if the compositing works correctly there. My guess is it will. If this is too simple an answer, definately go with Lars - he articulated it well.

Best,

Ben


Return to posts index


Sean Fennell
Re: Black edges around objects when I enable motion blur!? Help!
on Feb 17, 2006 at 11:53:26 pm

Maya (as well as most other renderers) always outputs un-premultiplied images when rendering. You can confirm this by setting the background color on the persp camera to white and rendering. The color channel will be white, but the alpha channel will be black. Compositing software can handle this quite well, but the 2d motion blur algorithm cannot. Which is why its usually best to render 2d motion blur over a pure background (meaning black).

One question I have is about the white background in your render, is that actual geometry that is colored white, perhaps with a surface shader, or is it a background color set to white? If its actual geometry, that can also cause very bad smearing in the color channel. Maya's 2d motion blur technique, as well as most other 2d motion blur technology, does not handle objects crossing other objects as well as they do objects moving across blank space.

Whatever the setup, the other posts are on the money. Render 2d motion blur passes over a pure empty background for the best quality. Combine this rendered pass on top of any backgrounds in a compositing package.

I also advise against using Smooth Color option in the 2d blur controls and suggest keeping it on Smooth Alpha, mainly because using smooth color tends to blur the color channels far too much, even at a smooth value of 0.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]