FORUMS: list search recent posts

blendshape on groups?

COW Forums : Autodesk Maya

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
jim
blendshape on groups?
by
on Jan 25, 2006 at 4:24:23 pm

hi, im trying to do a bit of blend shape mouth animation and have made up my head with one piece of poly geom for the main body and seperate teeth and tounge all these have been grouped and duplicated to make my blendshapes. (still with me:) cool. when I select my groups and apply blendshape the lips work but the teeth and tounge do not. please tell me what I'm doing wrong thanks


Return to posts index

Chad Briggs
Re: blendshape on groups?
on Jan 25, 2006 at 4:44:12 pm

i think in order to make this work, your gonna have to make all the parts of the blendshape one poly object (by using polygons->combine). I don't think the blendshape node will work on groups that use parenting.
-chad


Return to posts index

Sean Fennell
Re: blendshape on groups?
on Jan 25, 2006 at 5:57:38 pm

they should work with groups. I've done it many times. All the surfaces have to be in the same order in each group. And I don't think you can have any other objects besides deformable geometry within the group. So if you have joints or anything else rolled up in that group, that probably wont work. If you post a simple scene one of us might be able to figure it out.


Return to posts index


jim
Re: blendshape on groups?
by
on Jan 25, 2006 at 6:11:43 pm

hi cheers my scene is here
http://www.perpetuity.co.uk/movies/index.php

thanks in advance

Jim


Return to posts index

Sean Fennell
Re: blendshape on groups?
on Jan 25, 2006 at 6:38:32 pm

because of legal reasons i can't open the scene while im at work, but i can check it when i get home. I'll get back to you tonight or tomorrow.


Return to posts index

Sean Fennell
Re: blendshape on groups?
on Jan 26, 2006 at 4:58:25 am

K Jim, I had a chance to take a look at your file and noticed two problems.

The first on is that in each group the surfaces do not appear in the same order, so I had to manually reorder the surfaces within each group in the outliner by middle mouse dragging them. The order that I created for each model was this:

Group
-body
-tongue
-lower_teeth
-upper_teeth

you can put them in any order you like as long as ALL the groups have the surfaces in the same order in the outliner.

Secondly, the reason your tadpole teeth are not deforming with the blend shape is because they've been translated into position. Blend shapes ignore positional translations and only blend models who's point positions have changed. So what you'll need to do is use component mode to move your teeth around by their points. that will make the blend shape catch them as deformed geometry.

Hope that helps.


Return to posts index


jim
Re: blendshape on groups?
by
on Jan 26, 2006 at 10:52:59 am

cheers Sean,
thats bean bugging me-

thanks again
Jim


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]