FORUMS: list search recent posts

Fuzzines at glass window on cam body - mold?

COW Forums : Canon Cameras

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Kurt Raihn
Fuzzines at glass window on cam body - mold?
on Dec 4, 2007 at 7:39:04 pm

Hey everyone,

I just noticed something today when I was adding my 1.6x extender to my XL-1. When I looked at the window on the body of the camcorder where the lens attaches, I noticed a fuzziness. I attempted to clean it with a lens cleaning cloth but it did not go away. I am wondering if it is mold on the inside of the window. I live in a tropical environment (Costa Rica) so the possibility of mold growing on things is high. I don't think it is condensation because it is midday, warm out, and the camera has been at room temp for many hours (no air conditioning).

Does anyone know if I can remove the little window and clean it myself? Obviously the chip is located on the other side of the window so great care must be taken.

Any other suggestions?

Thanks,
Kurt




Return to posts index

Donald Berube
Re: Fuzzines at glass window on cam body - mold?
on Dec 6, 2007 at 4:54:59 am

Send it in to an Authorized Canon Repair Center.

- Don
http://noisybrain.com
http://www.bosfcpug.org



Return to posts index

Kurt Raihn
Re: Fuzzines at glass window on cam body - mold?
on Dec 6, 2007 at 2:15:44 pm

Hey Don,

I figured that would be the response. I live in Costa Rica so sending it to a Canon Dealer is not trivial nor inexpensive.

Oh well, I may have to bite the bullet.

Thanks.
Kurt



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]