FORUMS: list search recent posts

XL1 lens alert flashing

COW Forums : Canon Cameras

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Craig Lindvahl
XL1 lens alert flashing
on Oct 19, 2005 at 2:18:36 pm

Hello-

We have several Xl1 and XL1s cameras in our class. One of our Xl1 cameras has the "check the lens" alert flashing. According to the manual, the camera is not recognizing the lens.

I switched the lens to another XL1, and the lens worked fine, and the problem camera gave me the same message with a different lens attached.

Any ideas?


Thanks very much.

Craig Lindvahl


Return to posts index

Don Greening
Re: XL1 lens alert flashing
on Oct 19, 2005 at 3:25:14 pm

You might try having a look at the electrical connections on the camera body where the lens attaches. I seem to remember someone having a similar problem and they found dirt/dust/grease residue on those contacts. If that doesn't solve the problem then you may have to take it in for service.

- Don


Return to posts index

Craig Lindvahl
Re: XL1 lens alert flashing
on Oct 20, 2005 at 12:40:05 pm



I cleaned the posts, but no luck. I think I'll probably have to send it back in to Canon. I imagine it's due for servicing anyway.

Thanks a lot

Craig L


Return to posts index


Peter Ralph
Re: XL1 lens alert flashing
on Oct 25, 2005 at 3:13:18 pm

not just the posts you need to clean the entire mating surface. a pencil eraser rubbed very carefully over the surface might help , if you feel confident about not introduing any residue into the camera


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]