FORUMS: list search recent posts

GL2 No Playback; Can't Record; Editing Program Doesn't Recognize Camera Input

COW Forums : Canon Cameras

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
PhattBoy
GL2 No Playback; Can't Record; Editing Program Doesn't Recognize Camera Input
on Aug 24, 2005 at 3:38:49 am

HELP!!!! All of a sudden my GL2 doesn't playback any of my tapes... doesn't record video or audio, shows no time codes, and my editing software doesn't recognize my camera when it is plugged into my computer. I just played tapes on it a few days ago. This change is sudden... Has anyone out there ever experienced anything of this nature.


Return to posts index

Thax
Re: GL2 No Playback; Can't Record; Editing Program Doesn't Recognize Camera Input
by
on Aug 24, 2005 at 11:41:43 am

Does not sound good.

One thing to try is to remove the "backup" Battery and replace it with a new one.
(Its a CR2025.)

Open the LCD and inside on the CAMERA BODY you'll see the small door covering the battery (about the size of a US Quarter).

See page 138 in the CL2 manual.

I would unplug the camcorder from the AC supply, remove the (standard) camcorder battery pack, and then pull out this "Backup" battery
and leave the camera without ANY power for about 10 minutes.

Then put in a fresh CR2025, connect the AC supply and see if your GL2 wakes up "fresh" again.


Return to posts index

PhattBoy
Re: GL2 No Playback; Can't Record; Editing Program Doesn't Recognize Camera Input
on Aug 30, 2005 at 3:10:22 am

Hey, thanks for the advice. I only wish I had tried the backup battery thing before I sent back to Canon in Jersey to be repaired. Hopefully, if it's something as simple as reseting the camera, Canon won't charge me for a more expensive procedure. You know... like the auto mechanics do. Thanx again, my amigo.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]