FORUMS: list search recent posts

GL2 stops in the middle of filming!

COW Forums : Canon Cameras

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
David H Dennis
GL2 stops in the middle of filming!
on Apr 14, 2005 at 8:01:42 pm

My business partner and I have a gig filming a 45-50 minute class three times a week. He has a Canon GL2 and I have a Canon XL1. The GL2 is on loan from the school which we're filming; the XL1 is my own. The GL2 was previously used by other people who did filming of classes before us. It looks to have been kept in fine condition, with light use.

About a week ago, the GL2 started stopping and turning itself off in the middle of filming. My partner has to switch it back on and punch record, but of course we lost quite a bit of class time that way. In the last class we attended, this happened three times.

The battery is fully charged before each class, so I don't think that's the problem. He tells me that earlier he was holding the camera partly by the battery at the back, but he has stopped doing this and the problem persists.

I have never had a problem with the XL1, and we're dealing with the same supply of tapes, so I doubt that the tapes are bad. We get our Sony Premium MiniDV tapes from tapestockonline.com, which has been a very reliable and high-quality supplier up to now.

Any idea what might be the problem and what it would take to fix it?

Many thanks.

D


Return to posts index

Don Greening
Re: GL2 stops in the middle of filming!
on Apr 15, 2005 at 3:52:08 am

I doubt that anyone will have a direct response to your GL2 troubles unless it's an inherent problem with these cameras, and I've never heard of this to be the case. Other than checking to make sure the battery connection pins at the back of the camera are still spring loaded and in generally in good condition I would advise that the GL2 be taken to an authorized Canon repair facility. It's not much good to you if you can't depend on it to stay on and recording when you need it to be.

- Don


Return to posts index

Ralph Hajik
Re: GL2 stops in the middle of filming!
on Apr 16, 2005 at 9:27:06 pm

Hello David & Don,

Unfortunately I have the same problem. I could have my GL2 on and all of a sudden the GL2 turns off by itself and turns back on. Very bad when your ready to film. Plus, my switch on my tape door sticks to where I can't open it. I have to force it to the right a little and then I'm able to slide the switch. Also, while I'm filming, a message pops up stating that my heads are dirty, this is even after I use a head tape cleaner. I definitely need to send in my GL2 into the shop for some maintenance work.

Ralph Hajik
Westmont, IL


Return to posts index


Scott Draper
Re: GL2 stops in the middle of filming!
on Apr 20, 2005 at 2:38:50 am

I think I know the answer. Don't put film in your camcorder.


Return to posts index

Chad Simcox
Re: GL2 stops in the middle of filming!
on Apr 26, 2005 at 6:52:12 am

Scott beat me to it...


Return to posts index

Don Greening
Re: GL2 stops in the middle of filming!
on Apr 28, 2005 at 12:12:38 am

......by about six days

- Don


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]