FORUMS: list search recent posts

Avid media composer 8.5 GoPro & C300 sync

COW Forums : Avid Media Composer

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Phillip Jacob
Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 11:41:47 am

Hey guys & girls.



I've got a lot of GoPro and C300 material that I need to sync up.

My normal workflow, is to link, consolidate (relink), and then manually sync all the clips, used Plural eyes before but that dosen't seem to work with 8.5.

A side note, the gopros seems to get off sync randomly after a while, is that because of the camera or? - At the beginning it is synced perfekly but after maybe 2-5 minuts its out of sync.

Is there any chance that there is an easier way to do this?


Return to posts index

John Pale
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 12:38:10 pm

What frame rate are the cameras shooting at?


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 12:38:56 pm

25 fps


Return to posts index


Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 2:27:24 pm

The latest version of PluralEyes no longer support AMA, so it is not so much an MC version issue than it is a PluralEyes dropping support.

Sync that drifts indicates either picture or audio are at slightly different rates - either fps for picture or sample rate for audio. What is the nature of the drift? One frame every _____ seconds? Picture ahead of audio or audio ahead of picture?


Michael


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 2:52:11 pm

It might be the go pros audio?

Next time I'll check the One frame every ___ seconds.
Its the go pros sound and picture one frame ahead of the c300 and external sound.


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 3:06:03 pm

The GoPro sound may be the culprit. When you AMA link to the GoPro media, go to Source Settings, Playback TAB and see what it thinks the source might be. In that tab, there is a menu that allows you to select source rate, or project rate. Even if the same, select Project to see if that changes anything.


Michael


Return to posts index


Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 7:46:45 pm

I can't change the frame rate, it won't let me. :(


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 7:52:35 pm

Could it maybe be that the go pro is interlaced and c300 progressive?


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 8:51:28 pm

That could be - using something like MediaInfo on the GoPro clips would give us insight into frame rate, sample rate , codecs, p or i, etc.

https://mediaarea.net/en/MediaInfo


Michael


Return to posts index


Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 8:52:42 pm

Generelt
Fulde navn : /Volumes/Tom 12Tb disk/11/newfiles/newfiles/16_06_11_GoPro_Jørgen_Cangs_de_Onis_Klostret.mxf
Format : MXF
Format_Commercial_IfAny : XDCAM HD422
Formatversion : 1.2
Formatprofil : OP-1a
Formatindstillinger : Closed / Complete
Filstørrelse : 4,34 GiB
Varighed : 11min.
Samlet bitrate : 52,5 Mbps
Kodet den : 0-00-00 00:00:00.000
Skrivende program : FFmpeg OP1a Muxer 57.25.100

Video
ID : 2
Format : MPEG Video
Format_Commercial_IfAny : XDCAM HD422
Formatversion : Version 2
Formatprofil : 4:2:2@High
Formatindstillinger, BVOP : Ja
Formatindstillinger, Matrix : Standard
Formatindstillinger, GOP : M=3, N=10
Format_Settings_PictureStructure : Frame
Format_Settings_Wrapping : Frame
Codec-ID : 0D01030102046001-0401020201040300
Varighed : 11min.
Bitrate : 50,0 Mbps
Bredde : 1.920 billedpunkter
Højde : 1.080 billedpunkter
Størrelsesforhold : 16:9
Billedfrekvens : 25,000 fps
Standard : Component
Farverum : YUV
Chroma subsampling : 4:2:2
Bitdybde : 8 bits
Skantype : Sammenflettet
Skanorden : Bundfelt først
Komprimeringstilstand : Lossy
Bits/(Billedpunkter*Billed) : 0.965
TimeCode_FirstFrame : 00:00:00:00
TimeCode_Source : Group of pictures header
Strømstørrelse : 4,13 GiB (95%)
colour_primaries : BT.709
Overførselskarakteristika : BT.709
Matrix-coefficienter : BT.709

Lyd
ID : 3
Format : PCM
Formatindstillinger, Endianness : Little
Format_Settings_Wrapping : Frame (AES)
Codec-ID : 0D01030102060300
Varighed : 11min.
Bitratemodus : Konstant
Bitrate : 2.304 Kbps
Kanaler : 2 kanaler
Samplingsrate : 48,0 KHz
Billedfrekvens : 25,000 fps (1920 spf)
Bitdybde : 24 bits
Strømstørrelse : 195 MiB (4%)

Andet #1
ID : 1-Material
Type : Time code
Format : MXF TC
TimeCode_FirstFrame : 00:00:00:00
TimeCode_Settings : Material Package
TimeCode_Striped/String : Ja

Andet #2
ID : 1-Source
Type : Time code
Format : MXF TC
TimeCode_FirstFrame : 00:00:00:00
TimeCode_Settings : Source Package
TimeCode_Striped/String : Ja

Andet #3
Type : Time code
Format : SMPTE TC
Muxing-modus : SDTI
TimeCode_FirstFrame : 00:00:00:00


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 8:59:29 pm

and my MXF from c300 if necessary:


Format : MXF
Format_Commercial_IfAny : XDCAM HD422
Formatversion : 1.2
Formatprofil : OP-1a
Formatindstillinger : Closed / Complete
Filstørrelse : 1,90 GiB
Varighed : 5min.
Samlet bitrate : 51,8 Mbps
Kodet den : 2012-08-28 10:06:19.000
Skrivende program : CANON EOS C300 1.00

Video
ID : 2
Format : MPEG Video
Format_Commercial_IfAny : XDCAM HD422
Formatversion : Version 2
Formatprofil : 4:2:2@High
Formatindstillinger, BVOP : Ja
Formatindstillinger, Matrix : Tilpas
Formatindstillinger, GOP : M=3, N=12
Format_Settings_Wrapping : Frame
Codec-ID : 0D01030102046001-0401020201040300
Varighed : 5min.
Bitrate : 50,0 Mbps
Bredde : 1.920 billedpunkter
Højde : 1.080 billedpunkter
Størrelsesforhold : 16:9
Billedfrekvens : 25,000 fps
Standard : Component
Farverum : YUV
Chroma subsampling : 4:2:2
Bitdybde : 8 bits
Skantype : Progressiv
Komprimeringstilstand : Lossy
Bits/(Billedpunkter*Billed) : 0.965
Strømstørrelse : 1,84 GiB (96%)
colour_primaries : BT.709
Overførselskarakteristika : BT.709
Matrix-coefficienter : BT.709

Lyd #1
ID : 3
Format : PCM
Formatindstillinger, Endianness : Little
Format_Settings_Wrapping : Frame (AES)
Codec-ID : 0D01030102060300
Varighed : 5min.
Bitratemodus : Konstant
Bitrate : 768 Kbps
Kanaler : 1 kanal
Samplingsrate : 48,0 KHz
Billedfrekvens : 25,000 fps (1920 spf)
Bitdybde : 16 bits
Strømstørrelse : 28,9 MiB (1%)

Lyd #2
ID : 4
Format : PCM
Formatindstillinger, Endianness : Little
Format_Settings_Wrapping : Frame (AES)
Codec-ID : 0D01030102060300
Varighed : 5min.
Bitratemodus : Konstant
Bitrate : 768 Kbps
Kanaler : 1 kanal
Samplingsrate : 48,0 KHz
Billedfrekvens : 25,000 fps (1920 spf)
Bitdybde : 16 bits
Strømstørrelse : 28,9 MiB (1%)

Andet #1
ID : 1-Material
Type : Time code
Format : MXF TC
TimeCode_FirstFrame : 11:01:43:22
TimeCode_Settings : Material Package
TimeCode_Striped/String : Ja

Andet #2
ID : 1-Source
Type : Time code
Format : MXF TC
TimeCode_FirstFrame : 11:01:43:22
TimeCode_Settings : Source Package
TimeCode_Striped/String : Ja

Andet #3
Type : Time code
Format : SMPTE TC
Muxing-modus : SDTI
TimeCode_FirstFrame : 11:01:43:22


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 9:02:56 pm

That looks like pretty straightforward 25p material at 48kHz. The only other variable is that when recording it is not a locked 25fps@48kHz but once recorded it takes on those parameters. It's also an 11 minute piece which may play into this. Can you see/hear where the sync drifts by 1 frame, then 2, then 2 and what is the duration between those offsets? Is it a continius drift where the longer the clip, the more it is offset by the end?


Michael


Return to posts index


Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 9:05:59 pm

Yes. It starts with 1 frame and the goes on more of less.

Do you know why I can't change the Playback frame rate to project FPS?

And should I change the clips to progressiv with 'Motion Adapters / Timewarps' ?


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 9:17:00 pm

If it's a 24p clip in a 25p project timeline, there is nothing to change, so that may be what your're seeing. If you have a small clip you can share, send it to me at michael[at]24p[dot]com and I'll take a look at it.


Michael


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 9:18:27 pm

Both clips are 25 fps.


Return to posts index


Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 22, 2016 at 9:20:21 pm

All the raw footage is in 25 fps.


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 7:38:55 am

How would you import the files into avid - we're working 4 people on the same project, normally I consolidate and chose 'relink', but should I transcode the files instead? - and then chose set frame rate to project instead?

Its just needs to be possible to have 4-5 discs for grader, editor etc. with the same material.


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 1:41:01 pm

I would try a transcode to see if that eliminates the drifting anomaly you are seeing. But you are looking at more storage when transcoding from a LongGOP source to DNxHD to maintain equivalent quality. At the very least, you are looking at DNxHD 120.

Michael


Return to posts index


Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 1:41:37 pm

Also when transcoding in this scenario, transcode the audio as well.

Michael


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 1:43:52 pm

Hey Michael.

I'm now trying to transcode, and I'm transcoding audio sample rate and bit depth aswell.

I'll let you know. :)


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 3:23:37 pm

I have another question, right now I'm making a sequence, then I auto sequence my main camera, then auto sequence my second camera and makes an in-mark and sync those with the timecode, the same with the external audio.

Why is it that my camera is making 1 frame space in my timeline?



Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 4:27:22 pm

Is that separation between two different files? If you look at the START and END for those two, is the START of the second clip the same as the END of the previous or are they different by 1 frame?

Michael


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 4:42:06 pm

Different by 1 frame. :/


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 5:13:45 pm

So AutoSequence is doing the right thing by ensuring source TC lines up with Record TC in the timeline. If you display both timeline and source TC in the TC display or window, you will see that is true as you scroll through.

If you do not want to match timecode to source, then you need to hold down the option key when selecting AutoSequence, but that is just dropping all clips together in ascending TC order with no in-outs applied (they are cleared).


Michael


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 5:19:10 pm

The option key works. But is there any down side of that?


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 5:28:45 pm

Depends on what you're trying to do.


Michael


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 5:30:17 pm

Just sync two video tracks with audio (two audio tracks each) and five audio tracks in one timeline.


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 5:42:30 pm

If depending on common timecode, then do not use the option key as that lays out the clips based on their source timecode. From there you can slip elements for sync if needed.

If there is no common timecode, then it does not really matter.


Michael


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 5:45:39 pm

There is a generated timecode from the audio to both cameras when filming. Not sure if thats what you mean?


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 5:51:31 pm

Yes, that's what I mean. So there is common timecode for all three elements from the set. You do not want to use the option key then. You want all elements to align to their production (START) timecode. How well each camera holds that sync over the course of the day may cause elements to go out of sync relative to each other - depends on the camera. Usually syncing 2-3 times during the day solves that.

Michael


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 6:21:56 pm

Okay.
So I just need to manually fix the points? But im not sure I understand why it leaves out 1 frame?


Return to posts index

Michael Phillips
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 6:40:47 pm

Because the source clips as recorded are not continuous. The END timecode is MC is always +1, so in order for it be continuous in the recording, the END of the previous clip timecode must be the same as the START of the next one.

Michael


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 6:52:06 pm

Okay. A bit tricky.
I'll just manually adjust the 1 frame difference.
Thank you Michael. Really appreciated!


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 6:27:42 pm

Okay.
So I just need to manually


The timecode is generated all day with a betso timecode, so it should be generating all day. ?


Return to posts index

Phillip Jacob
Re: Avid media composer 8.5 GoPro & C300 sync
on Jun 23, 2016 at 4:54:01 pm

And thats only when I use autosync, when I'm looking at the clips individually its fine.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]