FORUMS: list search recent posts

Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID

COW Forums : Avid Media Composer

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Leire Egana
Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 15, 2015 at 8:29:45 am

Hi everyone,

I shot a film on Canon C300 PL and the DIT cloned the cards instead of copy them, so that I have 4 folders named as sparseimage.
It's the first time I have been delivered this so in order to view their content I have downloaded XF plugin but I am not sure how it works the AMA link with Avid.
I have read that the necessary plug ins to AMA link Canon C300 content are XF64-avid-+XF utility (xpmm-2-0-3-8-9l 2.dmg and xum-1-4-1-2-9l.dmg). So I downloaded them and as I read, my Avid does incorporate the MXF plug in.

I have enabled AMA mounting on settings, I have tried auto detect plug-in and select the precise plug-ing that thought it would work, but the folders are not able to link and I am not sure if the problem is:
- if I still need to download a missing plug in or change any of my settings.
- if there is something I am missing out regarding the sparse image folders (that I need to mount them somehow or so...). Since it's the first time I work with these I may be missing something very basic.

My system is: Mac Yosemite, Avid MC 8.

Thank you very much everyone for reading my post. I really hope someone can help me as I am quite lost here.


Return to posts index

Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 15, 2015 at 12:23:17 pm

These are image files created on OS X and need to be mounted first. They are like virtual drives that grow as they copy to them. They are not the same thing as creating a .dmg file which I think is they wanted to do as I have seen that practice being done on set. a .sparseimage is used by Apple Timemachine and thus has different mounting requirements. Perhaps this link will help:
http://neilstyles.com/auto-mounting-your-timemachine-networked-sparse-bundl...


I would ask that they not create sparseimage files. It is not a common practice. Once you've mounted the image file, you will need to copy contents out to another drive before you can AMA link to them. This is a case of a DIT trying to be too smart in his/her backup practices. They should either do DMG or use one of the many copying applications designed for on-set copy such as ShotPut Pro:
http://www.imagineproducts.com/index.php?main_page=product_info&cPath=1&pro...

RedGiant Offload: http://www.redgiant.com/products/offload/

Or even free with Resolve - these products can do sumcheck and reporting as needed. If they are making this a career or freelance job for themselves they should be aware of these tools. They should also be working to the requirements of post when delivering to them.


Michael


Return to posts index

Leire Egana
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 19, 2015 at 5:56:43 pm

Hi Michael,

Thank you for your suggestion. You are completely right. I think I've fixed the sparse image issue, but I am still having problems to AMA link the footage on Avid.

I have read in some posts that Canon hasn't upgraded plug-ins for MC8 version, is this correct? Any clue about what might be the problem?


Return to posts index


Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 19, 2015 at 6:04:06 pm

HAve you copied the folders from the mounted sparseimage file to another drive first? I am wondering if MC does not see the mounted sparseimage file as a real drive to link to. You can try entering "alldrives 1" into the console to see of that helps.


Michael


Return to posts index

Leire Egana
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 20, 2015 at 3:39:10 pm

I have copied the files into another drive and I have entered what you say in console, but it still says that isn't able to link and I really have no clues other than starting to consider using another method like importing files or using another software.


Return to posts index

Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 20, 2015 at 4:17:57 pm

Folder based formats like Canon/Sony/Panasonic that rely on XML and other sidecar/proxy formats can be frustrating to find the right AMA Plug-in as well as the right level to select (no more than 3 folders up) etc.

I find that installing all Canon AMA plug-ins can something help, and not just the one you think you need. Then I go with the the file AMA (not the folder one) and drill down to the actual clip to make sure I have the right plug-in. Once I know which one, then I switch to the folder based AMA plug-in and work my way back up from the clip folder until I find the level it is happy with in the hierarchy.

Not easy, but once you deciphered proper AMA and folder level, the rest is straightforward.


Michael


Return to posts index


Leire Egana
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 20, 2015 at 4:28:39 pm

Hi Michael, thank you very much for getting back to all my messages.
I really appreciate your suggestion but it's a very unpractical method. Is there any way I can send you one of the folders?

Otherwise, wouldn't it be easier to work with a software that is a bit more straightforward from the beginning. This has already been quite time consuming.


Return to posts index

Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 20, 2015 at 4:30:29 pm

I'll be glad to look at one of the folders. Please zip entire folder contents and send via filemail.com, Wetransfer.com or dropbox to michael[at]24p[dot]com


Michael


Return to posts index

Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 20, 2015 at 7:08:50 pm

Thanks for sending. I guess I should have asked this beforehand, but Canon has never supported 24.000fps with their AMA plug-in, and still do not. I have no idea what the issue might be and why that cannot be offered, but I sent an email off to my contacts there to see if that was going to change. Since camera manufacture the AMA plug-in, it is a Canon issue, and no Media Composer in this case.

I did open the files just fine in Resolve Lite. You can make QT wrapped versions or MXF native from there if you want. That is free, or you can look into EditReady (USD $49.95) http://www.divergentmedia.com/editready

Sorry for all the hassle... 24.000 is the bastard child in Canon AMA world.


Michael



Return to posts index


Per Scaffidi
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 22, 2015 at 8:20:50 pm

By far the easiest method is to open the files in Canon XF Utility, go to edit>Export MXF. This will rewrap the canon files as MXF files which you can drop into your bin (if I remember correctly).


Return to posts index

Leire Egana
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 24, 2015 at 12:45:42 am

Hi, thank you both for the suggestions about the rewrapping. I will try and get back if problem persists.
However, I am starting to think that if there is this issue with having shot on 24p-Avid, it might even be a better idea to edit on Premiere or FC... whatever is easier to avoid problems as I am always concerned about not having any issue either when relinking for the grade and all this is being so complicated that it makes me doubt on wether even rewrapping would be safe...

But as said, thank you Michael for having a look at the material and your help to identify the problem, and thank you Per for joining the thread.

Cheers!


Return to posts index

Per Scaffidi
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on May 24, 2015 at 6:24:18 pm

Canon XF viewer creates a new copy of the files that are rewrapped. Your original files will still exist.


Return to posts index


Leire Egana
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on Jun 1, 2015 at 9:36:31 am

Hi, I have wrapped the files using Canon XF utility creating .MXF files, but I am still unable to AMA link to them on Avid. It doesn't auto detect the plug in but it doesn't either work if I select the MXF plug in. I keep getting this error message:

***Error = 'Exception: FATAL_ERROR, msg:DIDDescriptor: GetAAFProperties could not determine the video format by using DeriveMCDataFromStandardParameters()., file:/Snapshots/relengmtnlion2_1418961066/coresw/ame/src/msm/DIDDescriptor.c, line:2367'.


Any clue?


Return to posts index

Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on Jun 1, 2015 at 12:12:34 pm

I experienced the same issue when using the Canon Utility. The only way I could get it to work was to use Resolve Lite in a dailies type workflow exporting .mov with either DNxHD or ProRes codec or native MXF wrapped DNxHD.

I never heard back from Canon when asking about 24.000 support being added to their AMA plug-in.


Michael


Return to posts index

Leire Egana
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on Jun 1, 2015 at 12:18:45 pm

Hi Michael, glad to hear from you.
Yes, it's very annoying this issue especially since the C300 has been in the market for some time now. How about using Premiere instead? Is this workflow easier?

I also have another question: how does the relink to raw rushes work from Resolve after doing the wrapped MXF? Sorry if this has a very obvious answer and thank you in advance for your help.


Return to posts index


Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on Jun 1, 2015 at 12:29:09 pm

I'll try loading up your test clip in Premiere Pro and see it works. I'm inclined to think it just will. As far as using Resolve, when you load up the sources in the Media Pool, you want to make sure that you set the REEL assignment correctly. This is done in settings on the default tab where it says "assist conform" as you see here in this screenshot:



From there, you create a timeline with all the clips, then go to the deliver page and make sure "individual clips" is selected along with container and codec type from the menu selects.


Michael


Return to posts index

Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on Jun 1, 2015 at 1:36:48 pm

I confirmed that Premiere Pro plays back your test files just fine - so you can either edit there, or create Media Composer compatible files from Adobe Media Encoder rather than using Resolve. I will send you a QT wrapped DNxHD back to via email.

Michael


Return to posts index

Leire Egana
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on Jun 1, 2015 at 3:12:23 pm

Thank you, Michael.
Then if I understand correctly, I won't have to do any converting if I work on Premiere and if I follow the steps on Resolve, the material should link correctly to the raw rushes on the sparse image.

Although I got the license for Avid, I am glad to have found a solution and finally be able to move forward.


Return to posts index


Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on Jun 1, 2015 at 3:15:11 pm

Correct on both points when using Canon at 24.000 fps.

Michael


Return to posts index

Michael Phillips
Re: Workflow Canon C300 SPARSEIMAGE files AMA LINK to AVID
on Jun 27, 2015 at 3:17:35 pm

As an FYI - upon further investigation with Canon on the 24.000 limitation, it is actually an Avid Media Composer issue and not a Canon AMA issue. From Canon:

Avid supports 24.00, but not in Long GOP format which is what the XF-MPEG Codec records in. Not a Canon AMA issue, but a lack of support within AVID for that format.

So there you have it. Getting to the bottom of these issues is always painful in trying to get to the heart of a problem when multiple vendors are involved. :)


Michael


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]