FORUMS: list search recent posts

Can't seem to upgrade to 8.3

COW Forums : Avid Media Composer

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Chris Harlan
Can't seem to upgrade to 8.3
on Jan 3, 2015 at 9:19:49 pm

Am I missing something, or is there something wrong with my account?

I bought the annual license upgrade for my 7.0/Symphony, a month ago, and just tried to upgrade to 8.3 before going back to work on Monday. I can't find any Activation ID in any emails or on my Avid support page. When I try to use my 7.0 Activation code, I get a fail message, telling me to contact an Avid rep, which I've done.

Anybody else have this problem? Am I missing something in particular? Though I can run on the 30 Day trial, I'd prefer to get this solved before Monday, if anyone has advice.


Return to posts index

Daniel Lawrence
Re: Can't seem to upgrade to 8.3
on Jan 3, 2015 at 10:29:10 pm

Hi Chris,

Don't know if this will apply to you but I had a similar problem when I tried to upgrade (round about Dec 19th). Paid, got a confirmation email, but there was no Activation Code in the section for retrieving the download, and the links in the email were not taking me to live pages on the Avid website. I called Avid support and they walked me through the My Products and Subscriptions page, pointing me to a different tab than I was used to looking at. If you take a look at that page, and check the "Media Composer - Standard Support" "tab", which probably will sit below the listing for the most current purchase of Media Composer that you own (in my case, the Standard Support table also says "upgrade from Symphony"), there you should see your perpetual product listed, plus the Standard Yearly Support that you've just paid for. If they haven't confirmed your old license, you may see "On Hold" rather than "Active" next to the words Standard Support… and it might be another day or two before they get to you. Below that should be good links and an activation code that'll get you 8.3. My experience with Avid support was very good, and I was even a temporary activation code… but I had started a claim at the beginning of the week. Given that it's the weekend, I don't know if Avid support will be able to solve the problem for you by Monday. Couldn't hurt to call them, though.

Happy New Year!


Return to posts index

Chris Harlan
Re: Can't seem to upgrade to 8.3
on Jan 4, 2015 at 3:46:40 am

Hey Daniel!

How's it going? Thanks for the reply. It really helps in that, from reading you description, I know there's something slightly wrong with my account. So, I'll calm down and get it worked out next week.

Thanks!


Return to posts index


Daniel Lawrence
Re: Can\'t seem to upgrade to 8.3
on Jan 4, 2015 at 4:23:07 am

Hey Chris!

Life's good on my end. Hope all is well with you too!

Sorry to hear that you're in limbo at the moment, but I have to say that Avid support has always been really good in the few times I've had to deal with them… which might run counter to other folks' experience, I know… but I'm certain that they'll get things resolved for you pretty swiftly. (BTW - I know that they got slammed by hordes of folks wanting to buy before the end of the year, and they have probably too few people literally tasked with verifying our purchases and serial numbers before they validate a "perpetual license" Avid owner as a new yearly subscriber. One of those times when it might have been nice if the process was fully automated, but I s'pose we don't want robots taking over everything just yet...

Cheers,

Dan


Return to posts index

Nick Griffin
Re: Can\'t seem to upgrade to 8.3
on Jan 5, 2015 at 7:43:24 pm

[Daniel Lawrence] "but I s'pose we don't want robots taking over everything just yet..."

No, but websites designed by humans for use by humans is always a big step forward. Avid's site seems to always have been somewhat more difficult to navigate than would be one with more logical navigation. (IMHO.)


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]