FORUMS: list search recent posts

Mac OSX 10.9.2 doesn't work with Avid MC 6.5

COW Forums : Avid Media Composer

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Joel Kotlowitz
Mac OSX 10.9.2 doesn't work with Avid MC 6.5
on Apr 27, 2014 at 3:41:47 am

Hi All -

I recently upgraded to Mac OSX 10.9.2 and now a bunch of my programs won't open; one of them being my some-what recently purchased educational version of Media Composer 6.5 (and After Effects CS6). Is there something I can do to make it work again that won't cost me a ton of money? Thank you.


Return to posts index

Michael Phillips
Re: Mac OSX 10.9.2 doesn't work with Avid MC 6.5
on Apr 27, 2014 at 11:15:40 am

You need to download the most recent version of 6.5.4 from the Download Center.

Michael


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]