FORUMS: list search recent posts

OSX Upgrade and Compatibiity

COW Forums : Avid Media Composer

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Chip Hess
OSX Upgrade and Compatibiity
on Jan 4, 2014 at 7:47:18 pm

Snow Leopard has been my fav OS, but it seems some pro applications are moving beyond.
Not ready to try Mavericks yet, due to lack of Avid support.

Adobe CC requires later than 10.8.6 for some newer versions of their applications.

So writing is on the wall.

What's the feeling here - Lion or Mountain Lion as the better, more stable OS?
I specifically need to run FCP 7, Avid MC 6.5 and latest After Effects.

I'll be keeping a back-up drive loaded with Snow Leopard, just in case!


Return to posts index

Michael Phillips
Re: OSX Upgrade and Compatibiity
on Jan 4, 2014 at 8:31:45 pm

I've been happily working with OS X 10.8.5 with MC 7.0.3 and latest updates to Adobe CC. I have no real rush to move to Mavericks.

Michael


Return to posts index

Oliver Peters
Re: OSX Upgrade and Compatibiity
on Jan 5, 2014 at 12:56:35 am

7.0.3 also supports Mavericks 10.9.0 and 10.9.1.

- Oliver

Oliver Peters Post Production Services, LLC
Orlando, FL
http://www.oliverpeters.com


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]