FORUMS: list search recent posts

Does Avid Media Composer 3 work on Mac 10.7.3 software update?

COW Forums : Avid Media Composer

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Sharif Al-Haj
Does Avid Media Composer 3 work on Mac 10.7.3 software update?
on Apr 30, 2012 at 6:04:03 pm

Hello,

Final Cut pro 6 no longer Prints to Video on the new mac software 10.7.3

I am now trying to work with my Avid Media Composer 3 however it will not even open up. Has the new software 10.7.3 outdated the Avid 3 as well?

All the Best!


Return to posts index

Juan Salvo
Re: Does Avid Media Composer 3 work on Mac 10.7.3 software update?
on Apr 30, 2012 at 11:52:22 pm

The current version of media composer is 6.0.1.1. You're quite a ways back there.

online editor | colorist | VFX | BD author

http://JuanSalvo.com


Return to posts index

Job ter Burg
Re: Does Avid Media Composer 3 work on Mac 10.7.3 software update?
on May 1, 2012 at 11:59:18 am

MC3.5.1 / 3.5.4 are not supported beyond MacOS 10.5.7 and QT 7.5.5/7.6.
MC3.1.x is not supported beyond MacOS 10.5.5 and QT 7.5.5.

If you need to use Avid under 10.7.3, you would need v6. An upgrade to MC6 would set you back 599USD.

There's also a current promo (until June 15th) that lets you crossgrade to Symphony software voor 999USD, which includes BCC8 (a value of at least 495).


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]