FORUMS: list search recent posts

want to purchase vs 5.5 for avid media composer

COW Forums : Avid Media Composer

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
John Neer
want to purchase vs 5.5 for avid media composer
on Apr 15, 2012 at 2:58:30 pm

I want to purchase media composer 5.5. I currently have 4.0 or 4.3..is there an upgrade for this version? Can I purchase 5.5 from an individual that want to sell/transfer their ownership? I just want to avid 6.o for the time being.


Return to posts index

Job ter Burg
Re: want to purchase vs 5.5 for avid media composer
on Apr 15, 2012 at 8:31:30 pm

If you're running a dongle-based system, just upgrade to v6 but install 5.5. The dongle will let you run that.

Also, I think Avid still sells 5.5 as a special item for those still needing 32-bit.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]