FORUMS: list search recent posts

Parts fly off when rotating as group?

COW Forums : Zaxwerks

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Mike Sussman
Parts fly off when rotating as group?
on Sep 16, 2009 at 8:51:38 pm

I've got this weird situation going on and I can't figure out what's causing it. Click here to see the problem and I'll explain in more detail below.

I have a logo Zax-ed in to 3D. It's all one layer but each color (black, gray 1, gray 2, purple, white, gold) is a separate 'object'. (Sorry if the word 'object' is being used incorrectly). I've grouped them all together, including the black outline, and then I can manipulate the group together fine. It starts out with the camera at an angle but the logo is right along the XY axis. In this comp, the camera never moves (it can't for other reasons) so I made a second pose with the grouped 'objects' all rotating to face the camera. All the colors stayed joined together in one combined group at both the initial and the second pose, simple enough. But as you can see in the video clip, all the colors rotated together except for the black, which flew off to the side and then came back to the correct ending point. Huh? I did this exact same process on 17 other logos and they all worked flawlessly. Each color was moved together as one combined group so why/how could just one section decide to take a different path than all the others? I even tried ungrouping them and just rotating each color individually but that same black layer still flies off to the side before landing in the correct end spot. Anybody know what's going on with this one?

Thanks.


Return to posts index

Edward Wu
Re: Parts fly off when rotating as group?
on Sep 16, 2009 at 9:53:00 pm

Hi Mike,

In your animation, try using the grouping controls in the Transition. The Transition Grouping should allow you to make a "Hard Group". The Hard Group will lock all the positions together, and should help hold your logo pieces all together.

As for the logo moving apart, if you were animating the logo using the Tweak controls, then I would recommend using the Pose Positioning tools for the animation.

If you are still running into issues with this animation, you can try sending the ProAnimator scene to me at ed@zaxwerks.com
I'll take a look at your setup and help you out with the issue.

Best,
Edward




Return to posts index

Mike Sussman
Re: Parts fly off when rotating as group?
on Sep 17, 2009 at 2:42:52 pm

Thanks. I tried making a group from the transition and not the pose but that didn't solve it. I just sent you the file so you can see what I've got.


Return to posts index


Edward Wu
Re: Parts fly off when rotating as group?
on Sep 17, 2009 at 5:00:20 pm

Hi Mike,

I took a look at your project and fixed the animation using the "Make Hard Group" command from the "Transition Grouping" drop down menu. Make sure to select the "Hard Group" instead of just the "Group" because the Hard Group will keep all objects in the same position. I re-saved the fixed project and sent it back to you. Please check your e-mail.

Best,
Edward


Return to posts index

Mike Sussman
Re: Parts fly off when rotating as group?
on Sep 17, 2009 at 10:11:45 pm

Thank you so much for your help.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]