FORUMS: list search recent posts

Jagged Edges

COW Forums : Zaxwerks

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Mike Sussman
Jagged Edges
on May 15, 2009 at 3:11:25 pm

I've made a very simple 3D animation in Zaxwerks ProAnimator from very simple elements imported from an Illistrator file. I then exported the 3D animation as a Quicktime movie +alpha which I then imported into an Adobe After Effects project.

The edges look smooth in Zax but I get jagged edges from my exported movie. Here's a screen gab from my AE program (captured while moving).



My render settings are more than adequate (up to Animation on high) and I've also fiddled around with Object Facet settings (which didn't seem related anyway). These jagged edges appear to me to be scanline related, but the odd thing is that you can see the slight shifting along the straight but not perfectly vertical left edges of the N and the U. Those shifts are caused by the pixel aspect ratio correction so if you ignore that, you see that those angled edges are otherwise perfectly smooth with no jagged edges. So why smooth there and not smooth in other slots?

Any ideas on what I can do or try to get these edges nice and smooth?


Return to posts index

Edward Wu
Re: Jagged Edges
on May 15, 2009 at 6:17:45 pm

Hi Mike,

it sounds like you're exporting the movie from ProAnimator as a standalone. Here are the settings you can check to make sure you have smooth edges in your graphics.

Make sure that you have AntiAlias set at 3x3 or above. If you do not have AntiAlias set, then you will have jagged edges around your objects. In addition, the Object Faceting settings also play a part in your rendering. The Draft Object Faceting setting determines how your objects look inside the preview window. The Draft Object Faceting setting should be set to "3" most of the time so that while your objects may look "rough" in the preview window, the program will perform faster as well. The Final/Best Object Faceting value determines the object smoothness when you render out your scene. The lower the value, the smoother the edges are. You can set the Final/Best Object Faceting to a value of "0.5" or "0.1". This will make the edges smooth for your objects when you are performing the render.

Also, make sure that you have the same project settings for both projects. They should have the same dimensions as well as the same pixel aspect ratios.

Hope this helps.

Best,
Edward


Return to posts index

Mike Sussman
Re: Jagged Edges
on May 15, 2009 at 6:57:55 pm

Thank you. It sounds like I've been on the right track but unfortunately those are the settings I had already tweaked that resulted in the screen grab shown above. :-(

I am indeed exporting this as a stand alone movie before importing into AE for final usage. Both Zax project and AE comp are set to NTSC DV 720x480 0.9par. I've tried up to 5x5 antialiasing but I haven't tried those antiflicker settings because mine wasn't flickering. I also did try adjusting the object facet setting for the best/final. The default was at 1 and I tried 0.5. Like you said, I could go as low as 0.1, but the problem seemed to me to be connected to horizontal scan lines and not the number of polygon segments, as the circle does seem like a near perfect circle to me (even if a jaggedy circle).

I can still try 0.1 on final facet and 5x5 +AA but I'm also wondering if I could possibly avoid the problem of a poor alpha channel rendering if I just avoided rendering an alpha channel all together. I may (overnight) try applying my Zax project directly to an AE layer and then render entirely within After Effects. Otherwise, I'm still looking for any other suggestions if I'm missing something.

Thanks.


Return to posts index



cowcowcowcowcow
Edward Wu
Re: Jagged Edges
on May 15, 2009 at 7:39:19 pm

Hi Mike,

Good assessment. You're right. I had forgotten that with Quicktime 7.6, movies that are rendered out are interpreted with "Separating (Lower)" when brought into After Effects. Therefore, in After Effects, select the footage, then go to File > Interpret Footage > Separate Fields > Off.

Hopefully this helps. Thanks for providing the detailed information.

Best,
Edward


Return to posts index

Mike Sussman
Re: Jagged Edges
on May 18, 2009 at 1:20:37 pm

That "File > Interpret Footage > Separate Fields > Off" solution worked perfectly. Thank you, thank you, thank you! Thanks to everybody for your assistance. :-)


Return to posts index

Edward Wu
Re: Jagged Edges
on May 18, 2009 at 11:59:38 pm

Hi Mike,

Good to hear that it's worked out for you.

You're welcome and thanks for the update!

Best,
Edward


Return to posts index


Matt Rhodes
Re: Jagged Edges
on May 16, 2009 at 9:02:58 pm

Hi Mike.

You may be finding that After Effects is showing the jaggies, but it's really just field separation and may look fine in your final output.

Would you be able to send me your PA project? And possibly your AE project?
I'd be happy to take a look.

Also, what's the final destination for these movies? DVD?

Send files to: matt@zaxwerks.com

Matt Rhodes
Zaxwerks, Inc.



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]