FORUMS: list search recent posts

Corrupt Quicktime file recorded by a Ki Pro. Rescue suggestions?

COW Forums : AJA Video Systems

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Michael Glass
Corrupt Quicktime file recorded by a Ki Pro. Rescue suggestions?
on Nov 5, 2009 at 11:18:27 am

We just recorded about 150 minutes of video using a KiPro. This is actually one of four Ki Pro's recording four different cameras simultaneously.

At the end of the show, three of the drives contained 40ish GB files that play perfectly. The fourth drive produced two files -- one 30GB and one 6GB. The 30GB file appears to be corrupt. Neither Quicktime, nor VLC, nor MPEG Streamclip nor any of our other tools can open the file. Only VLC's log seems to show some useful information (see end of the post).

We've also tried to open the file in HexEdit to compare headers with a successfully Ki-recorded file but are struggling to get HexEdit to even deal with the file.

Has anyone ever run into a similar glitch? Any suggestions on rescuing this file?

Thanks!

VLC - fail log:::::::::::

main debug: adding item `Clip2TK25.MOV' ( /Volumes/TED Talks - Cheng/TED India /Clip2TK25.MOV )
main debug: rebuilding array of current - root Playlist
main debug: rebuild done - 1 items, index -1
main debug: processing request item Clip2TK25.MOV node Playlist skip 0
main debug: resyncing on Clip2TK25.MOV
main debug: Clip2TK25.MOV is at 0
main debug: starting new item
main debug: creating new input thread
main debug: Creating an input for 'Clip2TK25.MOV'
main debug: thread (input) created at priority 22 (input/input.c:230)
main debug: thread started
main debug: using timeshift granularity of 50 MBytes
main debug: using timeshift path '/tmp'
main debug: `/Volumes/TED Talks - Cheng/TED India /Clip2TK25.MOV' gives access `' demux `' path `/Volumes/TED Talks - Cheng/TED India /Clip2TK25.MOV'
main debug: creating demux: access='' demux='' path='/Volumes/TED Talks - Cheng/TED India /Clip2TK25.MOV'
main debug: looking for access_demux module: 4 candidates
macosx debug: input has changed, refreshing interface
main debug: Creating an input for 'Clip2TK25.MOV'
main debug: TIMER module_need() : 16.142 ms - Total 16.142 ms / 1 intvls (Avg 16.142 ms)
main debug: creating access '' path='/Volumes/TED Talks - Cheng/TED India /Clip2TK25.MOV'
main debug: looking for access module: 8 candidates
vcd debug: trying .cue file: /Volumes/TED Talks - Cheng/TED India /Clip2TK25.cue
vcd debug: could not find .cue file
access_file debug: opening file `/Volumes/TED Talks - Cheng/TED India /Clip2TK25.MOV'
main debug: using access module "access_file"
main debug: TIMER module_need() : 97.825 ms - Total 97.825 ms / 1 intvls (Avg 97.825 ms)
main debug: Using AStream*Stream
main debug: pre buffering
main debug: received first data after 0 ms
main debug: pre-buffering done 1024 bytes in 0s - 50000 kbytes/s
main debug: looking for stream_filter module: 4 candidates
main debug: TIMER module_need() : 0.073 ms - Total 0.073 ms / 1 intvls (Avg 0.073 ms)
main debug: looking for stream_filter module: 1 candidate
main debug: using stream_filter module "stream_filter_record"
main debug: TIMER module_need() : 0.055 ms - Total 0.055 ms / 1 intvls (Avg 0.055 ms)
main debug: creating demux: access='' demux='' path='/Volumes/TED Talks - Cheng/TED India /Clip2TK25.MOV'
main debug: looking for demux module: 50 candidates
mp4 debug: found Box: ftyp size 32
mp4 debug: found an empty box (null size)
mp4 debug: dumping root Box "root"
mp4 debug: | + ftyp size 32
mp4 debug: unrecognized major file specification (qt ).
mp4 error: MP4 plugin discarded (no moov box)
avformat debug: detected format: mov,mp4,m4a,3gp,3g2,mj2
avformat error: av_open_input_stream failed
lua debug: Trying Lua scripts in /Users/computerexchange/Library/Preferences/VLC/lua/playlist
lua debug: Trying Lua scripts in /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/anevia_streams.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/appletrailers.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/bbc_co_uk.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/break.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/canalplus.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/cue.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/dailymotion.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/france2.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/googlevideo.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/joox.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/koreus.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/lelombrik.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/megavideo.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/metacafe.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/mpora.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/vimeo.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/youtube.lua
lua debug: Trying Lua playlist script /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/lua/playlist/youtube_homepage.lua
lua debug: Trying Lua scripts in /Volumes/vlc-1.0.3/VLC.app/Contents/MacOS/share/share/lua/playlist
vobsub debug: this doesn't seem to be a vobsub file
ps warning: this does not look like an MPEG PS stream, continuing anyway
main debug: no fetch required for (null) (art currently (null))
main debug: using demux module "ps"
main debug: TIMER module_need() : 16.670 ms - Total 16.670 ms / 1 intvls (Avg 16.670 ms)
main debug: looking for a subtitle file in /Volumes/TED Talks - Cheng/TED India /
main debug: `/Volumes/TED Talks - Cheng/TED India /Clip2TK25.MOV' successfully opened
ps warning: garbage at input, trying to resync...
main debug: control type=1
main debug: control type=1
main debug: adding item `Clip2TK25.MOV' ( stream:///Volumes/TED%20Talks%20-%20Cheng/TED%20India%20/Clip2TK25.MOV )
main debug: incoming request - stopping current input
main debug: dying input
main debug: control type=0
main debug: control: stopping input
main debug: removing module "ps"
main debug: removing module "stream_filter_record"
main debug: dying input
main debug: removing module "access_file"
main debug: thread ended
main debug: dead input
main debug: processing request item Clip2TK25.MOV node Playlist skip 0
main debug: rebuilding array of current - root Playlist
main debug: rebuild done - 2 items, index 1
main debug: starting new item
main debug: creating new input thread
main debug: Creating an input for 'Clip2TK25.MOV'
main debug: thread (input) created at priority 22 (input/input.c:230)
main debug: thread started
main debug: using timeshift granularity of 50 MBytes
main debug: using timeshift path '/tmp'
main debug: `stream:///Volumes/TED%20Talks%20-%20Cheng/TED%20India%20/Clip2TK25.MOV' gives access `stream' demux `' path `/Volumes/TED%20Talks%20-%20Cheng/TED%20India%20/Clip2TK25.MOV'
main debug: creating demux: access='stream' demux='' path='/Volumes/TED%20Talks%20-%20Cheng/TED%20India%20/Clip2TK25.MOV'
main debug: looking for access_demux module: 0 candidates
main debug: no access_demux module matched "stream"
main debug: TIMER module_need() : 0.069 ms - Total 0.069 ms / 1 intvls (Avg 0.069 ms)
main debug: creating access 'stream' path='/Volumes/TED%20Talks%20-%20Cheng/TED%20India%20/Clip2TK25.MOV'
main debug: looking for access module: 1 candidate
access_file debug: opening file `/Volumes/TED%20Talks%20-%20Cheng/TED%20India%20/Clip2TK25.MOV'
access_file error: cannot open file /Volumes/TED%20Talks%20-%20Cheng/TED%20India%20/Clip2TK25.MOV (No such file or directory)
main warning: no access module matching "stream" could be loaded
main debug: TIMER module_need() : 4.317 ms - Total 4.317 ms / 1 intvls (Avg 4.317 ms)
main error: open of `stream:///Volumes/TED%20Talks%20-%20Cheng/TED%20India%20/Clip2TK25.MOV' failed: (null)
main debug: finished input
main debug: thread ended
main debug: dead input
main debug: TIMER input launching for 'Clip2TK25.MOV' : 8.012 ms - Total 8.012 ms / 1 intvls (Avg 8.012 ms)
main debug: changing item without a request (current 1/2)
main debug: nothing to play
macosx debug: input has stopped, refreshing interface
main debug: TIMER input launching for 'Clip2TK25.MOV' : 134.253 ms - Total 134.253 ms / 1 intvls (Avg 134.253 ms)


Return to posts index

gary adcock
Re: Corrupt Quicktime file recorded by a Ki Pro. Rescue suggestions?
on Nov 5, 2009 at 2:01:24 pm

Michael-I just heard about something like this - are you based or working out of the DC/ baltimore area?


[Michael Glass] "The fourth drive produced two files -- one 30GB and one 6GB. The 30GB file appears to be corrupt. Neither Quicktime, nor VLC, nor MPEG Streamclip nor any of our other tools can open the file. "


Yes the QT files can get corrupted, I have only seen this happen when the Drive Module is partially removed during a recording or the drive is removed from the KiPro unit without first un-mounting (by using the SLOT button) the drive module while the unit is powered up.


I am under the impression that this is no way to "fix" a corrupted ProRes file.


gary adcock
Studio37
HD & Film Consultation
Post and Production Workflows for the Digitally Inclined
Chicago, IL


http://library.creativecow.net/articles/adcock_gary/AJAIOHD.php




Return to posts index

Jeremy Garchow
Re: Corrupt Quicktime file recorded by a Ki Pro. Rescue suggestions?
on Nov 5, 2009 at 6:10:16 pm

That's a tough one, Michael. I have no idea if this works but:

http://aeroquartet.com/movierepair/repair.html

Jeremy


Return to posts index


Michael Glass
Re: Corrupt Quicktime file recorded by a Ki Pro. Rescue suggestions?
on Nov 5, 2009 at 7:11:19 pm

Actually, just caught wind of that from a friend elsewhere and gave it a spin. Treasured found a bunch of available frames and said the file can be rescued. It uploaded a sample and they'll confirm in a few hours if they can actually repair it.
So, promising news. Will post whatever I discover.
Thanks for the replies!
Michael


Return to posts index

Michael Glass
Succcess!
on Nov 6, 2009 at 4:30:48 pm

Remarkably, the Treasured/AeroQuartet application managed to recover 98% of the video. The audio was lost but we have 12 other tracks of sync audio so on the whole I'd say they were remarkably successful.

Please pass on the word if you happen upon anyone else who needs to try to recover data from a corrupt quicktime file. The diagnostic app was free and quite informative as to what was happening during the process.



Return to posts index

Jeremy Garchow
Re: Succcess!
on Nov 6, 2009 at 5:15:24 pm

Good to know that it at least partially worked! Thanks for posting back.

Jeremy


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]