FORUMS: list search recent posts

FCP to AE to FCP ;-)

COW Forums : AJA Video Systems

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Bill Nelson
FCP to AE to FCP ;-)
on Jan 28, 2009 at 8:32:40 am

Hi everyone,

just got my new Kona LHe Card and did some tests with it. So far everything works fine but I got a couple of questions regarding the way from Final Cut Pro to After Effects and back to Final Cut:

1) I captured some footage from Digibeta in FCP in 10 Bit uncompressed. I exported for AE with the actual settings. Imported in AE and I got a gamma shift. I have to check the "Match quicktime legacy..." option in the project settings to get the same gamma as in FCP...why?

2) Then I render my footage again in AE using the AJAv210 codec. Back in FCP the footage looks worse compared to the original clip in FCP because it's blurry. I've tested all other codecs but get the same blurry picture (or gamma shifts using Animation Codec or 8-Bit Codecs). What am I doing wrong?





Return to posts index

walter biscardi
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 1:11:01 pm

This is a long documented RGB to YUV shift.

Walter Biscardi, Jr.
Biscardi Creative Media
HD and SD Production for Broadcast and Independent Productions.

Read my Blog!

STOP STARING AND START GRADING WITH APPLE COLOR Apple Color Training DVD available now!


Return to posts index

Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 1:19:39 pm

Hi Walter,

yeah I know (somehow).

Point 2 is more important to me...

Thanks!



Return to posts index


walter biscardi
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 1:25:59 pm

[Bill Nelson] "Point 2 is more important to me... "

there's no reason for your footage to come back blurry so long as you are working in exactly the same type of comp as the original footage and you render back to the exact same type of footage from AE.

No reason to use any codec other than the original.

The Gamma shift we just deal with quite simply with filtering.



Walter Biscardi, Jr.
Biscardi Creative Media
HD and SD Production for Broadcast and Independent Productions.

Read my Blog!

STOP STARING AND START GRADING WITH APPLE COLOR Apple Color Training DVD available now!


Return to posts index

Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 1:30:28 pm

Ok - I will try again...using different footage and keeping 10-Bit codec all the way.

The Gamma shift we just deal with quite simply with filtering.

Sorry - what do you mean?



Return to posts index

walter biscardi
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 1:35:03 pm

[Bill Nelson] "The Gamma shift we just deal with quite simply with filtering.

Sorry - what do you mean?"


You either apply a filter in AE or FCP to compensate for the shift.


Walter Biscardi, Jr.
Biscardi Creative Media
HD and SD Production for Broadcast and Independent Productions.

Read my Blog!

STOP STARING AND START GRADING WITH APPLE COLOR Apple Color Training DVD available now!


Return to posts index


Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 1:38:55 pm

Yes. That's what I used to do before the Kona Card. I applied Levels effect in AE with a correction to the gamma but didn't find this very handy in use. So I'm glad now that I can go from FCP to AE and back to FCP without any gamma shift.

Do you filter the gamma shift all the time?



Return to posts index

walter biscardi
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 1:50:10 pm

[Bill Nelson] "Do you filter the gamma shift all the time?"

nope.



Walter Biscardi, Jr.
Biscardi Creative Media
HD and SD Production for Broadcast and Independent Productions.

Read my Blog!

STOP STARING AND START GRADING WITH APPLE COLOR Apple Color Training DVD available now!


Return to posts index

Greg Booth
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 2:54:14 pm

Hi Bill,

Maybe you've already checked this but one thing to make sure is that the 'Field Render' in the Render Settings matches the Field Type of your footage. I've seen blurry renders of interlaced footage because the 'Field Render' was set to 'Off' when it should have been 'Upper Field First'.

Cheers,
Greg



Return to posts index


Jeremy Garchow
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 3:32:41 pm

Okay, if you don't need to use the v210 codec, I suggest the following:

Quit all open video programs.

Go to your Hard Drive > Library > Quicktime folder and move the AJAUNcompressedcodec.component to your desktop.

Launch AE. TUrn off all color management and uncheck the 'Use Legacy QT ...".

Render.

This should result in a near perfect match accept if you have any out of range clips, they will get clamped to to the RGB being 16-235 only. If you have legacy clips in the v210 codec, this can also cause problems as the codec is now deactivated.

Jeremy


Return to posts index

Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:04:22 pm

Launch AE. TUrn off all color management and uncheck the 'Use Legacy QT ...".

When I do so I get the gamma shift on my screen and on the waveform monitor.



Return to posts index

Jeremy Garchow
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:16:34 pm

I'm sorry, what version of AE are you using and what kind of computer?

Did you remove the codec I told you about BEFORE launching After Effects?


Return to posts index


Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:18:04 pm

I closed AE and FCP, removed the codec and started the apps again. Do I have to restart the Mac?

I'm using AE CS4 on a quad core mac with OS 10.5.6



Return to posts index

Jeremy Garchow
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:20:50 pm

[Bill Nelson] "I closed AE and FCP, removed the codec and started the apps again. Do I have to restart the Mac?"

No, but you have done this correctly.


[Bill Nelson] "I'm using AE CS4 on a quad core mac with OS 10.5.6"

Perfect.

Okay, so NOW you should start AE, turn off the use legacy and color management, and render. Your footage should now match your source.

Jeremy


Return to posts index

Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:24:25 pm

Perfect.

Okay, so NOW you should start AE, turn off the use legacy and color management, and render. Your footage should now match your source.

Jeremy


The render works fine. No gamma shift. But within the AE application I see the gamma shift when I DON'T check the "legacy" option.



Return to posts index


Jeremy Garchow
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:26:23 pm

[Bill Nelson] "The render works fine. No gamma shift. But within the AE application I see the gamma shift when I DON'T check the "legacy" option. "

I fail to see the problem? **EDIT Sorry that last one sounded weird. What you are seeing is correct. When you uncheck the legacy option, the gamma is no longer shifted with AJA codec out of the Library.


Return to posts index

Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:33:33 pm

Jeremy - sorry for my bad english. Maybe it's confusing you. So again:

When I import my Footage to AE and compare the clip to the same footage in FCP, I SEE a gamma shift on my waveform monitor. Means - my clip in FCP is darker than the clip in AE. The funny thing is; when I render my clip in AE and import it into FCP - the gamma is correct.

But when I turn ON the legacy-option the preview in AE works also correct. Means - I can't see a difference in gamma on my waveform comparing FCP and AE.

Do you get me?

I just would like to know why I still have to check the legacy-option to put out a correct signal over the AJA card.



Return to posts index

Jeremy Garchow
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:53:43 pm

[Bill Nelson] "Do you get me? "

So no matter what, your renders are now coming out gamma shift free, but in oder to get the proper preview out of AE, you need to enable the use legacy gamma?

Try capturing a new clip as a test with this current setup and see if that's still true.

In cs4, for me, it makes no difference if I check the use legacy or not, there's no shift.

If you can, would you care to upload a few frames of your video so we can see the same thing?

Jeremy




Return to posts index


Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 5:01:43 pm

So no matter what, your renders are now coming out gamma shift free, but in oder to get the proper preview out of AE, you need to enable the use legacy gamma?

Correct!

Try capturing a new clip as a test with this current setup and see if that's still true.


Yes. :(

If you can, would you care to upload a few frames of your video so we can see the same thing?

http://www.megaupload.com/?d=3BCIQJ4H

Although I think that you won't see a problem with this file, because it seems to be more a problem with my AE or Quicktime. I don't know! :(



Return to posts index

Jeremy Garchow
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 6:18:39 pm

I see what you're seeing. Maybe it has to do with PAL vs NTSC or more likely HD vs SD. All my tests have been with HD material and there's no reason for the gamma shift selection. Do you have any HD to try this out with? I'd be curious to see. Also, I'd test a ProRes capture vs a 10bit PAL capture. It might be codec and resolution dependent.

Jeremy


Return to posts index

Matt Larson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 6:22:27 pm

[Bill Nelson] "So no matter what, your renders are now coming out gamma shift free, but in oder to get the proper preview out of AE, you need to enable the use legacy gamma?"

In the AJA control panel tab "codec" look at the YUV>RGB Conversion Gamma tab. Is it set to auto? I might have this wrong, but I think the Kona will set gamma dependent on frame size, but AE doesn't necessarily do that. So, AE may be sending 601 to the Kona, but the Kona sees the frame size and sets it to 709. Anyway, try switching that out of Auto and see if that helps.




2 x3Ghz Quad MacPro
9 GB RAM
Mac OS X 10.5.5
QT 7.5.5
FCP 6.0.5
AJA Kona 3 (6.0.1 drivers)
G-Speed XL 12 RAID


Return to posts index

Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 29, 2009 at 8:24:58 am

Hooray! Found the solution! Thank you!!!

To test my problem I created a normal DV-PAL Composition and added a 50% grey solid. My waveform displayed me a solid line at about 60% - the gamma shift.

Then I changed to the AJA Control Panel and left ColorSpace untouched set to "Auto". I changed Gamma to Linear (1.8) and bang! - my line just sits perfectly on 50%.

Now I only have to learn about Gamma stuff again, because I don't understand in detail why I have to select 1.8. I always thought of video with a gamma of 2,2.

Thank you guys!



Return to posts index

walter biscardi
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 3:47:13 pm

[Greg Booth] " I've seen blurry renders of interlaced footage because the 'Field Render' was set to 'Off' when it should have been 'Upper Field First'. "

OR lower field depending on what you're doing and the format you're delivering to.

AE always defaults to Off for field render.



Walter Biscardi, Jr.
Biscardi Creative Media
HD and SD Production for Broadcast and Independent Productions.

Read my Blog!

STOP STARING AND START GRADING WITH APPLE COLOR Apple Color Training DVD available now!


Return to posts index

Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 3:49:52 pm

Alright...coming from DigiBeta with upper field first that could be the reason...thank you guys.

I'm gonna test it soon.

Jeremy: Am I right that all AJA 8 Bit and 10 Bit Codecs are legacy codecs that I should avoid?



Return to posts index

cowcowcowcowcow
Jeremy Garchow
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:13:02 pm

[Bill Nelson] "Jeremy: Am I right that all AJA 8 Bit and 10 Bit Codecs are legacy codecs that I should avoid?"

They are legacy codecs, yes. They served a purpose before Apple changed their Uncompressed codecs to fit HD specs. It's up to you. I don't use v210 and I remove it from my QT library to get rid of the gamma shifts from AE. Seems to work a treat. I don't know if this is an AE or AJA problem, I just know it works.

Also, concerning your fields, if you didn't render the proper field order, you can set the field order in FCP and it should look better. For instance, that No fields movie you rendered, change the 'Field Dom' in FCP to Upper and the blurriness should go away. Now, that motion might not match as you render a progressive movie, essentially, but it will at least get rid of the blurriness. For a proper interlaced render, you should render Upper FIeld first for PAL SD.

Jeremy


Return to posts index

Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:16:36 pm

Hm, removed the codec but still get the shift.



Return to posts index

Bill Nelson
Re: FCP to AE to FCP ;-)
on Jan 28, 2009 at 4:01:34 pm

Cool. That tip solved my problem. Forgot to take care of the fields...

Thank you!



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]