FORUMS: list search recent posts

Kona/FCP/Xsan Issues

COW Forums : AJA Video Systems

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Tucker Dansie
Kona/FCP/Xsan Issues
on Apr 5, 2008 at 7:35:36 am

I am not sure where to post this message so I'm writing this here, if it should be elsewhere, please tell me. I have a strange problem with our new studio setup.

We have 2 Mac Pro's, each connected by Fiber to the Xsan and each uses an AJA Kona LHe card. They each have been working fine for the past 6-8 months, but we have not been using the Kona's until the last month. We did Firewire before that as we waited for a Video Routing System to be put in place. This system is in place and houses 2 Sony HDV decks, 1 HDcam deck and 1 Multiformat Digibeta Deck. Once the routing was in place we were able to use each of the Mac Pro's for a few weeks with no problems, capturing from each of the 4 decks.

In those first few weeks I was working with a new editor and so we worked on 1 Mac Pro with this editors log in and we never logged him off during that project. It all worked flawlessly, but when the project was finished I logged in with my Log In to capture and I was able to get machine control and audio, but the picture was just a grey box. The AJA control panel was/is set correctly, although it seems to reset every time I reboot back to analog. We are routing everything through SDI with embedded audio.

Now, if I get the grey screen and then I switch the capture settings to "AJA to DV" (from "AJA to ProRes) the picture will come on for a fraction of a second and then "skip-loop" on that frame, so it just keeps repeating a few frames over and over, like a stuck record needle for video. The timecode is going on though, as is the audio, just a lock-up on the video frame. I tried this on a few other users log in's and got the same issues. But, if we log in under the editor which I talked about eariler, it works fine.

Now, the OTHER Mac Pro is logged in under a single user this whole time (it is his personal machine vs. the other which is a shared public one) and it "broke" on that same day, giving him the grey screen. One day later, after we reset EVERYTHING (the router, the Xsan, the machines clean reboot) and his is working again. But, the shared Mac Pro is STILL not working with the captures.

Our video engineers came and verified that their video routing and cabling is fine, it seems to be the connect to the AJA Kona card. Usually, I can just close the capture window or choosing "Refresh AV Device" and it all starts working again. But, the captures will only work under these user ID's. Also, just to mention, the SDI output on the Kona is driving our broadcast monitors at each station and they work no matter what. If I open an old project then I can play it back through the Kona to monitor.

I have had other weird Finder inconsistencies when working with the Xsan files as well. For instance, today I tried renaming a quicktime and, although I could get the blue box and the cursor, my keyboard would not work. I couldn't type anything, nor could I delete the words with backspace when dealing with the files ON the Xsan. Locally renaming a file worked fine.

The big problem is that nothing seems to have changed. We HAD used the video router to capture for a few weeks. The video router worked with my login just fine, but suddenly stop working and I can't put my finger on why that would be.

We are a very small (4 video guys across 3 Final Cut Pro's and 2 Vegas Systems) self-contained group and so we ARE our own tech support. We do have support on the Video Router from our Vidoe Engineers, but they only support the rack and the cables up to the machine, once it meets the cards and/or breakout boxes, it is our problem. We have an Xsan/Network guy who supports 5 different Xsan's and a Unity Server, so he is very busy and when we need him it takes a few days to get him in (hopefully this is getting remedied). He should be coming in on Monday, but I am not sure that he will understand hte Final Cut Pro/Kona integration. He mostly supports the Avid's/Unity in our department and we are the only ones using this setup, so he may not be able to help much. Because of this, I would like to be able to try my own solutions before he comes and then give him some more technical ideas.

I am sorry with all the questions, it seems like I am slowly turning into the tech support guy! If you have any wild thoughts that I could look at, I'd so appreciate it. I'm happy to provide you with more details as needed as well.

One last thing, for the record, we have 2 Vegas Systems that we are "phasing out" and they both work flawlessly with the Routing System. I also work mostly off my Mac Book Pro and I am able to edit and work on the Xsan (over ethernet) just fine.

Alright, sorry for the long description. I hope you are having/have had a good weekend and I thank you EXTRA for looking at my issue during your weekend!

thanks
-TD



Return to posts index

gary adcock
Re: Kona/FCP/Xsan Issues
on Apr 5, 2008 at 12:46:19 pm

Ok

really hard to determine what to look at since there are no hardware and software specs - for your systems.

Grey screens- usually mean no drivers

Try dropping one of the Prorez or DV files into AJA TV (in the applications > aja utilities folder) and see if they play out. ( this app will over ride all settings in FCP and output video via the card)

if it works inside of AJA TV- it is a FCP setup problem, not a kona issue.

gary adcock
Studio37
HD & Film Consultation
Post and Production Workflows
Inside look at the IoHD




Return to posts index

Tucker Dansie
Re: Kona/FCP/Xsan Issues
on Apr 6, 2008 at 7:32:46 am

Sorry for forgetting to list specs. I am not by those machines until Monday, so I'll list what I can remember and if there is something more you need I'll grab that on Monday.
The two Mac's match perfectly, including software updates, since we always update them together:

2.8ghz Quad-core Mac Pro (2 of them)
-2gbs of RAM each
-AJA Kona LHe card
-AJA FCP driver v5.1
-Mac OS v10.4.11
-Final Cut Studio 2 v6.0.2
Is there anything else you want that might help?

As for the drivers, when we installed the routing system and connected the Kona cards to it, we upgrade the drivers to the newest listed on the site (5.1). Then, it was working fine for several weeks like that. When we were troubleshooting this week, we reinstalled the drivers again and it didn't help.

But, remember that the grey screens are only on the capture and only with certain users, everything works fine if you are logged in as one particular user. I'm pretty sure that the Kona drivers are machine wide, not user wide? Right? I mean, you couldn't have a different driver loaded depending on the used. Either way, I did reinstall the drivers under my login and rebooted and it didn't help.

As far as the AJA TV thing, I will try that, but my bet is that it will be fine. All users can open media in FCP and we CAN playback (in viewer or timeline) THROUGH the Kona card to the SDI monitor. We only get the grey screen when trying to capture.

The video signal is coming through, becasue if I am in capture and seeing the grey screen, I can playback the tape (timecode is running and audio is coming in) and then switch the capture settings to something else (it doesn't matter what I switch to, but for instance going from 525 DV to 525 ProRes) and suddenly I see the video come through for a moment and then a second later it "loops up". The video keeps playing and the audio is heard but the picture that it is capturing becomes this quick little 5 frame loop.

I'm just totally confused as to why things would be different based on the USER! I guess this means I don't have to do any work since it won't work under my login...I just feel bad for the one guy in the office that it does work for, he's gonna be busy!!!




Return to posts index


Matt Riley
Re: Kona/FCP/Xsan Issues
on Apr 7, 2008 at 1:09:38 am

[Tucker Dansie] "I'm just totally confused as to why things would be different based on the USER! "

This sounds like a permissions/ownership problem.

Xsan - and any other shared workgroup environment - depends on users and groups to determine file ownership. If User A captures video files to the Xsan then User A, by default, is the owner of those captured files. Unless User B is granted permission via some method (explicitly redefined or by being part of the same group, etc.) then User B will have no access to the files User A captured. Try putting your users into a new group and give that group full R/W access to your capture scratches on the Xsan volume(s). This would hopefully rule out most or all of any permissions problems you might have.

As for the file renaming problem, I suspect you had illegal characters in your file name. A trip to the command line of the Xsan metadata controller would've probably allowed you to rename the file in-place.

-Matt



Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]