FORUMS: list search recent posts

Very slow directory fetching in both OSX 10.8 and 10.9 with unRAID NAS

COW Forums : NAS - Network Attached Storage

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Eddie Adams
Very slow directory fetching in both OSX 10.8 and 10.9 with unRAID NAS
on Sep 8, 2014 at 8:33:40 pm

Current setup: 24 iMacs on Cat6 running into a GS728TXS Netgear smart switch. Switch is patched into the chassis via SFP+. Chassis is a 24-bay with 3TB WD Green drives running Limewire unRAID. One single Mac Pro has a direct Fibre line to the switch as well. All computers experience the same issues, which is:

Upon first connecting to the NAS, there is a 20-30 sec delay while the Finder window fetches the listing of Shares. From here, there is typically a 10-30 sec delay in loading EVERY directory as we move further into the shares and away from the root. Sometimes when we leave a Finder window open and idle for a few mins, the directory will display a 20-30 delay next time we click into that directory.

Also, I've noticed that if we attempt to search within a folder using Spotlight, it will never search any sub-directory within the current search folder. We also use a program called VisualDiffer to compare directory contents between local and NAS folders. The program will often list a folder as empty on the NAS, but when going into the directory, there are most certainly files inside it. Doing another compare will then show the contents of the directory.

Additionally, if Finder is trying to fetch info from any of the NAS shares and is experiencing the 10-30 delay I'm referring to, ALL local folders will also exhibit identical delays in fetching directory info, despite being local. It's as if the NAS slows down the Finders fetching process across the board.

From what I understand WD Greens are terrible NAS drives due to their desire to spin down after 8 seconds of inactivity. Within the unRAID setup, we've told the OS to never spin down discs, but that did not seem to have any affect on load times. Unfortunately this is what we have to work with and replacing the HDD is likely not an option at this point.

Any ideas of what the slow down could be caused from, or any suggestions for a fix? Thanks.


Return to posts index

Bob Zelin
Re: Very slow directory fetching in both OSX 10.8 and 10.9 with unRAID NAS
on Sep 8, 2014 at 10:10:21 pm

you have 24 iMacs. You have 24 employees running these iMacs.
And you bought Green drives to save money ?
What RAID host adaptor are you using ?
What 10G card is hooked up to the 728 switch ?

bob Zelin

Bob Zelin
Rescue 1, Inc.
bobzelin@icloud.com


Return to posts index

Eddie Adams
Re: Very slow directory fetching in both OSX 10.8 and 10.9 with unRAID NAS
on Sep 8, 2014 at 10:18:16 pm

This is the current build:

* unRAID 5.0
* Case: NORCO RPC-4224 4U Rackmount Server Case (24 x 3TB HDDs, 69TB of usable storage with one dedicated 3TB parity drive)
* MB: SUPERMICRO MBD-X9SCM-F-O LGA 1155 Intel C204 Micro ATX Intel Xeon E3 Server Motherboard
* CPU: Intel Core i3-2120 Sandy Bridge 3.3GHz LGA 1155 65W Dual-Core Desktop Processor
* Power: CORSAIR TX650 650W ATX12V/EPS12V 80 PLUS BRONZE Active PFC High Performance Power Supply
* Controllers: 3x SUPERMICRO AOC-SASLP-MV8 PCI-Express x4 Low Profile SAS RAID Controller
* Memory: 2x Kingston ValueRAM 4GB 240-Pin DDR3 SDRAM ECC Unbuffered DDR3 1333
* Intel X520-DA2 Dual Ports 10 Gigabit Ethernet Converged Network Adapter, PCI Express 2.0 x8, Low Profile w/ Intel E10GSFPSR Ethernet SFP+ SR Optics transceiver

This is not my build, I inherited this system so working with what I got to try and make the best of it.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]