FORUMS: list search recent posts

BMPCC not powering up after 1.9.3 update

COW Forums : Blackmagic Cinema Camera

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Andrew Rendell
BMPCC not powering up after 1.9.3 update
on Aug 26, 2014 at 2:34:35 pm

I upgraded the firmware this morning - downloaded the latest Camera Utility, plugged BMPCC in by USB, it immediately said that it needs to update, so I clicked ok and let it happen.

So now what happens is I press the power button on the camera and it flashes on very briefly and turns itself off immediately. SD in or out, on battery power, on power adapter with battery in place, on power adapter & no battery, doesn't make a difference. The flash of display is far too short to read anything before it's off again.

Is there anything I can do or is it broken?


Return to posts index

Andrew Rendell
Re: BMPCC not powering up after 1.9.3 update
on Aug 26, 2014 at 6:45:04 pm
Last Edited By Andrew Rendell on Aug 26, 2014 at 6:47:37 pm

Worked it out... I guess there's been a slight change to the operating because a quick press of the on button then leaving it alone and the camera comes on after a couple of seconds. So holding the power on button down as I had been doing takes it through turning on and into turning off before you see that it's turning on...

Sorry to bother anyone who was scratching their head, but maybe this'll help anyone who has the same issue.


Return to posts index

David_Kuznicki
Re: BMPCC not powering up after 1.9.3 update
on Aug 27, 2014 at 1:34:38 pm

Same problem here, however, you're lucky. Mine will not power up at all.

Blackmagic support isn't responding to my emails, either.

Production Manager, WGTE-TV30
Weekend Director (News), WUPW


Return to posts index


Andrew Rendell
Re: BMPCC not powering up after 1.9.3 update
on Aug 27, 2014 at 7:45:38 pm
Last Edited By Andrew Rendell on Aug 27, 2014 at 7:54:05 pm

Sorry to hear that David. I found the forum here - http://forum.blackmagicdesign.com/viewforum.php?f=1
but it wouldn't accept my registration. Maybe they're overwhelmed at the moment. I might try again in a couple of days.
I notice there are a couple of BM groups on LinkedIn, but I haven't looked into them (the tedious Avid versus FCP arguing has rather put me off a couple of LinkedIn groups tbh, but it might be worth a look), although the 'Cow is still my first go-to.


Return to posts index

John Fishback
Re: BMPCC not powering up after 1.9.3 update
on Sep 1, 2014 at 7:53:40 pm

My BMPCC has done the same since 1.9.2. Never tried the short press and wait. I always held the button until just the first hit of flash and often it started up ok. Sometimes I'd have to try a couple of times. I'll try the single push and wait tomorrow. Thanks for the hint.


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]