FORUMS: list search recent posts

JVC GY-HM100u clip corrupt - how to recover?

COW Forums : JVC cameras/decks

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Scott Palmer
JVC GY-HM100u clip corrupt - how to recover?
on Sep 29, 2010 at 8:33:41 pm

Hello all. Long time reader, first time poster. I think I have some corrupt footage, and I need help recovering it. Anyone have experience with this...?

I've been shooting on a JVC HM-100 for a month or two now; about 20 hours of footage in the can. All shot 1080x1920, 30p in .MOV format (not .MP4). Until now, on a Mac Pro with FCP installed, all of the .MOV files could easily be viewed in Quicktime Player, and could be dragged into FCP and were editable right away without rendering, etc. My workflow has been to 1) shoot on the SD card, 2) dump the entire contents of the SD card to a hard drive, DCIM and PRIVATE folders/file structure and all. Once the dump is complete, 3) I review the footage using QT player, and edit in FCP. I also use Compressor to create lo-fi .mp4 clips of all of my shots for sharing with others, laptop logging, etc.

Today was the first time I've encountered this: I shot about 30 minutes of footage, among five different clips. One of the clips isn't playable after transfer from the SD card. My first clue that something was wrong was when the MacOS/Finder created image thumbnails for four of the clips, but left the fifth one with the little default QT icon. The file still transferred with the filename, .mov extension, and the full file size (1.82 GB), but Quicktime won't play it. The QT error message says that the file "could not be opened. The movie is not in a format that QuickTime Player understands." I've tried to create a lo-fi version in Compressor, and compressor will not even accept the clip in the batch window, even though it will accept the other adjacent clips from the same card. I also attempted to drag the file into FCP, and receive the error message "File Error: Unknown file".

Here's what's strange: The entire clip plays back on the camera. It is a "part two" clip, meaning that the clip is the second half of another earlier clip that had reached it's maximum file size (a weakness of the whole solid-state SDHC recording media technology that I really hate, but that's another post). But I also had another two-part clip on the same card, and both of those transferred just fine. It's just this one that isn't readable by the computer, even though it still plays in the camera.

I used the copy feature in the camera to copy the contents of card A to card b, and then imported card b hoping that would help - same result.

Here's one other fact that may be relevant: at the conclusion of shooting this particular clip, I turned off the camera, changed batteries, and fired up again. I may or may not have "closed" the file before I turned off the camera. (the HM100 will let you stop/start recording multiple times and compile all of those shots into one clip/scene. The scene isn't "closed" until you push *and hold* the record button to stop recording.) I just did a test shot where I recorded, stopped, intentionally didn't close the file, and powered down and removed the battery. That clip still imported and played fine; apparently the JVC "closes" any open file before powering down.

So there's my saga. I guess I have two questions. 1) how can I recover this footage? and 2) What's your best theory on why this happened?

I hate to think that this camera might just drop entire sections of my footage at random. That's a HUGE deal. Imagine an event photographer whose HM100u decides to drop the wedding vows...

Thanks in advance!!

-Scott,
Houston, TX


Return to posts index

Scott Palmer
Re: JVC GY-HM100u clip corrupt - how to recover?
on Sep 30, 2010 at 3:10:47 am

Update: I did some more sleuthing, and I think I'm a victim of the 4GB file size limitation that I'm just now learning about. Seems that the HM100u didn't correctly split a long continuous shots into multiple files.

For the benefit of others who stumble here with the same issue, here are the details.

Recall that the clip in question is part two of a very long shot. Put simply, it's kinda like one long shot that the camera broke up into parts and stored as multiple clips for more manageable file sizes. When I review today's footage in the camera, i only have three "scenes" to choose from. The first two scenes, being very long continuous shots, are broken up into subparts. So I have a total of five .mov files that can be described as 1a, 1b, 2a, 2b, and 3. It's file 1b that is misbehaving - the second half of my first long shot.

I reviewed .mov file 1a on my computer in Quicktime. The file size was 3.71 GB, it's 13 minutes and 54 seconds long, and ends on a camera zoom. I reviewed scene 1 again in the camera, and it plays the whole thing just fine - scene 1 lasts an additional 7 or 8 minutes beyond that camera zoom. That 7 or 8 minutes is the second half of scene one, so it's the second .mov file that the camera created after the first half of shot/scene 1 reached it's maximum file size. That's the .mov file that I describe in my original post as "corrupt". It's the one that won't play.

So it looks like I have a situation where the camera split a shot into two clips, and failed to package up the second half in such a way that QT/FCP/Compressor/etc. knows what to do with it. It's still there, I can watch it in the camera, I just can't use it anywhere else.

Anyone have any additional suggestions?

Thanks,

-Scott


Return to posts index

Charles Wannop
Re: JVC GY-HM100u clip corrupt - how to recover?
on Nov 4, 2010 at 10:47:40 am

I had some problems when I formatted the card in my Mac before loading into the camera - really spooky, but the fix was to either NEVER format in my Mac OR when the camera wants to re-format it , re-format it twice! As far as recovering the clip - I was able to sneak up on it with MPEG-Streamclip, I only lost a few seconds around the corrupt point in the file.
I also had "un-finalised" clip issues when I swapped cards too quickly - resulted in an unrecognised QT clip (as you have experienced) but the fix was just to put the card back into the camera - it recognised that the clip was un-finalised and prompted to fix it - which it did just fine. Have you tried using a USB link to the camera instead of reading the clip externally?


Charles.


Return to posts index


Mat Sunderland
Re: JVC GY-HM100u clip corrupt - how to recover?
on May 28, 2011 at 7:25:20 pm

Hi Scott,

Using FCP7 and the JVC GY-HM700E I have had the same problem. Did you get anywhere. I was recording a VERY long speech and had to remove the 1 card to change to another during the show. The slot had switched before I removed the original card but out of the 4 records 1 had the same problem as you have.

Oddly though it was neither the first or last clip created but the second. Did you have any joy rebuilding the file as this is a problem for me as this is the only record of the event.

Mat Sunderland
UK


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]