FORUMS: list search recent posts

Pro JVC power problem

COW Forums : JVC cameras/decks

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
Andre
Pro JVC power problem
on Apr 22, 2005 at 3:10:09 am

Hi to all.
I've recently acquired a JVC GY-DV500 and powered it on once. I tried to
power it up a day later to find that it is dead to both battery power and
external DC.
The manual states that a dead LI-ION backup battery can prevent the unit
from powering on but I am wondering if anyone here has had any experience
with these units and may be able to shed some light.
I've found that it has absolutely no response at all as if it were disconnected from all power.
One interesting discovery was that of a reset button hidden in the uppermost right-hand corner of the backup battery compartment. I don't know what it's purpose is but I would like to know what its purpose is.
Thanks for all your help in advance.


Return to posts index

Perry Rubin
Re: Pro JVC power problem
on Apr 22, 2005 at 1:25:18 pm

I had this problem with my DV500 as well. No power at all, I had to send back to JVC for repair (a total nightmare, a few hundred dollars and 4 months later it was fixed). They first tried fixing the I.C. protectors. It would test fine on the bench, but when received back would fail. After sending back 3 times they replaced something listed as the REG PWB ASSY. Seems to work fine now. I sent my unit to a repair center in New Jersey. If you send it there, call the service center and ask for the the Service Manager, Gene...he's the one that finally got me up and running.

Good Luck to you,
Perry


Return to posts index

<< PREVIOUS   •   VIEW ALL   •   PRINT   •   NEXT >>
© 2017 CreativeCOW.net All Rights Reserved
[TOP]